•   
  • 1
  • 23
  • 24
  • 25(current)
  • 26
  • 27
  • 168
  •   
  Thread Closed
OpenELEC Testbuilds for RaspberryPi (Kodi 16.0)
No crash with video playing in a looping playlist with Milhouse's guisettings.xml. Any config.txt settings?
I'm currently running with everything removed (except codec keys and gpu_mem).
/flash/config.txt
/flash/cmdline.txt
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
http://pastebin.com/ggJH5CH6 config.txt
http://pastebin.com/jzDCppWv cmdline.txt


I have still no freeze with deinterlaced disabled.
Ok got a freeze soon after i have enabled deinterlacer to auto.
Debug log:
http://pastebin.com/aXgMxGd8

Chreshlog:
http://pastebin.com/LhnUGd6m

First the gui has freezed and after few minutes the kodi has restarted and there is a debug and chrashlog.
Still no crash here with Milhouse's config.txt and guisettings.xml. I am running my own debug build which may change things.

@Milhouse, does disabling deinterlace also avoid the issue for you? Is "Bob" good or bad?

I'm suspecting a firmware issue (although that is not certain, but kodi failing to work after a restart, but without a reboot suggests that).

One question is does reverting firmware (start.elf/fixup.dat) a few versions avoid the issue?
(2015-07-26, 01:18)michidg Wrote: Have been watching dvd today some hours and had no problems in fullscreen mode.
But i left fullscreen one time and was navigating through the kodi menu and the same happend again, but with a dvd that was NOT one of these 10% that were not working before.
Here is the log, but its not a debug log. Could not reproduce it again with debug log,
because the cpu load is too high with dvd in background and menu navigate. There happen other problems with debug log active, terrible video / audio sync, but not the stopping video.

log
at 00:08:14 i left the fullscreen mode.Then video hang and audio playing like the problem before 5sec, cache, 5sec... After stopping the dvd it even crashed completly.
Seems to be again something with receiving the buffers.

This was also a gui freeze. Didin't try it last week, but today and you can still ssh to it.

I use your test firmware from last week and used 0722 and now 0730 and get this freezes also.
But completly random. Could not reproduce something. happens with bob and mmal advanced.
Will try other settings later.

But mostly it happens, when you open one of these 10% problem dvds ( fullscreen never a problem with test firmware )
and go to systeminfo and let it run some seconds or minutes in the background.
When the image stops wait a minute, stop the dvd playback and in 90% of the cases it freezes. Sometimes it stops correctly.
if you take again the file from last week. ( you need the test firmware )
use mmal advanced and Sync playback to display ( pll ). ( problem occurs also with bob and and without Sync playback to display, but not so often )

https://dl.dropboxusercontent.com/u/8884...S_01_4.VOB

Start it, go to systeminfo ( video playing in background ), video will always stop after about 1,5 minutes ( but not the same second exactly )

Then stop after video hang. GUI will freeze, but not everytime.

I think this are two problems. The dvd problem provokes the gui freeze, but not always.

But i don't know if it is the same gui freeze, that is caused at the other people.


Edit: With bob it sometimes only stutters shortly, sometimes video stops.
With deinterlace disabled. no stutter, no hang.
for me, freezes while watching live tv are gone
(2015-07-31, 19:07)popcornmix Wrote: Still no crash here with Milhouse's config.txt and guisettings.xml. I am running my own debug build which may change things.

@Milhouse, does disabling deinterlace also avoid the issue for you? Is "Bob" good or bad?

I'm suspecting a firmware issue (although that is not certain, but kodi failing to work after a restart, but without a reboot suggests that).

With #0730, and "bad" guisettings.xml in a "clean" .kodi, I dont' get a frreeze with either deinterlace "Off" or On/MMAL-Bob" - MTV-Dance1.ts played 5 or 6times.

However as I enabled deinteralce On/MMAL-Advanced, I experienced a freeze soon after.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2015-07-31, 21:32)Milhouse Wrote: With #0730, and "bad" guisettings.xml in a "clean" .kodi, I dont' get a frreeze with either deinterlace "Off" or On/MMAL-Bob" - MTV-Dance1.ts played 5 or 6times.

However as I enabled deinteralce On/MMAL-Advanced, I experienced a freeze soon after.

Any difference with overclock disabled?
(2015-07-31, 21:48)popcornmix Wrote: Any difference with overclock disabled?

Good call. Without overclocking, 10 plays and no freezes with MMAL-Advanced:

Code:
gpu_mem=320
disable_overscan=1
hdmi_pixel_encoding=2
decode_MPG2=0xf9b2627b,0x302327ff
decode_WVC1=0x2e08e90f,0xf191ab33

Hmmm.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2015-07-31, 22:24)Milhouse Wrote: Good call. Without overclocking, 10 plays and no freezes with MMAL-Advanced:

Are you using an official Pi power supply?
(2015-07-31, 22:35)popcornmix Wrote: Are you using an official Pi power supply?

I'm not (as I've got more Pi's than spare electrical sockets!) but to test the theory I switched the Pi2 to a white RPi Foundation PSU, re-enabled the overclocks and playback froze during the 4th play.

Debug log: http://sprunge.us/bFXK (4th play starts at 608.164734)
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
New OpenELEC Jarvis build #0731: RPi / RPi2
(Supercedes previous build)

Code:
# uname -a
Linux rpi512 4.1.3 #1 Fri Jul 31 21:40:23 BST 2015 armv6l GNU/Linux

# vcgencmd version
Jul 30 2015 17:56:23
Copyright (c) 2012 Broadcom
version 065d51651eeaced58522f5591150b64cacdc00f8 (clean) (release)

# lsb_release
OpenELEC (Milhouse) - Version: devel-20150731213934-#0731-g2fa61b7 [Build #0731]

# vcdbg log msg 2>&1 | grep DTOK
001557.589: Kernel trailer DTOK property says yes

# Kernel device tree status: Enabled

Based on tip of OpenELEC master (2fa61b78, changelog) and tip of XBMC master (7137081a, changelog) with the following modifications: Build Highlights:
  1. MMAL updates
  2. Revert eventlircd disable, as some buttons not currently working (known issue)
Build Details:
  1. OpenELEC:
    • kodi: add ALT+F4 keymapping (9564fcc6)
    • eventlircd: disable Hama/Ortek remote support. TODO: testing and remove completly (25a51dad)
    • sqlite: update to sqlite-autoconf-3081101 (dfb65936)
    • xf86-video-nvidia: update to xf86-video-nvidia-352.30 (2fa61b78)
  2. XBMC:
    • fix trac 16159 Yes (single) / Separate is doing reverse (PR:7649, 1 commit, 1 file changed)
    • [AudioDSP] Fix audio offset dialog slider popup has no label (PR:7569, 1 commit, 1 file changed)
    • Change 'mytv' remote mapping to open the TV Shows node (PR:7669, 1 commit, 1 file changed)
    • [guilib] label2 colors need to be updated as well (PR:7673, 1 commit, 1 file changed)
    • [dsp] Fix CID#1312065 Uninitialized scalar variable. (PR:7674, 1 commit, 1 file changed)
  3. pvr.dvblink:
    • fix ubuntu packaging: disable LTO (PR:23, 2 commits, 2 files changed)
  4. newclock4:
    • New commits in this build:
      • squash: mmal: increase queue limit to 1 second to avoid stalls (fce21009)
      • [mmalcodec] Prefer to return pictures when render queue is low (5c761493)
      • Revert "[mmalcodec] Prefer to return pictures when render queue is low" (e9af0da3)
      • [mmalcodec] Tidy up debug logging for decode (658a2e0d)
      • dvdplayer: drop work-around for very fast ff, obsolete after flushing render buffers correctly after seek (a68fe098)
  5. Additional commits/pull requests/changes not yet merged upstream:
    • Reverted: 25a51dad: Not yet ready for prime time
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
During the night rpi was not showing any output on tv even if it was not playing anything.
This is chrash log if it say something:
http://pastebin.com/FcfjN6CH



About power supply. I have one from linksys and is very good actualy the best i have seen so far so there is no problem with power supply.
Since disabling interlacer i have not seen any gui freezes but have seen the picture freeze at one frame and it stops. Then I can press stop and play again and it plays fine again.
Will try to catch debug of this event.

P.S.:
Should new build be considered as next test build for all those kodi freeze video testing?
  •   
  • 1
  • 23
  • 24
  • 25(current)
  • 26
  • 27
  • 168
  •   
  Thread Closed
 
Thread Rating:
  • 10 Vote(s) - 5 Average



Logout Mark Read Team Forum Stats Members Help
OpenELEC Testbuilds for RaspberryPi (Kodi 16.0)510