•   
  • 1
  • 35
  • 36
  • 37(current)
  • 38
  • 39
  • 168
  •   
  Thread Closed
OpenELEC Testbuilds for RaspberryPi (Kodi 16.0)
#0808 build seems to fix EPG.
Yep, 0808 seems to have brought the guide back. Thanks, wife was flipping out over it.
Experience: It's what you get when you were expecting something else.
(2015-08-09, 09:03)afremont Wrote: Yep, 0808 seems to have brought the guide back. Thanks, wife was flipping out over it.
You use test builds on your wife? Braver than me!
If I have helped you or increased your knowledge, click the 'thumbs up' button to give thanks :) (People with less than 20 posts won't see the "thumbs up" button.)
(2015-08-09, 08:19)illiac4 Wrote: #0808 build seems to fix EPG.

I also confirm that #0808 also fixes ArgusTv epg refresh issues. Thanks for fix. SmileSmile
Location UK; Media server Windows 7 with ArgusTV 2.3 with TBS6981 DVB-S2 x4 and DVB-T x 2:All network connections cabled on 1Gb router Raspberry Pi2 1GB x 2; RPI 3 x1; PiB+512MB x 3; TV Samsung 55" C8000; AV Denon AVR X2200W
(2015-08-09, 07:19)doveman2 Wrote: What's even more confusing is that neither Confluence or AppTV show a menu entry for LiveTV and I can't see anything in the settings for either skin to enable one (although I'm sure there used to be such a setting).

Settings > TV > Enabled - is this option enabled?

If so, then if you don't get any replies here you might be better off asking in the TVHeadend subforum.

Determining the build when this last worked might also be helpful.

(2015-08-09, 07:19)doveman2 Wrote: EDIT2: It seems the default keymapping has my power button shutdown Kodi, which isn't ideal as it just looks like it's frozen! Maybe have it display the power menu would be better?

06:30:20 1438.410278 T:1966985216 DEBUG: LIRC: Update - NEW at 1430582:e2 0 KEY_MEDIA_UP devinput (KEY_MEDIA_UP)
06:30:23 1441.148804 T:1966985216 DEBUG: LIRC: Update - NEW at 1433320:74 0 KEY_POWER devinput (KEY_POWER)
06:30:23 1441.149048 T:1966985216 DEBUG: OnKey: rewind (0xc4) pressed, action is ShutDown()

Is this a recent change? There's ongoing work trying to fix some MCE remote control issues (hence the delay to OE6.0 release) and some buttons have been re-mapped in the last few builds. Changing the "Shutdown function" in Settings > System > Power Saving to "Suspend" should avoid shutting down your Pi (it will switch off the display instead).
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
New to this but eager to try out new OE as I have a CEC problem, but having difficulty getting these builds working.

Started from a working build of full Kodi 15.0 with OE 5.95.3 going on my RPi2, then dropped #808 tar file into the update folder. On restart it seemed to load, but version details still show 15.0 etc., and despite the tar file vanishing from the update folder every time I reboot it goes through the initial setting entry (system name, SSH/Samba enabled etc.). What am I getting wrong?
(2015-08-09, 14:16)Milhouse Wrote: Is this a recent change? There's ongoing work trying to fix some MCE remote control issues (hence the delay to OE6.0 release) and some buttons have been re-mapped in the last few builds. Changing the "Shutdown function" in Settings > System > Power Saving to "Suspend" should avoid shutting down your Pi (it will switch off the display instead).
Maybe you missed it, it could help here, have a look here
http://forum.kodi.tv/showthread.php?tid=...pid2072656
Config, audio player only:
2T HDD <USB> RPi2/Kodi <HDMI> Denon AVR-2313 <HDMI> LG TV 55UF860V
Do you see it extracting the tar on the first reboot after copying over the tar - any errors? How much free space do you have in your second partition - are you out of free space? What version does "lsb_release" return in ssh (after the upgrade)? Are you "booting from NFS" or some other boot method that disables the automated update?
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2015-08-09, 17:20)Milhouse Wrote: Do you see it extracting the tar on the first reboot after copying over the tar - any errors? How much free space do you have in your second partition - are you out of free space? What version does "lsb_release" return in ssh (after the upgrade)? Are you "booting from NFS" or some other boot method that disables the automated update?
Millhouse I presume this is a reply to me (another post interceeded), thanks for being so quick. Currently reformatting the SD card and trying again from scratch (Kodi 15.0 build etc.) because SSH stopped working. But will answer best I can.

1) Do you see it extracting the tar on the first reboot after copying over the tar - any errors?
A column of text ran on startup, I presumed that was extraction, but too small and fast for me to read so no idea about errors. Can I capture this somehow if it happens again?

2) How much free space do you have in your second partition - are you out of free space?
Loads, 8MB card so should be OK I hope

3) Are you "booting from NFS" or some other boot method that disables the automated update?
Boot from SD card.

Will check lsb_release when up and going again.
(2015-08-09, 17:32)DaveBlake Wrote: Millhouse I presume this is a reply to me

Yes. Smile

(2015-08-09, 17:32)DaveBlake Wrote: A column of text ran on startup, I presumed that was extraction, but too small and fast for me to read so no idea about errors. Can I capture this somehow if it happens again?

The only way to capture it is to take a photograph or video.

If the upgrade succeeds it will usually take 30-40 seconds to complete, showing progress messages (only about 8 lines) along the way, it will also confirm at the beginning that the extraction is taking place. If the upgrade fails it should show a message and reboot after 30 seconds. It should be very obvious whether the upgrade is being attempted or not.

A column of text sounds like a regular (non-upgrade) boot when you don't have "quiet" added to the end of your line in cmdline.txt.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2015-08-09, 17:04)DaveBlake Wrote: New to this but eager to try out new OE as I have a CEC problem, but having difficulty getting these builds working.
...

(2015-08-09, 17:32)DaveBlake Wrote:
(2015-08-09, 17:20)Milhouse Wrote: Do you see it extracting the tar on the first reboot after copying over the tar - any errors? How much free space do you have in your second partition - are you out of free space? What version does "lsb_release" return in ssh (after the upgrade)? Are you "booting from NFS" or some other boot method that disables the automated update?
Millhouse I presume this is a reply to me (another post interceeded), thanks for being so quick. Currently reformatting the SD card and trying again from scratch (Kodi 15.0 build etc.) because SSH stopped working. But will answer best I can....

My fault!! Blush It seems that I messed up the original card burn - accidentally removed the storage partition name. I now have #808 running. Thanks for you attention.

As far as my CEC problem goes it seems even worse than Isengard, which at least gives a PulseCode 8 adapter TV connected message even if the TV does not see Kodi as a CEC enabled device. Where can I best give this CEC issue feedback?? Do you know who is looking at the CEC problems that are delaying the 6.0 OpenELEC release?

Edit: Not wanting to clutter this thread with yet another post so adding here. Thanks Millhouse. Yes I may have mentioned my CEC isue in several places, but there was a detailed posting in this thread. I also added the post that you found in OE forum. So hard to know where best to discuss things!
(2015-08-09, 08:18)Heiko123 Wrote:
(2015-08-08, 15:47)Heiko123 Wrote: We are talking about the first ploint, it get dry.

And I will install 802 and tested overnight.

So I tested with it, but the same results.
The epg ended today 21:00 (last scan yesterday)
And the records task wont be updated,
Normally if I goto recordings I see the "working..." event for short time, but now never.

I'll testing the actually version.

Ok, the following result i have.
The recordings are refresh
But
The epg data wont be refresh ( I use serverWMC)
(2015-08-09, 17:56)DaveBlake Wrote: As far as my CEC problem goes it seems even worse than Isengard, which at least gives a PulseCode 8 adapter TV connected message even if the TV does not see Kodi as a CEC enabled device. Where can I best give this CEC issue feedback??

All I've seen is you posting in various places that you have a CEC problem without providing any detail or even describing what the problem is.

I suggest that you start a new thread where you can describe the CEC problem in detail and also provide debug logs (wiki) and whatever other information anyone willing to help you investigate the problem may require. A dedicated thread may make discussion easier to follow, assuming this unknown CEC problem takes some time to solve.

And since these test builds contain the very latest libcec commits I'd recommend that you continue to test these builds while trying to solve your problem.

(2015-08-09, 17:56)DaveBlake Wrote: Do you know who is looking at the CEC problems that are delaying the 6.0 OpenELEC release?

As far as I'm aware, there are no CEC problems delaying the OE 6.0 release - the problems delaying OE6.0 relate to MCE-type remote controls (eg. Ortek/Hama VRC-1100 etc.).

Edit: Ah, I see you started this thread since I last visited the OE forum... Smile
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
New OpenELEC Jarvis build #0809: RPi / RPi2
(Supercedes previous build)

Code:
# uname -a
Linux rpi512 4.1.4 #1 Sun Aug 9 21:04:04 BST 2015 armv6l GNU/Linux

# vcgencmd version
Aug  3 2015 14:56:05
Copyright (c) 2012 Broadcom
version 4b51d81eb0068a875b336f4cc2c468cbdd06d0c5 (clean) (release)

# lsb_release
OpenELEC (Milhouse) - Version: devel-20150809210314-#0809-ge3f7ec9 [Build #0809]

# vcdbg log msg 2>&1 | grep DTOK
001571.125: Kernel trailer DTOK property says yes

# Kernel device tree status: Enabled

Based on tip of OpenELEC master (e3f7ec97, changelog) and tip of XBMC master (f0b65843, changelog) with the following modifications: Build Highlights:
  1. Various PVR/EPG fixes
  2. [rbp] Add ntsc version of 48Hz mode
Build Details:
  1. OpenELEC:
    • wetek/dvb: reduce debug log spam (PR:4268, 1 commit, 1 file changed)
    • projects/imx6/patches/linux: add udoo dual device tree (PR:4269, 1 commit, 3 files changed)
    • u-boot: switch to SPL for udoo boards (PR:4271, 1 commit, 8 files changed)
  2. XBMC:
    • [gui] fix confirm state not reset in CGUIDialogSelect (PR:7748, 1 commit, 1 file changed)
    • [epg] Sync epg update from client / db on startup (PR:7367, 1 commit, 3 files changed)
    • [PVR] Fix PVR_TIMER_STATE_NEW usage (PR:7763, 2 commits, 4 files changed)
    • [pvr] CPVRChannel::SetEpgId() should flag the record as changed (PR:7762, 1 commit, 1 file changed)
    • [pvr.dvbviewer] Change back to SHA or it will continue to fail (PR:7765, 1 commit, 1 file changed)
    • fix Window.IsMedia infobool (PR:7761, 1 commit, 1 file changed)
    • [keyboard] support coding input method for chinese (PR:5326, 1 commit, 18 files changed)
    • [PVR] Fix timer type compat code. Solves a crash with MediaPortal addon. (PR:7764, 1 commit, 1 file changed)
  3. pvr.hts:
    • Predictive tuning fixes (PR:82, 5 commits, 6 files changed)
  4. newclock4:
    • New commits in this build:
      • [rbp] Add ntsc version of 48Hz mode (d117bf90)
    • Commits no longer in build:
      • changed: For memory file cache there's no point creating a bigger cache than filesize (5456cabf)
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2015-08-03, 18:20)MrNice Wrote: I use a RPi1 with a USB Flirc (it simulates a keyboard) and the AVR remote.
Until #0714 I could shutdown RPi by pressing a button simulating Ctrl-End.
From #0715b when I press the button, Rpi freeze but ssh still works, I can reboot from it.
Reboot and shutdown from the menu with mouse or remote works fine.

Could you confirm this bug?

(2015-08-09, 07:19)doveman2 Wrote: EDIT2: It seems the default keymapping has my power button shutdown Kodi, which isn't ideal as it just looks like it's frozen! Maybe have it display the power menu would be better?

06:30:20 1438.410278 T:1966985216 DEBUG: LIRC: Update - NEW at 1430582:e2 0 KEY_MEDIA_UP devinput (KEY_MEDIA_UP)
06:30:23 1441.148804 T:1966985216 DEBUG: LIRC: Update - NEW at 1433320:74 0 KEY_POWER devinput (KEY_POWER)
06:30:23 1441.149048 T:1966985216 DEBUG: OnKey: rewind (0xc4) pressed, action is ShutDown()

@MrNice/@doveman2: Apologies both, for some reason I misinterpreted your posts and thought the problem was that Kodi is now going straight to shutdown instead of offering you an option from the power menu. I hadn't taken on board that Kodi is in fact locking up when the power button is pressed (and only when the shutdown function is "Shutdown", as Suspend works fine). Also "Power off" from the Power menu is working normally.

I can reproduce this with the latest build (once I set my shutdown function to Shutdown), and there's a trac ticket for this issue (trac #16146) so hopefully there will be a fix soon - it's most likely one of the ApplicationMessenger commits introduced in build #0715b.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
  •   
  • 1
  • 35
  • 36
  • 37(current)
  • 38
  • 39
  • 168
  •   
  Thread Closed
 
Thread Rating:
  • 10 Vote(s) - 5 Average



Logout Mark Read Team Forum Stats Members Help
OpenELEC Testbuilds for RaspberryPi (Kodi 16.0)510