Thread Closed
OpenELEC Testbuilds for RaspberryPi (Kodi 16.0)
(2015-08-27, 15:42)popcornmix Wrote:
(2015-08-27, 13:04)afremont Wrote: It's not a show stopper since full screen is fine, just trying to help you perfect it. Smile

I have added a patch that tries to detect these cases and discard every other frames when framerate is 50 or 60 fps.
Rendering the GUI is just too expensive to keep up with 50fps video. With the patch audio sync seems okay.

Enabling omxplayer is likely to work better for these cases as the rendering is handled by GPU.

I just downloaded 0827 and did a quick test. Exactly the same symptoms, though I can see the dropped frames when it's in a window so now the video is more choppy than before when the GUI is up. Audio still goes instantly out of sync and video races to catch up when I go back to full screen. Honestly, I'm not surprised because the CPU time never went over 10% for a single core fullscreen or when in a window. I still think that it thinks the frame rate is only 50FPS when I put it in a window which (to me anyway) would explain why you don't see any problem (as I understand it, you live in a 50FPS "world") Wink

The problem appeared with 0822b. Before then, it was fine. The frame dropping isn't helping.

Thanks for the help. I'm not griping, just trying to help.

I'd like to know if zaphod24 is having the same issue since he has a very similar setup to me. Perhaps something is corrupt on my installation? Is that possible?
Experience: It's what you get when you were expecting something else.
  Thread Closed
 
Thread Rating:
  • 10 Vote(s) - 5 Average


Messages In This Thread
RE: OpenELEC Testbuilds for RaspberryPi (Kodi 16.0) - by afremont - 2015-08-29, 00:16
Bluetooth on #1003 - by cdvreede - 2015-10-13, 11:08
Re: RE: Bluetooth on #1003 - by Milhouse - 2015-10-13, 13:24


Logout Mark Read Team Forum Stats Members Help
OpenELEC Testbuilds for RaspberryPi (Kodi 16.0)510