•   
  • 1
  • 64
  • 65
  • 66(current)
  • 67
  • 68
  • 168
  •   
  Thread Closed
OpenELEC Testbuilds for RaspberryPi (Kodi 16.0)
I can't figure this out... Tvheadend seems properly configured but the EPG won't propagate (in both TVH and Kodi the EPG is empty). The Kodi tvheadend client is properly configured inside OE, but the info below shows no new info (though the update file is 9MB). Any idea what I'm missing?

Quote:2015-09-01 00:08:43.089 /storage/.kodi/addons/service.multimedia.tvheadend/bin/tv_grab_file: grab /storage/.kodi/addons/service.multimedia.tvheadend/bin/tv_grab_file
2015-09-01 00:08:43.098 spawn: Executing "/storage/.kodi/addons/service.multimedia.tvheadend/bin/tv_grab_file"
2015-09-01 00:08:44.531 /storage/.kodi/addons/service.multimedia.tvheadend/bin/tv_grab_file: grab took 1 seconds
2015-09-01 00:08:44.847 /storage/.kodi/addons/service.multimedia.tvheadend/bin/tv_grab_file: parse took 0 seconds
2015-09-01 00:08:44.849 /storage/.kodi/addons/service.multimedia.tvheadend/bin/tv_grab_file: channels tot= 24 new= 0 mod= 0
2015-09-01 00:08:44.851 /storage/.kodi/addons/service.multimedia.tvheadend/bin/tv_grab_file: brands tot= 0 new= 0 mod= 0
2015-09-01 00:08:44.852 /storage/.kodi/addons/service.multimedia.tvheadend/bin/tv_grab_file: seasons tot= 0 new= 0 mod= 0
2015-09-01 00:08:44.853 /storage/.kodi/addons/service.multimedia.tvheadend/bin/tv_grab_file: episodes tot= 0 new= 0 mod= 0
2015-09-01 00:08:44.854 /storage/.kodi/addons/service.multimedia.tvheadend/bin/tv_grab_file: broadcasts tot= 0 new= 0 mod= 0

UPDATE: Even weirder, when I click a channel in the TV area of Kodi, then stop playing the channel, then click the same channel again, I get a random other channel's content. What is going on?
You probably want to post in the tvheadend forum for tvheadend support.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Debug enabled #0831x builds: RPi / RPi2
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
I was just wondering, what is causing the delay when starting a live stream? This is both when starting http/rtsp/m3u8 for the same stream. Opening in vlc is just very fast.

In the snippet below the 8 sec delay between Window Deinit and CDVDPlayer::SetCaching is exactly the delay I see in the live stream (a CCTV camera in my house). Adjusting buffermode in advancedsettings does not help.

Code:
08:58:20 276.455933 T:1967312896   DEBUG: COMXCoreComponent::Deinitialize : OMX.broadcom.image_decode handle 0x35c7aa8
08:58:20 276.457764 T:1967312896   DEBUG: COMXCoreComponent::Deinitialize : OMX.broadcom.egl_render handle 0x33582b0
08:58:20 276.458069 T:1967312896   DEBUG: DecodeJpegToTexture: decoded special://skin/backgrounds/media-overlay.jpg 1280x720
08:58:20 276.563293 T:1967312896   DEBUG: ------ Window Deinit (DialogBusy.xml) ------
08:58:28 284.635956 T:1541186560   DEBUG: CDVDPlayer::SetCaching - caching state 0
08:58:28 284.677704 T:1499460608  NOTICE:  fps: 25.000000, pwidth: 1920, pheight: 1080, dwidth: 1920, dheight: 1080
(2015-09-01, 06:34)Milhouse Wrote: You probably want to post in the tvheadend forum for tvheadend support.

Sure - sorry, not trying to spam this thread. What's the best way to remove the Demo channels (the fam is a little confused by it). I disabled them in the Channel Manager, but then they magically turned themselves back on (one at a time over the period of about an hour)...
(2015-09-01, 09:05)erikoo Wrote: I was just wondering, what is causing the delay when starting a live stream? This is both when starting http/rtsp/m3u8 for the same stream. Opening in vlc is just very fast.

In the snippet below the 8 sec delay between Window Deinit and CDVDPlayer::SetCaching is exactly the delay I see in the live stream (a CCTV camera in my house). Adjusting buffermode in advancedsettings does not help.

Always post complete logs with debug enabled to a paste site (e.g. xbmclog.com).

Kodi is designed for file playback where data can be read faster than it is played out.

For live streams you may be better off playing through the PVR interface. The IPTV simple (Add-on:IPTV_Simple_Client) addon may be an option.
(2015-09-01, 13:59)buddy123 Wrote: Sure - sorry, not trying to spam this thread.

No problem, it's just that I (and maybe others here) don't know much about the PVR side, so you may have more luck asking where they do understand the PVR functionality.

(2015-09-01, 13:59)buddy123 Wrote: I disabled them in the Channel Manager, but then they magically turned themselves back on (one at a time over the period of about an hour)...

Is the PVR Demo client disabled?
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Quote:Is the PVR Demo client disabled?
It is now... thanks Smile
(2015-09-01, 06:26)buddy123 Wrote: I can't figure this out... Tvheadend seems properly configured but the EPG won't propagate (in both TVH and Kodi the EPG is empty). The Kodi tvheadend client is properly configured inside OE, but the info below shows no new info (though the update file is 9MB). Any idea what I'm missing?

Quote:2015-09-01 00:08:43.089 /storage/.kodi/addons/service.multimedia.tvheadend/bin/tv_grab_file: grab /storage/.kodi/addons/service.multimedia.tvheadend/bin/tv_grab_file
2015-09-01 00:08:43.098 spawn: Executing "/storage/.kodi/addons/service.multimedia.tvheadend/bin/tv_grab_file"
2015-09-01 00:08:44.531 /storage/.kodi/addons/service.multimedia.tvheadend/bin/tv_grab_file: grab took 1 seconds
2015-09-01 00:08:44.847 /storage/.kodi/addons/service.multimedia.tvheadend/bin/tv_grab_file: parse took 0 seconds
2015-09-01 00:08:44.849 /storage/.kodi/addons/service.multimedia.tvheadend/bin/tv_grab_file: channels tot= 24 new= 0 mod= 0
2015-09-01 00:08:44.851 /storage/.kodi/addons/service.multimedia.tvheadend/bin/tv_grab_file: brands tot= 0 new= 0 mod= 0
2015-09-01 00:08:44.852 /storage/.kodi/addons/service.multimedia.tvheadend/bin/tv_grab_file: seasons tot= 0 new= 0 mod= 0
2015-09-01 00:08:44.853 /storage/.kodi/addons/service.multimedia.tvheadend/bin/tv_grab_file: episodes tot= 0 new= 0 mod= 0
2015-09-01 00:08:44.854 /storage/.kodi/addons/service.multimedia.tvheadend/bin/tv_grab_file: broadcasts tot= 0 new= 0 mod= 0

UPDATE: Even weirder, when I click a channel in the TV area of Kodi, then stop playing the channel, then click the same channel again, I get a random other channel's content. What is going on?

SOLVED
Quote:Microsoft has switched their EPG provider for their North American listings from Zap2It to Rovi and have not updated their legacy service (listings run out on 2015/07/26). It is not known if this is temporary or not. The service continues to update listings for other countries.
Solved: This is an issue with mc2xml. Looks like mc2xml will provide an updated version which fixes the broken data in the xml file with a donation. Alternatively, users can use zap2xml.
(2015-08-31, 21:02)metaron Wrote: I'm having problems seeking / with 4:3 to 16:9 transitions on RPi with the latest build (New OpenELEC Jarvis build #0830: RPi) using both the OMXPlayer and MMAL acceleration options. This seems to affect channels when they use different formats/bitrates for ads and shows.

Thanks for detailed bug report. I can see the cause of the MMAL issue. If you disable deinterlace it should work correctly again (would be useful if you can confirm that).

Basically the video_decode component can generate notification messages. One of these is aspect ratio has changed.
However when deinterlace is enabled we tunnel video_decode to image_fx (which does the deinterlace) and that's where the notification goes, and kodi doesn't see it.

I suspect I'll need to plumb in similar notifications from image_fx to fix this problem.
I don't understand how people are using MMAL with Live TV or recordings at all. I'm using my own RPi v2 now that I've sent my brother's off to him and even using HDMI for video and audio it stutters every 9-10s. Huh
Using only mmal on an rpi2 with a Mythtv backend. My tv streams are 1080i60 mpeg2 and play back great. Obvious question, have you licensed hardware mpeg2?
New OpenELEC Jarvis build #0901: RPi / RPi2
(Supercedes previous build)

Code:
# uname -a
Linux rpi512 4.1.6 #1 Tue Sep 1 23:55:35 BST 2015 armv6l GNU/Linux

# vcgencmd version
Aug 23 2015 19:27:51
Copyright (c) 2012 Broadcom
version 41b1f861989dc4d1bbe19a52361a248ae57ee82b (clean) (release)

# lsb_release
OpenELEC (Milhouse) - Version: devel-20150901235445-#0901-g494f51d [Build #0901]

# vcdbg log msg 2>&1 | grep DTOK
001577.680: Kernel trailer DTOK property says yes

# Kernel device tree status: Enabled

Based on tip of OpenELEC master (494f51df, changelog) and tip of XBMC master (7500b5d6, changelog) with the following modifications: Build Highlights:
  1. Kodi 16.0a3 - bump videodb schema to v95
  2. Merge dcadec support
  3. Reintroduce "[PVR] API 3.0.0 Version Bump"
Build Details:
  1. XBMC:
    • CVideoLibraryRefreshingJob: ditch m_showDialogs in favor of CProgressJob:Big GrinoModal/IsModal() (PR:7918, 3 commits, 4 files changed)
    • set version to 16.0a3 (PR:7937, 1 commit, 2 files changed)
    • [GUI] New <depth> tag for stereoscopic effect for controls. (PR:7855, 8 commits, 17 files changed)
    • [CEC] change bool setting "pause playback on changing source" into (PR:7160, 1 commit, 3 files changed)
    • [groovy] Update groovy to 2.4.4 and move to tools/codegenerator/ (PR:7899, 2 commits, 5 files changed)
    • kodi.sh: use portable printf (PR:7895, 1 commit, 1 file changed)
    • changed: When matching articles, ignore their case (PR:7889, 1 commit, 1 file changed)
    • [core] use std:: instead of using namespace std (PR:7912, 22 commits, 254 files changed)
    • [videodb] Never clean empty TV shows if the path still exists. (PR:7904, 1 commit, 1 file changed)
    • [guilib] nuke VisualisationPresetList.xml (PR:7863, 1 commit, 3 files changed)
    • [guilib] add support for sorting dynamic directory listings from <content> (PR:7882, 4 commits, 6 files changed)
    • [PVR][Confluence] Add EPG to search results window (PR:7925, 1 commit, 1 file changed)
    • CApplication: improve skin reloading in case theme/color/font is not default (PR:7843, 1 commit, 2 files changed)
    • [video] add missing container.art for movie sets (PR:7914, 1 commit, 1 file changed)
    • [video] replace play stack selection dialog with select dialog (PR:7876, 2 commits, 12 files changed)
    • [infomanager] add Visualisation.HasPresets info bool (PR:7870, 2 commits, 5 files changed)
    • [videodb] add genre to episode_view (PR:7920, 1 commit, 2 files changed)
    • [video] add listitem audio/subtitle properties from streamdetails (PR:7921, 1 commit, 1 file changed)
    • [infomanager] add System.HasHiddenInput info bool (PR:7881, 1 commit, 4 files changed)
    • [dialog] use DialogOK as basis for the gamepad dialog (PR:7879, 1 commit, 3 files changed)
    • [keymap] improve handling of KEY_MENU (PR:7916, 2 commits, 2 files changed)
    • [cleanup] dont search for ogg/vorbis/vorbisenc shared libs (PR:7908, 1 commit, 3 files changed)
    • [Util] Generalize external subtitle retrieval method(s). (PR:7902, 2 commits, 2 files changed)
    • [bluray] Update libbluray to 0.8.1 and some enhancements (PR:7727, 12 commits, 10 files changed)
    • [guilib] add Container(id).Position for grouplist controls (PR:7866, 3 commits, 4 files changed)
    • [guilib] Add randomize tag for fadelabels (PR:7900, 1 commit, 5 files changed)
    • [infomanager] add Container.Row/Column info label for panels (PR:7915, 1 commit, 3 files changed)
    • [peripheral] Move initialisation after language init to fix notifcations (PR:7935, 1 commit, 1 file changed)
    • [ActiveAE] Added GetCurrentSinkFormat method (PR:7609, 2 commits, 4 files changed)
    • [peripherals] replace peripherals manager with dialogselect (PR:7872, 4 commits, 15 files changed)
    • [confluence] update bookmark OSD icon (PR:7791, 1 commit, 2 files changed)
    • [dx11] Fixed displaying GUI in limited color range. (PR:7865, 4 commits, 15 files changed)
    • Use mmap to accelerate SQLite file accesses (PR:7926, 2 commits, 2 files changed)
    • [binary addons] Allow regex patterns in ADDONS_TO_BUILD (PR:7880, 1 commit, 2 files changed)
    • [infomanager] add Container.Content info label (PR:7934, 1 commit, 1 file changed)
    • [ffmpeg] Add support for libdcadec (PR:7102, 2 commits, 19 files changed)
    • typo (9662020b)
  2. newclock4:
    • Commits no longer in build:
      • [ffmpeg] Add support for libdcadec (ba108d0f)
      • change bool setting "pause playback on changing source" into tristate option with possible settings: 1. do nothing (as was before) 2. pause playback (as was bef (64782f67)
      • Revert "[PVR] API 3.0.0 Version Bump" (13e203f7)
      • [peripheral] Move initialisation after language init to fix notifcations (b4c36a38)
  3. Additional commits/pull requests/changes not yet merged upstream:
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
@Milhouse Wasnt able to reproduce that crashloop on the first test with #831x.

Oddly it was the fastest scp I have ever managed to get to my rPi2, (maxing at 2.8MB/s compared to 1.4MB/s max before) so im suspecting somehow there is some caching or hashing of the chunks going on and reusing the last transfer somehow? I did remove the old file on the pi, and renamed it on the source before transferring to try and prevent that.

Will try with a different large file and report if it makes the crash happen, but it seems to be a fluke so far.
A 2GB file should ensure there is minimal caching occurring.

One observation would be that you are overclocked, particularly sdram, and pushing sdram too far can result in unexplained behaviour and random crashes, so if you are able to reproduce or have other unexplained instability, it might be worth reverting sdram back to stock frequency and seeing if the situation improves.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
  •   
  • 1
  • 64
  • 65
  • 66(current)
  • 67
  • 68
  • 168
  •   
  Thread Closed
 
Thread Rating:
  • 10 Vote(s) - 5 Average



Logout Mark Read Team Forum Stats Members Help
OpenELEC Testbuilds for RaspberryPi (Kodi 16.0)510