•   
  • 1
  • 75
  • 76
  • 77(current)
  • 78
  • 79
  • 168
  •   
  Thread Closed
OpenELEC Testbuilds for RaspberryPi (Kodi 16.0)
The builds before #0908 had ass sub issues too,I have tested build #0821/#0901/#0904/0907, but a little different,the sub displayed ok,after about 100 minutes I played movie with ass sub(2line) PI2 became to freezed, all I can do is reboot it. with srt sub, it's fine no freeze at all. (GPU Memory 256MB)
(2015-09-14, 12:35)Milhouse Wrote:
(2015-09-13, 22:20)bagofcrap24 Wrote: Here is the bcmstat.sh -cxgpd10 output
http://pastebin.com/fxLpQrzm


Question: bcmstat.sh is reporting your sdram_freq @ 400MHz (default on Pi2 is 450MHz) - have you applied the default Pi1 sdram_freq of 400MHz on your Pi2? Or is this a detection error in bcmstat.sh, can you paste your config.txt?
I'm pretty sure it will likely be my mess up with the sdram freq. I'll check the config.txt when I get home.
I'm certain I originally copied the configurations from the pi1 when initially setting up the pi2 and then just changed the overclock values.
It's quite possible that I missed this one.

[EDIT}
Yes, after checking, I have indeed left sdram_freq at 400MHz. so no worry on the detection in bcmstat
(2015-09-14, 12:49)popcornmix Wrote: Okay, for the gpu mem leak. Are subs essential?
Playback of a tv show without any subs at all resulted in no leakage at all.
284MB free GPU at start of playback & 284MB free GPU at end of playback 20mins later

http://pastebin.com/Ti5374r1
New OpenELEC Jarvis build #0914: RPi / RPi2
(Supercedes previous build)

Code:
# uname -a
Linux rpi512 4.1.7 #1 Mon Sep 14 22:35:23 BST 2015 armv6l GNU/Linux

# vcgencmd version
Sep 14 2015 19:42:22
Copyright (c) 2012 Broadcom
version b8dac9fd087b95a97cc6b522638f8c21c119ee0a (clean) (release)

# lsb_release
OpenELEC (Milhouse) - Version: devel-20150914223436-#0914-g43d5606 [Build #0914]

# vcdbg log msg 2>&1 | grep DTOK
001715.489: Kernel trailer DTOK property says yes

# Kernel device tree status: Enabled

Based on tip of OpenELEC master (43d56068, changelog) and tip of XBMC master (4f9bb775, changelog) with the following modifications: Build Highlights:
  1. New firmware
  2. New kernel 4.1.7
  3. PVR Addon API 4.0.0
  4. Fix subtitle-induced GPU memory leak
Build Details:
  1. Firmware (Sep 14):
    • firmware: Fix touchscreen I2C to only read from i2c in smaller bursts to avoid a fifo overrun problem with the i2c peripheral. See: link
    • firmware: arm_display: Fix issue with nonsensical negative overscan settings. See: link
    • firmware: arm_loader: Enable the i2c_arm and i2c_vc aliases for CM. See: link
    • firmware: di_adv: Allow the v3d priority boost to be modified. See: link
  2. XBMC:
    • [pvr] Some cleanup, makes it easier to change format string (PR:8033, 1 commit, 1 file changed)
    • [fix][udf] Free allocated memory in the destructor. (PR:8036, 1 commit, 1 file changed)
    • videodb: allow calling SetDetailsForSeason() for "All seasons" (PR:8044, 1 commit, 1 file changed)
    • UPnP: add support for video's countries through xbmc:country (PR:8045, 3 commits, 7 files changed)
    • Update .gitignore to ignore new Makefile's (PR:8039, 1 commit, 1 file changed)
    • UPnP: add support for video's user ratings through xbmc:userrating (PR:8051, 3 commits, 7 files changed)
    • [strings] remove obsolete strings after #8011 (PR:8052, 1 commit, 1 file changed)
    • settings: default to visualization.spectrum, not visualization.glspectrum (PR:8043, 1 commit, 1 file changed)
    • [fix][subs] Fix MicroDVD Subtitles after b5432d54de865529226b56101394… (PR:8023, 1 commit, 2 files changed)
    • [ios] - add missing gesture swipe handlers for 2 and 3 finger swipes … (PR:8047, 1 commit, 1 file changed)
    • AESinkPULSE: Emulate periodSize as ALSA to stop fragmentation (PR:8016, 1 commit, 2 files changed)
    • [PVR] PVR Addon API 4.0.0 (PR:8005, 7 commits, 26 files changed)
    • CGUIDialogSelect: cleanup Add/SetItems. pass const reference (PR:8042, 1 commit, 12 files changed)
    • [adsp] Several small fixes (PR:8046, 4 commits, 5 files changed)
    • [pvr] fix/improve RDS parts (PR:8034, 6 commits, 4 files changed)
  3. pvr.argustv:
    • Update to PVR addon API v4.0.0 (PR:31, 1 commit, 3 files changed)
  4. pvr.demo:
    • Update to PVR addon API v4.0.0 (PR:21, 1 commit, 3 files changed)
  5. pvr.dvblink:
    • Update to PVR addon API v4.0.0 (PR:27, 1 commit, 4 files changed)
  6. pvr.dvbviewer:
    • Update to PVR addon API v4.0.0 (PR:18, 1 commit, 3 files changed)
  7. pvr.filmon:
    • Update to PVR addon API v4.0.0 (PR:29, 1 commit, 5 files changed)
  8. pvr.hts:
    • Update to PVR addon API v4.0.0 (PR:96, 1 commit, 7 files changed)
  9. pvr.iptvsimple:
    • Update to PVR addon API v4.0.0 (PR:42, 1 commit, 3 files changed)
  10. pvr.mediaportal.tvserver:
    • Update to PVR addon API v4.0.0 (PR:23, 1 commit, 6 files changed)
  11. pvr.mythtv:
    • Update to PVR addon API v4.0.0 (PR:36, 1 commit, 5 files changed)
  12. pvr.nextpvr:
    • Update to PVR addon API v4.0.0 (PR:24, 1 commit, 4 files changed)
  13. pvr.njoy:
    • Update to PVR addon API v4.0.0 (PR:17, 1 commit, 3 files changed)
  14. pvr.pctv:
    • Update to PVR addon API v4.0.0 (PR:24, 1 commit, 3 files changed)
  15. pvr.stalker:
    • Update to PVR addon API v4.0.0 (PR:25, 1 commit, 3 files changed)
  16. pvr.vbox:
    • Update to PVR addon API v4.0.0 (PR:100, 1 commit, 3 files changed)
  17. pvr.vdr.vnsi:
    • Update to PVR addon API v4.0.0 (PR:27, 1 commit, 2 files changed)
  18. pvr.vuplus:
    • Update to PVR addon API v4.0.0 (PR:23, 1 commit, 4 files changed)
  19. pvr.wmc:
    • Update to PVR addon API v4.0.0 (PR:24, 1 commit, 6 files changed)
  20. newclock5:
    • New commits in this build:
      • [OverlayRenderer] Fix memory leak of subtitles 2 (843abc76)
  21. kernel 4.1.y_rebase:
    • New commits in this build:
      • vchiq: fix NULL pointer dereference when closing driver (20833437)
      • bcm2708_fb: remove redundant code as detected by static analysis (020b3c7b)
      • bcm2708_fb: remove unnecessary initialization of result (51a3a0c4)
      • vcsm: increment res_stats MAP_FAIL stats before we potentially release the resource (1026505b)
      • bcm2835: camera: check for scene not being found (00515479)
      • bcm2835: memcpy port data to m rather than rmsg (7b881078)
      • Revert "BCM270X_DT: mz61581: Revert to spi-bcm2708" (2a8c0025)
      • BCM270X_DT: mz61581: Set txbuflen to 32k (5893b0be)
      • bcm2835-mmc: Don't overwrite MMC capabilities from DT (a137fc76)
      • BCM270X_DT: Use fixed-factor-clock for uart1 (48dfdc5e)
  22. Additional commits/pull requests/changes not yet merged upstream:
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Milhouse, popcornmix (and any other dev working on this), just want to say again that you guys are doing awesome work on RPi2. Thanks!
[H]i-[d]eft [M]edia [K]een [V]ideosaurus
My Family Room Theater
I got problem about mouse pointer.
Hardware mouse pointer doesn't exact position under input box. GUI key button highlighted but pointer stay previous position for a while(very long).
I'm having an issue with the trakt add-on since build #0910.

I've described the issue in a private discussion with the author (razze): https://teamkodi.slack.com/archives/gene...5885005656 (Team members only), see 02:34
Basically, I have it configured to rate videos after watching. It shows a custom dialog to do so and then waits for the user to rate it or close the dialog.
Since build #0910 the dialog is not shown, but the add-on thinks it is and then sits there indefinitely, so it basically stop working (scrobble, manual sync, etc. It really is waiting for the dialog). GUI is fully usable as no dialog is shown at all.
It might need a few tries to reproduce (you can fast forward near the end).

Seems a bit difficult to track it down, as build #0910 has lots of commits and files changed, but you guys might have an idea...

Edit: the dialog I'm talking about is this:
https://github.com/trakt/script.trakt/bl...ing.py#L97
https://github.com/trakt/script.trakt/bl...ng.py#L154
Never used trakt before, I'll try installing it later today. Complete guess, but could it be PR7800?
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2015-09-14, 15:03)popcornmix Wrote: Can you test on another kodi platform? E.g. a nightly build on windows or linux. Would be useful to know if it's an upstream kodi issue.

Hello,

I tested it with nightly build on windows and the subtitle is working good. I just have the video half cut because kodi on windows can't handle 3D MVC MKV.

I made some other tests on my raspberry and the subtitle is ok when I deactivate "stereoscopic mode", kodi is just playing the file like a classic 2D file (ignoring the MVC stream). So I have the problem only in 3D stereoscopic and 2D monoscopic mode.

I tested older builds and last openelec beta and I have the same problem.
(2015-09-15, 00:39)Milhouse Wrote:
  • [OverlayRenderer] Fix memory leak of subtitles 2 (843abc76)

Confirmed that the GPU memory leak with Embedded ASS Subs is no longer present in build 914
(2015-09-15, 04:22)menakite Wrote: I'm having an issue with the trakt add-on since build #0910.

Looks like the significant commits were all merges to kodi master. Can you reproduce it on another kodi platform. E.g. nightly build on windows/linux?
(2015-09-15, 04:22)menakite Wrote: I'm having an issue with the trakt add-on since build #0910.

I've described the issue in a private discussion with the author (razze): https://teamkodi.slack.com/archives/gene...5885005656 (Team members only), see 02:34
Basically, I have it configured to rate videos after watching. It shows a custom dialog to do so and then waits for the user to rate it or close the dialog.
Since build #0910 the dialog is not shown, but the add-on thinks it is and then sits there indefinitely, so it basically stop working (scrobble, manual sync, etc. It really is waiting for the dialog). GUI is fully usable as no dialog is shown at all.
It might need a few tries to reproduce (you can fast forward near the end).

Seems a bit difficult to track it down, as build #0910 has lots of commits and files changed, but you guys might have an idea...

Edit: the dialog I'm talking about is this:
https://github.com/trakt/script.trakt/bl...ing.py#L97
https://github.com/trakt/script.trakt/bl...ng.py#L154

I've rebuilt #0910 and reproduced the issue. I then reverted PR7800, rebuilt #0910, and now the trakt rating is working. The only difference between the two builds being the presence or omission of PR7800.

Here are the debug logs when watching Falling Skies 5x10, seeking to the end, and then waiting for the Trakt Rating dialog to appear:
#0910a - with PR7800, dialog doesn't appear
#0910b - without PR7800, dialog does appear

This is the part in the debug log where the non-working build #0910a attempts to load the Ratings dialog:
Code:
11:39:43  45.365074 T:1966022656   DEBUG: ------ Window Init (/storage/.kodi/addons/script.trakt/resources/skins/Default/720p/script-trakt-RatingDialog.xml) ------
11:39:43  45.365250 T:1966022656    INFO: Loading skin file: /storage/.kodi/addons/script.trakt/resources/skins/Default/720p/script-trakt-RatingDialog.xml, load type: LOAD_ON_GUI_INIT
11:39:43  45.384960 T:1966022656   DEBUG: POParser: loaded 157 strings from file /storage/.kodi/addons/script.trakt/resources/language/English/strings.po
11:39:44  45.401741 T:1966022656   DEBUG: SECTION:LoadDLL(special://xbmcbin/system/ImageLib-arm.so)
11:39:44  45.402008 T:1966022656   DEBUG: Loading: /usr/lib/kodi/system/ImageLib-arm.so
11:39:44  45.466091 T:1966022656   DEBUG: CGUIMediaWindow::GetDirectory ()
11:39:44  45.466255 T:1966022656   DEBUG:   ParentPath = []
11:39:44  45.505447 T:1966022656   DEBUG: ------ Window Deinit () ------
11:39:44  45.505634 T:1966022656   DEBUG: ------ Window Deinit (/storage/.kodi/addons/script.trakt/resources/skins/Default/720p/script-trakt-RatingDialog.xml) ------
11:39:44  45.538445 T:1966022656   DEBUG: ------ Window Init () ------
11:39:46  48.181763 T:1838150656   DEBUG: POParser: loaded 157 strings from file /storage/.kodi/addons/script.trakt/resources/language/English/strings.po

And the same in build #0910b, which is working - I didn't set a rating in the Ratings dialog (clicked the "Back" button on my remote)
Code:
11:42:58  80.103386 T:1966514176   DEBUG: ------ Window Deinit () ------
11:42:58  80.103561 T:1966514176   DEBUG: ------ Window Init (/storage/.kodi/addons/script.trakt/resources/skins/Default/720p/script-trakt-RatingDialog.xml) ------
11:42:58  80.103683 T:1966514176    INFO: Loading skin file: /storage/.kodi/addons/script.trakt/resources/skins/Default/720p/script-trakt-RatingDialog.xml, load type: LOAD_ON_GUI_INIT
11:42:58  80.123070 T:1966514176   DEBUG: POParser: loaded 157 strings from file /storage/.kodi/addons/script.trakt/resources/language/English/strings.po
11:42:58  80.139923 T:1966514176   DEBUG: SECTION:LoadDLL(special://xbmcbin/system/ImageLib-arm.so)
11:42:58  80.140236 T:1966514176   DEBUG: Loading: /usr/lib/kodi/system/ImageLib-arm.so
11:42:58  80.203163 T:1966514176   DEBUG: CGUIMediaWindow::GetDirectory ()
11:42:58  80.203362 T:1966514176   DEBUG:   ParentPath = []
11:42:58  80.242615 T:1966514176   DEBUG: ------ Window Init () ------
11:43:01  82.990295 T:1838150656   DEBUG: POParser: loaded 157 strings from file /storage/.kodi/addons/script.trakt/resources/language/English/strings.po
11:43:07  89.031746 T:1966514176   DEBUG: LIRC: Update - NEW at 81429:ae 0 KEY_EXIT devinput (KEY_EXIT)
11:43:07  89.032066 T:1966514176   DEBUG: OnKey: menu (0xd8) pressed, action is ParentDir
11:43:07  89.064400 T:1838150656   DEBUG: [script.trakt] rating: Rating dialog was closed with no rating.
11:43:07  89.065704 T:1966514176   DEBUG: LIRC: Update - NEW at 81463:ae 0 KEY_EXIT_UP devinput (KEY_EXIT_UP)
11:43:07  89.405533 T:1966514176   DEBUG: ------ Window Deinit (/storage/.kodi/addons/script.trakt/resources/skins/Default/720p/script-trakt-RatingDialog.xml) ------

The non-working version (with PR7800) seems to perform a "Window Deinit ()" on the Ratings dialog without actually displaying it, which presumably the add-on is unaware of and so it waits for input that never comes - either a bug introduced by PR7800, or a new behaviour in Kodi which the addon now needs to take account of?
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Debugging the call to gui.doModal(), it appears that in #0910a (ie. the non-working version) the gui.doModal() call succeeds, but doesn't display anything so at that point the add-on is "stuck" wiating for the gui.doModal() call to complete.

With PR7800 included, the Kodi doModal() method appears to be defective, or has a different behaviour that now needs to be accounted for - ping @Paxxi ?
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Build 914

Thought i had noticed it a couple of times but didn't think anything of it.
At start of playback sometimes I'm just presented with a black video screen.
Sometimes it stays as a black screen for a second or two, audio starts but video does not, then a few seconds later the video resumes from the correct point.
Sometimes it just stays on a black screen indefinetly.

Here is a log.
http://pastebin.com/rNdj8XdZ

If it gets stuck at the beginning of the file indefinetely I can seek forwards which will continue playback as normal.

Image

[EDIT]
This appears to only affect OMX acceleration
When trying to load the same episode with MMAL it begins playback of both audio & video immediately

What is the best way to cut a sample file down.
Opening the file in question in VLC will begin playback normally (in.mkv)
Code:
ffmpeg -i in.mkv -ss 0 -t 30 -c:v copy -c:a copy out.mkv
results in a 30second file which will not begin playback until 7 seconds in VLC
Code:
ffmpeg -ss 00 -i in.mkv -t 30 -c:v copy -c:a copy out.mkv
results in a 30second file which plays back correctly on both VLC & the Pi2

[EDIT2]
Now I'm not so sure weather I just have some damaged files.
Original File "In.mkv" is causing issues with OMX
running
Code:
ffmpeg -i in.mkv -c:v copy -c:a copy out2.mkv
correct me if I'm mistaken but doesnt the above command just literally bitstream the audio & video directly into out2.mkv
out2.mkv is 4kb smaller than in.mkv and has no issues playing back with OMX on the pi
(2015-09-15, 16:59)bagofcrap24 Wrote: Thought i had noticed it a couple of times but didn't think anything of it.
At start of playback sometimes I'm just presented with a black video screen.
Sometimes it stays as a black screen for a second or two, audio starts but video does not, then a few seconds later the video resumes from the correct point.
Sometimes it just stays on a black screen indefinetly.

Any idea when you first saw this? I'd be intested if it coincided with switch to VideoPlayer.
  •   
  • 1
  • 75
  • 76
  • 77(current)
  • 78
  • 79
  • 168
  •   
  Thread Closed
 
Thread Rating:
  • 10 Vote(s) - 5 Average



Logout Mark Read Team Forum Stats Members Help
OpenELEC Testbuilds for RaspberryPi (Kodi 16.0)510