•   
  • 1
  • 79
  • 80
  • 81(current)
  • 82
  • 83
  • 168
  •   
  Thread Closed
OpenELEC Testbuilds for RaspberryPi (Kodi 16.0)
(2015-09-11, 15:08)popcornmix Wrote:
(2015-09-10, 20:53)polo_joe Wrote: anything else I could try to debug my playback problem?

Can you try this test firmware.
Copy start_x.elf and fixup_x.dat and replace start.elf and fixup.dat from the boot partition of OE sdcard.

and add:
Code:
hvs_priority=0x100000

I wonder if reducing the sdram priority of the deinterlacer may help.

Tried latest build, less artefacts but still there. also tvheadend discontinuity counter slowly increasing.
hvs_priority=0x100000
Hi great work on the official RPI touchscreen support

Can I ask if there will be further adjustments to how screen taps are processed

I am referring to latest build is smooth on the pointer to finger but selection requires double tap can this or will this be changed to one click selection to simulate android or ios touchscreen

Thanks again and I hope I'm not over stepping the mark by asking
Tested 3D ISO playback, works just as well as MVC MKV. Think I'll stick to latter though as smaller footprint and quicker playback.

Re: ISO's, chapter skips aren't enabled yet it appears? I only tried in 3D mode.
[H]i-[d]eft [M]edia [K]een [V]ideosaurus
Kodi 3D MVC Hardware Options
Kodi A/V Samples wiki
3D: Zidoo X9S | Intel D34010WYK w/Kodi MVC build
4K: nVidia Shield TV (2nd gen)
(2015-09-17, 15:14)popcornmix Wrote:
(2015-09-17, 14:58)woronczak Wrote: HDMKV - I'm not entirely sure that's exactly the same issue. This happens 100% of the time if the GUI resolution is 1080 / 23.98 on any 3d movie and it doesn't say "no signal" - W1070 the projector stays on 1080 / 24 / Frame packing and the GUI shows up with the L half of the screen overlapping the right one (so Kodi is not sending or the Projector is not receiving the message to turn back to the GUI resolution of 1080/23.98 without frame packing).

Can you ssh in and report output of:
Code:
tvservice -s
when you have the overlapping gui.

state 0x12000a [HDMI CEA (32) RGB lim 16:9], 1920*1080 @ 23.98Hz, progressive

Hope that helps
New OpenELEC Jarvis build #0917: RPi / RPi2
(Supercedes previous build)

Code:
# uname -a
Linux rpi512 4.1.7 #1 Thu Sep 17 22:22:18 BST 2015 armv6l GNU/Linux

# vcgencmd version
Sep 17 2015 19:44:51
Copyright (c) 2012 Broadcom
version bf3605ae6ee50c1fb2f0ce5f3e75a38d12a53c7d (clean) (release)

# lsb_release
OpenELEC (Milhouse) - Version: devel-20150917222016-#0917-g2eec924 [Build #0917]

# vcdbg log msg 2>&1 | grep DTOK
001735.947: Kernel trailer DTOK property says yes

# Kernel device tree status: Enabled

Based on tip of OpenELEC master (2eec9240, changelog) and tip of XBMC master (1971f023, changelog) with the following modifications: Build Highlights:
  1. New firmware
  2. Drop RapidJSON due to PVR.GetChannels problem
Build Details:
  1. Firmware (Sep 17):
    • firmware: video codec: Cleanup of fix for regression from refactor userdata release mechanics in categoriser commit
  2. OpenELEC:
    • sqlite: update links to secure (e39ca595)
    • libmicrohttp: update to libmicrohttp-0.9.23, update licence and links(secure) (2eec9240)
  3. XBMC:
    • FIX: [droid;storage] check readability last (PR:8066, 1 commit, 1 file changed)
    • [appmessenger] Fix broken python addons after #7800 (PR:8065, 1 commit, 1 file changed)
    • [Fix]CMusicInfoTag: Remove duplicated setters added in #8012 (PR:8071, 1 commit, 1 file changed)
    • AdjustRefreshrate: Switch to higher resolution depending on source dims (PR:8031, 1 commit, 1 file changed)
    • [osx/ios] - add support for compiling with Xcode7 MacOSX SDK 10.11 and iOS SDK 9.0 (PR:8072, 11 commits, 12 files changed)
  4. pvr.vdr.vnsi:
    • epg: fill episodeName with short text (PR:29, 1 commit, 2 files changed)
  5. Additional commits/pull requests/changes not yet merged upstream:
    • Reverted: PR:8031: AdjustRefreshrate: Switch to higher resolution depending on source dims
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Periodically while watching recorded TV and skipping commercials, I'll skip too far forward and start skipping 10 seconds backward. After a few one or more skips backward, the video stops and freezes but the audio continues. I'll see this in the log:

20:15:11 84823.281250 T:1632084992 ERROR: CDVDMsgGeneralSynchronize - timeout
20:15:12 84824.187500 T:1632084992 ERROR: Previous line repeats 12 times.

The recorded TV is mpeg2 at 1080i60 and I'm using advanced deinterlacing.
It finally occurred to me to try disconnecting stuff to try and fix my "stutter every 9s with Live TV and recordings" problem and I traced the problem down to....my remote receiver!

It's an Emprex 3000ARF, whilst my brother's is the slightly different URF model so it's possible he doesn't have the same problem but I expect they're not that different and he probably will have.

With the dongle disconnected, I tried playing back my earlier recordings and even with MMAL-Advanced deinterlace there was no stutter. Then I tried LiveTV and that was smooth too.

Saying that, I then got some major audio pitch fluctuating with the signature music on Sky News. Bringing up the overlay showed around 68ms err on the P line, which dropped to about 9ms once the problem settled down.

I've uploaded the relevant extract from the (52MB) log here: https://drive.google.com/file/d/0B1fDI89...sp=sharing

I do need to fix the problem with the IR receiver as well, as whilst I can use CEC (most of the time at least, sometimes the RPi won't come out of screensaver Dim mode unless I use the Emprex remote but I've disabled the Screensaver now, so hopefully that will fix that) my brother can't and has to use the remote. It's much nicer than using the TV's one anyway, as it has loads of dedicated buttons for playback controls and jumping to specific features like Music, EPG, Pictures, etc. So if anyone can advise how to stop it causing this problem, that'd be much appreciated.
I'm having a problem with video addons, starting with rpi2 build 907 (906 is great!).

When using a very popular video plugin, and this happens on at least one other popular plugin that I know of, and browsing though file lists, I've noticed that the display list is now forced to refresh every ~13 seconds. This results in being thrown back to the top of the list every 13 seconds--highly annoying when you're trying to figure out what to watch. Other times, if the refresh hits at some point during the processing of a file selected for play, I'll have to select "full screen" to get to the video right. And one time the refresh kicked me from one addon back to a previous one I'd been using.

I tested builds 917, 914, 911, 907, 906, 904, 901, and 823 in regards to this problem. The problem started with 907.

Thanks to all the devs, especially Milhouse, for your work. You've been rocking my 'box since 2002.
@dlxmax: Are you able to reproduce this using an add-on that can be discussed on the forum, eg. YouTube? Nothing in #0907 leaps out at me that might be causing this odd behaviour, and I haven't noticed it myself so far. Anything in a debug log (wiki)?
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
PR:7874 is the only possibility I can see from #0907, but it's not immediately obvious how a repo updating is affecting an add-ons file list (but it's not completely implausible).
(2015-09-18, 00:43)hdmkv Wrote: Tested 3D ISO playback, works just as well as MVC MKV. Think I'll stick to latter though as smaller footprint and quicker playback.

Re: ISO's, chapter skips aren't enabled yet it appears? I only tried in 3D mode.

No. I don't currently know enough about about how this works for iso files to know if this is simple or hard to implement.
I'll add it to the list of things that would be nice to support.
(2015-09-18, 00:17)shaunhoop1981 Wrote: Can I ask if there will be further adjustments to how screen taps are processed

I am referring to latest build is smooth on the pointer to finger but selection requires double tap can this or will this be changed to one click selection to simulate android or ios touchscreen

I have had a look through the code and I don't think there is any touchscreen support in kodi apart form in Android/iOS specific code.
I had hoped that this was supported directly from kodi through the linux touch driver, but I don't think it is.

While making a tap cause a click may be simple, that's probably not enough to make kodi usable.
You really need context menu, and back and other controls, which iOS/Android support through two finger gestures and double taps.

It's something I'd like to improve, but it's not high on the priority list.
I'd welcome patches from anyone who'd like to have a go at this.
(2015-09-17, 18:29)polo_joe Wrote: Tried latest build, less artefacts but still there. also tvheadend discontinuity counter slowly increasing.
hvs_priority=0x100000

Can you try this test firmware:
https://dl.dropboxusercontent.com/u/3669...e_main.zip

Remove hvs_priority and report if there's any change in behaviour.
fixup_x.dat and start_x.elf and rename as last time or
fixup.dat and start.elf?
(2015-09-18, 17:19)polo_joe Wrote: fixup_x.dat and start_x.elf and rename as last time or
fixup.dat and start.elf?

Same as last time.
  •   
  • 1
  • 79
  • 80
  • 81(current)
  • 82
  • 83
  • 168
  •   
  Thread Closed
 
Thread Rating:
  • 10 Vote(s) - 5 Average



Logout Mark Read Team Forum Stats Members Help
OpenELEC Testbuilds for RaspberryPi (Kodi 16.0)510