•   
  • 1
  • 99
  • 100
  • 101(current)
  • 102
  • 103
  • 168
  •   
  Thread Closed
OpenELEC Testbuilds for RaspberryPi (Kodi 16.0)
Hi guys,

Any news on the audio cracle at the beginning of videos with videoplayer. I am still having it with the latest nightly.
New OpenELEC Jarvis build #1006: RPi / RPi2
(Supercedes previous build)

Code:
# uname -a
Linux rpi512 4.1.9 #1 Tue Oct 6 23:21:17 BST 2015 armv6l GNU/Linux

# vcgencmd version
Oct  4 2015 17:47:18
Copyright (c) 2012 Broadcom
version e7d3d0fe7ae383863dbf177ba62c0807b12df0d5 (clean) (release)

# lsb_release
OpenELEC (Milhouse) - Version: devel-20151006232026-#1006-gdc340f5 [Build #1006]

# vcdbg log msg 2>&1 | grep DTOK
001716.318: Kernel trailer DTOK property says yes

# Kernel device tree status: Enabled

Based on tip of OpenELEC master (dc340f53, changelog) and tip of XBMC master (3628fd9c, changelog) with the following modifications: Build Highlights:
  1. New kernel 4.1.9 - see if this locks up or not
  2. VideoPlayer: Fix when "sync playback to display" is enabled
Build Details:
  1. XBMC:
    • [depends] update cmake to 3.3.2 (PR:8183, 1 commit, 1 file changed)
    • [screensaver] Avoid getting stuck in dim state when skin is reloaded (PR:8179, 1 commit, 1 file changed)
    • [ios] - removed, atv2 support. time to make way for something new. hi… (PR:8181, 1 commit, 60 files changed)
  2. pvr.nextpvr:
    • Added support for Jarvis timers (PR:27, 1 commit, 10 files changed)
  3. newclock5:
    • New commits in this build:
      • another resolution fix (5225b688)
      • squash: rename OnLostDevice, OnResetDevice (dbe88837)
      • sync cmake project (b5e3cc4b)
      • Merge pull request #302 from wsnipex/fernet-master (b2daecf1)
      • Merge pull request #303 from popcornmix/omxupdate (785c1186)
      • Merge pull request #304 from popcornmix/mmalrenderbypass (72f7cdf6)
    • Commits no longer in build:
      • Revert "disable passthrough when sync playback to display" (4a39fa3c)
      • Revert "[rbp] Refactor the vsync handle to support multiple callers" (e40edb85)
      • Revert "[mmalrenderer] Wait for vsync before submitting to mmal when display sync is disabled" (14ba251c)
      • squash: Fix convergence of PLL adjust sync method (51dc7128)
      • [rbp] Refactor the vsync handle to support multiple callers (c153edd6)
      • [mmalrenderer] Wait for vsync before submitting to mmal when display sync is disabled (2ef59e19)
      • squash: pll adjust (3943fa3c)
      • omxplayer: squash: Enable pause/resume again (c6a10127)
  4. Additional commits/pull requests/changes not yet merged upstream:
    • Reverted: [env] 6c9a6c55: linux: update to linux-4.1.10 (Reason: Causing hard freeze)
    • Reverted: [pkg] b5e3cc4b: sync cmake project (Reason: Breaks build on RPi1) (kodi)
    • Reverted: [pkg] linux-999.20-mt7601u-support.patch: Reverted as patching order conflicts with rpi-4.1.y commits - continue using rpi-4.1.y equivalent (linux)
    • Reverted: [pkg] PR:8181: [ios] - removed, atv2 support. time to make way for something new. hi… (Reverted: Breaks VideoPlayer build)
    • Updated: [env] 2fd666ec: VAAPI: Enable EGL
    • Updated: [env] 5bccbe3e: Kodi: Use Limited Range by default
    • Updated: [env] 43f7e22a: Intel: Implement Passthrough-Range
    • Updated: [env] 77368091: Mesa: Bump to 11.0.2
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2015-10-07, 00:42)popcornmix Wrote:
(2015-10-07, 00:36)Forage Wrote: I can provide a log in 12 hours if nobody beats me to it.

No need for logs if #1005z fixed your problem.
If you still have problems then logs or sample files are useful.
I was thinking about creating a log in #1005 to get it fixed for 4.1.10.
The issue is not present in #1006 either.
MECOOL KIII Pro (S912)
Raspberry Pi 2 Model B, overclock mode: 'Pi2' (1000/500/500/2), gpu_mem_1024: '320'
How to reproducing 'pause after sync' problem.
Playback CBSN video addon and within 1 hour(48min or more, somtimes less 18 minites) you can see video paused with buffering window 100% filled.
Changing "sync playback to display" has no effect on this problem.

Image
both my RPi2's locked up after a while on 1005, just sitting idle. Would not allow SSH connections, and while I could view the GUI, and see the time change, I could not control them at all. Tired both Kore remote and a USB/wireless keyboard. Nada... Will install 1006 and see how that goes.
(2015-10-07, 03:15)J_E_F_F Wrote: both my RPi2's locked up after a while on 1005, just sitting idle. Would not allow SSH connections, and while I could view the GUI, and see the time change, I could not control them at all. Tired both Kore remote and a USB/wireless keyboard. Nada... Will install 1006 and see how that goes.

So...

Today's build fixed the resolution being unchangeable.

Am seeing the same issue with cache filling, showing 100%, but then not continuing play.

Noticing that an mkv at 36Mbps caches a lot when skipping around, should that be expected?

Thanks!
(2015-10-07, 06:59)msattler Wrote:
(2015-10-07, 03:15)J_E_F_F Wrote: both my RPi2's locked up after a while on 1005, just sitting idle. Would not allow SSH connections, and while I could view the GUI, and see the time change, I could not control them at all. Tired both Kore remote and a USB/wireless keyboard. Nada... Will install 1006 and see how that goes.

So...

Today's build fixed the resolution being unchangeable.

Am seeing the same issue with cache filling, showing 100%, but then not continuing play.

Noticing that an mkv at 36Mbps caches a lot when skipping around, should that be expected?

Thanks!

Continous play problem(actually pause) introduces 1002 build ("VideoPlayer: rework player sync to clock (79311dea)"),
build 1001 has no problem.
(2015-10-07, 03:09)parcel Wrote: How to reproducing 'pause after sync' problem.
Playback CBSN video addon and within 1 hour(48min or more, somtimes less 18 minites) you can see video paused with buffering window 100% filled.

Do you have a debug log for this problem?
(2015-10-07, 12:55)popcornmix Wrote:
(2015-10-07, 03:09)parcel Wrote: How to reproducing 'pause after sync' problem.
Playback CBSN video addon and within 1 hour(48min or more, somtimes less 18 minites) you can see video paused with buffering window 100% filled.

Do you have a debug log for this problem?

yep.

http://xbmclogs.com/piid3buwv#
Apologies for the delay. 1006 froze within 2 minutes on the first boot after updating.
Looks like it's something added in 4.1.9 that's causing the issue.

[EDIT]
& 2nd boot
3rd boot lasted about 3 minutes before freezing
(2015-10-07, 12:55)popcornmix Wrote:
(2015-10-07, 03:09)parcel Wrote: How to reproducing 'pause after sync' problem.
Playback CBSN video addon and within 1 hour(48min or more, somtimes less 18 minites) you can see video paused with buffering window 100% filled.

Do you have a debug log for this problem?

Just a quick 'me too'... Using the MLBMC addon to watch last nights baseball game, sometimes it would lock up within 10 seconds... sometimes it would go as long as 15 minutes before lockup.

I then switched over to using the MLB app on PlayOn to stream to Kodi, and that had no problems. PlayOn does transcode the stream as it sends it, so that may have something to do with why I had no trouble... I also have no trouble playing my local files from my NAS.

I did initially have the Sync option error on all playback... that has all been cleared with 1005z and 1006. This issue does not seem to care if Sync playback is turned on or off.

I am not at home, so I can't help with a log at the moment.
(2015-10-07, 19:15)bagofcrap24 Wrote: Apologies for the delay. 1006 froze within 2 minutes on the first boot after updating.
Looks like it's something added in 4.1.9 that's causing the issue.

Thanks. Although only 8 days between 4.1.8 and 4.1.9 there are 160 commits.
I believe about 80 are in code we don't use but that still leaves 80 commits.
Of those commits nothing stands out particularly.

I might have to adjust the tree each night to binary chop the problem. That will take about a week.
I'll need you to call out good or bad each day.
(2015-10-07, 19:47)popcornmix Wrote:
(2015-10-07, 19:15)bagofcrap24 Wrote: Apologies for the delay. 1006 froze within 2 minutes on the first boot after updating.
Looks like it's something added in 4.1.9 that's causing the issue.

Thanks. Although only 8 days between 4.1.8 and 4.1.9 there are 160 commits.
I believe about 80 are in code we don't use but that still leaves 80 commits.
Of those commits nothing stands out particularly.

I might have to adjust the tree each night to binary chop the problem. That will take about a week.
I'll need you to call out good or bad each day.

I'll do what I can
Just noticed when using OMX acceleration ff/rw is broken. Video stops but timer doesn't change.
Also when seeking it only displays the progress bar for a split second (both OMX and mmal)
Not sure if this is a known issue
@Milhouse sorry for the late reply. I tested all builds since #1002 regarding the luckup on twitch-addon I reported to you on IRC yesterday, but it never happened on any version again. I'm kind of confused because the streams all palyed well without stuttering or an abnormal loading time. No idea if the twitch-addon is somehow fetching the comments on the twitch-chat because if it does that could have provoked the lockups (I tried to watch the League of Legends Worlds live stream with tons of comments each second). If they happen again, I'll try to get a proper log.
  •   
  • 1
  • 99
  • 100
  • 101(current)
  • 102
  • 103
  • 168
  •   
  Thread Closed
 
Thread Rating:
  • 10 Vote(s) - 5 Average



Logout Mark Read Team Forum Stats Members Help
OpenELEC Testbuilds for RaspberryPi (Kodi 16.0)510