•   
  • 1
  • 119
  • 120
  • 121(current)
  • 122
  • 123
  • 168
  •   
  Thread Closed
OpenELEC Testbuilds for RaspberryPi (Kodi 16.0)
(2015-10-27, 19:45)asfi Wrote: is it possible to play .mk3d or something like this ? MKV with full frame like a ISO 3D.

I try .mk3d but Kodi (through my Pi 2) play it in 2D.

I assume you are using a Milhouse build?

.mkv is fine as an extension. You should add 3D tags to filename (e.g. include .3D.MVC. in filename).
Make sure 3D stream was ripped with makemkv (post mediainfo of file to be sure).
In settings/video/acceleration enable "Support MVC video" and "Use Full HD HDMI modes for 3D" (if you TV supports framepacking modes).
In settings/video/playback enable "Adjust display refresh rate to match video".

When you play video it should offer the choice to play as Mono or 3D.
When I start kodi the tvheadend addon isn't working. If I deactivate and reactivate the addon all working good.

dmesg http://sprunge.us/ICQQ
kodi.log http://sprunge.us/AccA
journalctl http://sprunge.us/cJKI
(2015-10-27, 19:52)popcornmix Wrote: In settings/video/acceleration enable "Support MVC video" and "Use Full HD HDMI modes for 3D" (if you TV supports framepacking modes).


I wanted to ask this a long time now.
I have a Panasonic Plasma 3D, Yamaha RX-V571 and using this testbuilds or OpenElec 5.95.5.
If I enable the option "Use Full HD HDMI modes for 3D" I often get only a black screen. Sometimes the audio plays but I have the blackscreen.
One time a movie started with this option enabled but it was really only one time.

What is this option precisely?
(2015-10-27, 20:46)Kendos Wrote: I wanted to ask this a long time now.
I have a Panasonic Plasma 3D, Yamaha RX-V571 and using this testbuilds or OpenElec 5.95.5.
If I enable the option "Use Full HD HDMI modes for 3D" I often get only a black screen. Sometimes the audio plays but I have the blackscreen.
One time a movie started with this option enabled but it was really only one time.

What is this option precisely?

Read this: http://www.best-3dtvs.com/what-is-frame-packing-3d/

If kodi uses a standard 1920x1080 hdmi mode, the usual way to get 3D content displayed is to transmit the picture as side-by-side or top-and-bottom which halves the resolution in that direction.
The framepacking "Full HD" option allows each eye to be full 1920x1080 resolution and so has double the resolution.

However some TVs/receivers don't support framepacking modes. Also there seems to be a problem with some equipment not detecting the switch properly. It's something I'd like to find a solution to, but the displays I have don't have this problem.

If you are using a receiver, I'd be interested if bypassing it (connect Pi directly to TV) helps this issue.
I know what framepacking is but I didnt know what this option do.

I have tried some movies to start with the Pi connected to the TV and it started without problems.
Then I tried again with the receiver and at the moment it works too and I dont know why. Huh

I even turned off TV, receiver and Pi and tried again and it worked too.
My TV doesnt give information about the 3D content displayed it only shows "1080p/24 - 3D".
Can I somehow see what the Pi is sending?
(2015-10-27, 21:23)Kendos Wrote: Can I somehow see what the Pi is sending?

Yes, if you ssh in and run "tvservice -s" it will show resolution, frame rate and 3D mode (SBS/TAB/FP).

Let me know if you spot any pattern for when the 3D switching works or doesn't work. This is something I'd very much like to understand.
I tried now something because it didnt work again and I found something out.
I used only 5.95.5.

If I connect directly to the tv it works everytime and connected first to the receiver and then TV it dont work but I found a workaround.
I connect the Pi to the tv and start a movie with "Full 3D Enabled", it works and the Pi is sending FP.
I now connect the Pi to the receiver without turning either tv or Pi off and it works now too and that is confusing.

Its like the Pi needs to know that the TV and receiver can display FP and for me it looks like a handshake problem.
If it dont work the receiver isnt displaying that it has a audio signal, it shows only "decoder off".
2D works every time with the same 3D file.
(2015-10-27, 20:42)polo_joe Wrote: When I start kodi the tvheadend addon isn't working. If I deactivate and reactivate the addon all working good.

dmesg http://sprunge.us/ICQQ
kodi.log http://sprunge.us/AccA
journalctl http://sprunge.us/cJKI

Did this behaviour start recently? Which OpenELEC build does it start with?

Although to be honest I really don't know anything about tvheadend. Make sure you are using the latest tvheadend addon that is uploaded after each build (or maybe that's part of the problem - did an older tvheadend work better?), or run it past the tvheadend developers as it's their addon/server etc.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2015-10-27, 22:25)Kendos Wrote: If I connect directly to the tv it works everytime and connected first to the receiver and then TV it dont work but I found a workaround.
I connect the Pi to the tv and start a movie with "Full 3D Enabled", it works and the Pi is sending FP.
I now connect the Pi to the receiver without turning either tv or Pi off and it works now too and that is confusing.

Its like the Pi needs to know that the TV and receiver can display FP and for me it looks like a handshake problem.
If it dont work the receiver isnt displaying that it has a audio signal, it shows only "decoder off".
2D works every time with the same 3D file.

With "Use Full HD HDMI modes for 3D" disabled does it work every time, or still fail?

Can you first add hdmi_force_hotplug=1 to config.txt (and reboot). Not expecting it to fix anything, but removes a variable in the following tests.

A couple more experiments may be interesting. If you play the 3D video and get a blank screen. Can you:
Power the TV off and on again.
Change AV input away and back with remote on TV
Power the receiver off an on again.
Change AV input away and back with remote on receiver.
Unplug and then replug hdmi cable from receiver to TV.
Unplug and then replug hdmi cable from Pi to receiver.
Unplug hdmi cable from Pi to receiver and directly connect it from Pi to TV.

Do any of those make the picture reappear?

Can you also add "config_hdmi_boost=7" to config.txt (and reboot). If that doesn't help try "config_hdmi_boost=11".
I don't think that will help, but it's a simple thing to rule out. If it doesn't help you can remove it.
(2015-10-28, 00:01)popcornmix Wrote: With "Use Full HD HDMI modes for 3D" disabled does it work every time, or still fail?

Can you first add hdmi_force_hotplug=1 to config.txt (and reboot). Not expecting it to fix anything, but removes a variable in the following tests.

A couple more experiments may be interesting. If you play the 3D video and get a blank screen. Can you:
Power the TV off and on again. [still blackscreen]
Change AV input away and back with remote on TV [still blackscreen]
Power the receiver off an on again. [still blackscreen]
Change AV input away and back with remote on receiver. [still blackscreen]
Unplug and then replug hdmi cable from receiver to TV. [will try]
Unplug and then replug hdmi cable from Pi to receiver. [still blackscreen]
Unplug hdmi cable from Pi to receiver and directly connect it from Pi to TV. [still blackscreen]

Do any of those make the picture reappear?

Can you also add "config_hdmi_boost=7" to config.txt (and reboot). If that doesn't help try "config_hdmi_boost=11".
I don't think that will help, but it's a simple thing to rule out. If it doesn't help you can remove it.

I will try the settings in the config.txt tomorrow (its already 11PM here).
But some testing I had already done (see above in the quote) and yes, with "Use Full HD HDMI modes for 3D" disabled it works everytime.
I will do tomorrow the same with the settings.

How big is the disadvantage to disable omxplayer?
Because with omxplayer disabled the movies started with no blackscreen but I will do more testing tomorrow.
(2015-10-28, 00:13)Kendos Wrote: How big is the disadvantage to disable omxplayer?
Because with omxplayer disabled the movies started with no blackscreen but I will do more testing tomorrow.

omxplayer is disabled by default on Pi2 and is the recommended option, so no disadvantage.

If you are willing it would be useful if you can continue to run tests (with omxplayer enabled) to try to sort out the issue.

I suspect that omxplayer enabled/disabled is not actually the reason for the blank screen. I suspect it is a timing issue and with your current setup,
omxplayer enabled is hitting the issue and disabled is not hitting the issue.

Another config,txt test is to add "hdmi_clock_change_limit=10". Again not likely to fix it, but a simple test for something that is just possible.
New OpenELEC Jarvis build #1027: RPi / RPi2
(Supercedes previous build)

Code:
# uname -a
Linux rpi512 4.1.11 #1 Tue Oct 27 21:29:05 GMT 2015 armv6l GNU/Linux

# vcgencmd version
Oct 23 2015 16:28:38
Copyright (c) 2012 Broadcom
version c1a8b643677011791abeea1f5dc3a4738349ea55 (clean) (release)

# lsb_release
OpenELEC (Milhouse) - Version: devel-20151027212811-#1027-g0847aae [Build #1027]

# vcdbg log msg 2>&1 | grep DTOK
001739.917: Kernel trailer DTOK property says yes

# Kernel device tree status: Enabled

Based on tip of OpenELEC master (0847aaec, changelog) and tip of XBMC master (e83e2f94, changelog) with the following modifications: Build Highlights:
  1. Restore "hide watched for home screen widgets" support
Build Details:
  1. OpenELEC:
    • kodi: add PR8254 (3c411691)
    • kodi: add upstream patch (24fc5b39)
    • projects/imx6/linux: build CONFIG_I2C_MUX as module (0847aaec)
  2. XBMC:
    • [xcode] add xbmc/addons/include directory to project (exists for ages… (PR:8302, 1 commit, 1 file changed)
    • [guiinfo] Fixed LISTITEM_ISRECORDING for epg event items ... (PR:8301, 1 commit, 1 file changed)
    • CHG: [droid] decouple kodi and system audio volumes (PR:8291, 1 commit, 4 files changed)
  3. pvr.hts:
    • Fix Settings ctor initialization, closes #128 (PR:129, 1 commit, 1 file changed)
  4. pvr.nextpvr:
    • Fixed potential issue with last pull request. (PR:30, 1 commit, 3 files changed)
  5. newclock5:
    • New commits in this build:
      • VideoPlayer: Remove SetFileItem method. RTMP needs a different solution (f50ff5ae)
  6. Additional commits/pull requests/changes not yet merged upstream:
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2015-10-27, 19:52)popcornmix Wrote:
(2015-10-27, 19:45)asfi Wrote: is it possible to play .mk3d or something like this ? MKV with full frame like a ISO 3D.

I try .mk3d but Kodi (through my Pi 2) play it in 2D.

I assume you are using a Milhouse build?

.mkv is fine as an extension. You should add 3D tags to filename (e.g. include .3D.MVC. in filename).
Make sure 3D stream was ripped with makemkv (post mediainfo of file to be sure).
In settings/video/acceleration enable "Support MVC video" and "Use Full HD HDMI modes for 3D" (if you TV supports framepacking modes).
In settings/video/playback enable "Adjust display refresh rate to match video".

When you play video it should offer the choice to play as Mono or 3D.

Thank you, with .3D.MVC. in filename it works Smile
I have recently set up my RPI2 and installed OpenELEC and have gotten everything working except Dolby TrueHD. It was my understanding that the newer builds can decode TrueHD and output as PCM, however, no matter what settings I try, I cannot get the center channel working. The only way I can hear voices is if I change the speaker setting to 2.1 or 4.1, but any higher and the center channel goes missing. What can I do to fix this? Thanks.
(2015-10-28, 03:35)tate1293 Wrote: I have recently set up my RPI2 and installed OpenELEC and have gotten everything working except Dolby TrueHD. It was my understanding that the newer builds can decode TrueHD and output as PCM, however, no matter what settings I try, I cannot get the center channel working. The only way I can hear voices is if I change the speaker setting to 2.1 or 4.1, but any higher and the center channel goes missing. What can I do to fix this? Thanks.

What does the first line of the codec info show when playing the video?
  •   
  • 1
  • 119
  • 120
  • 121(current)
  • 122
  • 123
  • 168
  •   
  Thread Closed
 
Thread Rating:
  • 10 Vote(s) - 5 Average



Logout Mark Read Team Forum Stats Members Help
OpenELEC Testbuilds for RaspberryPi (Kodi 16.0)510