•   
  • 1
  • 137
  • 138
  • 139(current)
  • 140
  • 141
  • 168
  •   
  Thread Closed
OpenELEC Testbuilds for RaspberryPi (Kodi 16.0)
When normal drivers for HiFiBerry DIGI + are added to kernel 4.3.0?
(2015-11-13, 02:50)Milhouse Wrote:
(2015-11-13, 02:16)albertstroh77 Wrote: Just tried the 11-12 version and the hifiberry quit working. There was no option to choose it in the audio output. Tried the 11-10 version and it was working then. Had the option to choose pulse audio and it was working.

Edit: Sorry, not sure how the multiple posts happened.

So it works with #1110.
Doesn't work with #1112.
Is the Hifiberry working with #1111b?

There are no kernel config changes between #1110 and #1112. There is a firmware change in #1111, and PulseAudio is entirely disabled starting with #1111 (until the passthrough issue is resolved).

Hifiberry works with #1110, but audio output settings for it missing in #1111b and #1112
(2015-11-13, 10:09)beertank Wrote: Hifiberry works with #1110, but audio output settings for it missing in #1111b and #1112

Can you paste the output from "dmesg | paste", "aplay -l | paste" and "lsmod | sort | paste" from both build #1110 and build #1111b?

Also, the output of "ls -la /storage/.config/modules-load.d | paste" (doesn't matter which build). Thanks.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
TouchScreen issues with #1109

** FORGET THIS - FIX WITH A COLD BOOT **

Just had to do a clean install after breaking my system, gone back to 1109 as this was the last working one for me (didn't try #1110). I have i2S soundcard and touch screen.

With touchscreen long hold does not activate right click context menu.
Under system menu, touching submenu tabs highlights them blue but does not open menu, I have to use a mouse for right clicks and to open system submenus.
(2015-11-13, 10:09)beertank Wrote:
(2015-11-13, 02:50)Milhouse Wrote:
(2015-11-13, 02:16)albertstroh77 Wrote: Just tried the 11-12 version and the hifiberry quit working. There was no option to choose it in the audio output. Tried the 11-10 version and it was working then. Had the option to choose pulse audio and it was working.

Edit: Sorry, not sure how the multiple posts happened.

So it works with #1110.
Doesn't work with #1112.
Is the Hifiberry working with #1111b?

There are no kernel config changes between #1110 and #1112. There is a firmware change in #1111, and PulseAudio is entirely disabled starting with #1111 (until the passthrough issue is resolved).

Hifiberry works with #1110, but audio output settings for it missing in #1111b and #1112

Same thing for me

(2015-11-13, 10:46)Milhouse Wrote:
(2015-11-13, 10:09)beertank Wrote: Hifiberry works with #1110, but audio output settings for it missing in #1111b and #1112

Can you paste the output from "dmesg | paste", "aplay -l | paste" and "lsmod | sort | paste" from both build #1110 and build #1111b?

Also, the output of "ls -la /storage/.config/modules-load.d | paste" (doesn't matter which build). Thanks.

The weird thing is that the sound is working after installing #1111b or #1112 but when i go into system settings or reboot the Raspberry it's gone.
Here are the logs :

#1110

http://sprunge.us/MTLE
http://sprunge.us/cPhE
http://sprunge.us/hSGb

1112# Only installing update and play files(Sound)

http://sprunge.us/DMFZ
http://sprunge.us/NLMR
http://sprunge.us/RPIA



#1112 Rebooting or going into system settings(No sound)

http://sprunge.us/YNjZ
http://sprunge.us/BAWN
http://sprunge.us/ObbL

ls -la /storage/.config/modules-load.d

http://sprunge.us/dMaT
Milhouse Wrote:
hansolo77 Wrote:I'll ask a different question.. Is it possible to go into a "failing" addon's script file and simply change where it calls for DVDPlayer to VideoPlayer?
Can't say for sure, but it's quite possible that will work.
@Milhouse, thanks for this simple tip within Post: #1842 of this thread which I have just used to modify one string within an existing script of ITV player addon, which ensures the live streams as well as catch-up are working in these latest testbuilds. (tested with #1112) CoolCool
rPi 3, SanDisk Ultra 8Gb SD & Milhouse LE TestBuild (Kodi 18) -> Onkyo AV -> Philips 42" LCD TV
(2015-11-13, 10:46)Milhouse Wrote:
(2015-11-13, 10:09)beertank Wrote: Hifiberry works with #1110, but audio output settings for it missing in #1111b and #1112

Can you paste the output from "dmesg | paste", "aplay -l | paste" and "lsmod | sort | paste" from both build #1110 and build #1111b?

Also, the output of "ls -la /storage/.config/modules-load.d | paste" (doesn't matter which build). Thanks.

#1110:
http://sprunge.us/RROb
http://sprunge.us/afdU
http://sprunge.us/VBKZ

#1111b:
http://sprunge.us/gBVZ
http://sprunge.us/cgXY
http://sprunge.us/bieO
http://sprunge.us/DWEI
New OpenELEC Jarvis build #1113: RPi / RPi2
(Supercedes previous build)

Code:
# uname -a
Linux rpi512 4.3.0 #1 Fri Nov 13 23:08:29 GMT 2015 armv6l GNU/Linux

# vcgencmd version
Nov 11 2015 21:36:20
Copyright (c) 2012 Broadcom
version 54011a8ad59a9ae1c40bd07cddd9bcf90e779b66 (clean) (release)

# lsb_release
OpenELEC (Milhouse) - Version: devel-20151113230740-#1113-g60c4d40 [Build #1113]

# vcdbg log msg 2>&1 | grep DTOK
001692.112: Kernel trailer DTOK property says yes

# Kernel device tree status: Enabled

Based on tip of OpenELEC master (60c4d40d, changelog) and tip of XBMC master (9c7322e4, changelog) with the following modifications: Build Highlights:
  1. Switch from rpi-4.3.y to rpi-4.3.y_rebase, which includes PR;1178:
    • Support for Linux ATAGS has been removed
    • Device Tree is now mandatory - if you have the following in your config.txt your device will not boot:
      Code:
      device_tree=
    • This change should reduce the number of out-of-tree Linux patches that need to be maintained
Build Details:
  1. OpenELEC:
    • libpng: update to libpng-1.6.19 (60c4d40d)
  2. XBMC:
    • Music file view content as "files" and still have "media info" view type (PR:8377, 1 commit, 2 files changed)
    • AE: fix GetDelay - only apply time correction to sink delay (PR:8379, 1 commit, 2 files changed)
  3. dcadec:
    • Add API concept of positive warning codes. (67758a82)
    • Remove check for extra XBR and X96 channels. (57012a4b)
  4. kernel 4.3.y_rebase:
    • New commits in this build:
      • squash: include ARCH_BCM2708 / ARCH_BCM2709 (22401464)
    • Commits no longer in build:
      • BCM2708: Use upstream interrupt driver on all Pi1's (4a57b61b)
      • BCM270x: Switch to firmware driver (a2416c9a)
      • BCM2708: Use brcm,bcm2835-system-timer (de957bb0)
      • mailbox: bcm2835: Support ARCH_BCM270x (e7a8a95c)
      • Add bcm2708_gpio driver (1ebd175f)
      • bcm2708 watchdog driver (5f7a83bf)
      • bcm2835-audio: Create the platform device if the DT node is disabled (3a999971)
      • Add hwrng (hardware random number generator) driver (3ba7b24a)
      • Add Chris Boot's spi driver. (69105999)
      • ASoC: Add support for BCM2708 (573ddddc)
      • BCM2708: Add I2S support to board file (caa36c0f)
      • BCM2708: Added support for HiFiBerry Digi board Board initalization by I2C (9fe685e4)
      • Added support to reserve/enable a GPIO pin to be used from pps-gpio module (LinuxPPS). Enable PPS modules in default config for RPi. (86e63a0b)
      • bcm2709: Simplify and strip down IRQ handler (892ad15a)
      • mach-bcm270x: Enable the building of pinctrl-bcm2835 (472e1a31)
      • BCM270X_DT: Add pwm and pwm-2chan overlays (3ba398f9)
      • lirc-rpi: Make buildable on bcm2835 (0f1e587e)
      • i2c-bcm2708: Make buildable on bcm2835 (9f2b30f4)
      • bcm2708-i2s: Make buildable on bcm2835 (f5a639a7)
      • vchiq: hack: Add include depecated dma include file (2d840791)
      • bcm2709: Remove custom barrier implementation it is no different to default (95547b46)
      • dwc_otg: Remove duplicate gadget probe/unregister function (dd834a28)
      • config: remove CONFIG_CPU_SW_DOMAIN_PAN it causes panics (83c7a839)
      • BCM270X_DT: configure I2S DMA channels (d8ea31d6)
      • configs: enable SND_BCM2835_SOC_I2S (d88a42c2)
      • BCM270X_DT: switch to bcm2835-i2s (244eb406)
      • config: fix RaspiDAC Rev.3x dependencies (bd4c88f2)
      • bcm2708-i2s: Remove driver (39fee189)
      • dmaengine: bcm2708: Make legacy API available for bcm2835-dma (58c46cd9)
      • configs: Enable DMA_BCM2835 (e26d3431)
      • dmaengine: bcm2708: Change DT compatible string (b8313464)
      • dmaengine: bcm2708: Remove driver but keep legacy API (91aeeb42)
  5. Additional commits/pull requests/changes not yet merged upstream:
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2015-11-14, 01:53)beertank Wrote: #1111b:
http://sprunge.us/gBVZ

(2015-11-13, 16:28)Bor_NL Wrote: Here are the logs :

1112# Only installing update and play files(Sound)

http://sprunge.us/DMFZ

You've both got the same kernel backtrace with #1111b and #1112, which I can only imagine right now is down to the firmware change in #1111b.

The latest #1113 build is a "clean" build so please test that and see if the situation is the same (in which case another dmesg would be useful), or is now fixed.

If it's not fixed in #1113, then the output from "vcdbg log msg 2>&1 | paste" (when booting #1113) might be useful in case it's an overlay related issue.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2015-11-14, 02:46)Milhouse Wrote:
Does it need this added to config.txt?
Code:
dtparam=random=on
(I can't Try it and See until tomorrow.)
Updated from Isengard a few days ago, and noticed a problem: seeking through a file is too fast, there is not enough time for the seek/info bar animation to complete and show up before it disappears again. It's OK on confluence (but still only visible for a fraction of a second), but probably not on anything more animated.

Skin issue?
(2015-11-14, 03:03)Milhouse Wrote:
(2015-11-14, 01:53)beertank Wrote: #1111b:
http://sprunge.us/gBVZ

(2015-11-13, 16:28)Bor_NL Wrote: Here are the logs :

1112# Only installing update and play files(Sound)

http://sprunge.us/DMFZ

You've both got the same kernel backtrace with #1111b and #1112, which I can only imagine right now is down to the firmware change in #1111b.

The latest #1113 build is a "clean" build so please test that and see if the situation is the same (in which case another dmesg would be useful), or is now fixed.

If it's not fixed in #1113, then the output from "vcdbg log msg 2>&1 | paste" (when booting #1113) might be useful in case it's an overlay related issue.

No audio output settings option for hifiberry in #1113:
dmesg http://sprunge.us/BRgX
vcdbg http://sprunge.us/cZNS
(2015-11-14, 03:03)Milhouse Wrote:
(2015-11-14, 01:53)beertank Wrote: #1111b:
http://sprunge.us/gBVZ

(2015-11-13, 16:28)Bor_NL Wrote: Here are the logs :

1112# Only installing update and play files(Sound)

http://sprunge.us/DMFZ

You've both got the same kernel backtrace with #1111b and #1112, which I can only imagine right now is down to the firmware change in #1111b.

The latest #1113 build is a "clean" build so please test that and see if the situation is the same (in which case another dmesg would be useful), or is now fixed.

If it's not fixed in #1113, then the output from "vcdbg log msg 2>&1 | paste" (when booting #1113) might be useful in case it's an overlay related issue.

dmesg http://sprunge.us/RfiO
vcdbg http://sprunge.us/iiHK
(2015-11-14, 03:03)Milhouse Wrote:
(2015-11-14, 01:53)beertank Wrote: #1111b:
http://sprunge.us/gBVZ

(2015-11-13, 16:28)Bor_NL Wrote: Here are the logs :

1112# Only installing update and play files(Sound)

http://sprunge.us/DMFZ

You've both got the same kernel backtrace with #1111b and #1112, which I can only imagine right now is down to the firmware change in #1111b.

This issue was commented on here.
It's a problem with I2S driver and 4.3 kernel. It occurs when driver is closed. Does setting "keep audio alive" to "always" avoid this issue?
Presumably the PulseAudio Server masked that problem prior to #1111b by keeping the driver active, then once we removed PulseAudio...
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
  •   
  • 1
  • 137
  • 138
  • 139(current)
  • 140
  • 141
  • 168
  •   
  Thread Closed
 
Thread Rating:
  • 10 Vote(s) - 5 Average



Logout Mark Read Team Forum Stats Members Help
OpenELEC Testbuilds for RaspberryPi (Kodi 16.0)510