•   
  • 1
  • 149
  • 150
  • 151(current)
  • 152
  • 153
  • 168
  •   
  Thread Closed
OpenELEC Testbuilds for RaspberryPi (Kodi 16.0)
(2015-11-27, 11:55)Milhouse Wrote:
(2015-11-27, 04:01)npuser Wrote: @millhouse - I am not sure about a protocol to request to include a new PVR to your build. The HDHomeRun pvr is now part of kodi pvr releases and available. It appears, HDHR PVR available already in the windows/android nightly.This would be an excellent PVR add-on for all rpi 2 HDHomeRun tuner owners which seems to work as a native PVR.


https://github.com/kodi-pvr/pvr.hdhomerun

http://forum.kodi.tv/showthread.php?tid=246658

Thank you
NPuser

You might want to ask on the OpenELEC forum and see if someone is willing to add this client as I've tried building with this patch to add the package, but it fails with this error and I don't know why (OE packaging is not my strong suit).
I asked a q there. Got this cryptic response.

http://openelec.tv/forum/71-pvr-live-tv/...-oe#152551

user responded with
http://sprunge.us/gOaa

thank you
NPuser
(2015-11-27, 20:22)npuser Wrote: I asked a q there. Got this cryptic response.

http://openelec.tv/forum/71-pvr-live-tv/...-oe#152551

user responded with
http://sprunge.us/gOaa

thank you
NPuser

Good job I can just about speak cryptic. With @seo's help I've added PR:4469 which will be in tonight's build.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
New OpenELEC Jarvis build #1127: RPi / RPi2
(Supercedes previous build)

Code:
# uname -a
Linux rpi512 4.3.0 #1 Fri Nov 27 21:25:44 GMT 2015 armv6l GNU/Linux

# vcgencmd version
Nov 25 2015 17:54:26
Copyright (c) 2012 Broadcom
version fda23007cfd89bf42af864b57701b39e1ac8c552 (clean) (release)

# lsb_release
OpenELEC (Milhouse) - Version: devel-20151127212455-#1127-g4e26348 [Build #1127]

# vcdbg log msg 2>&1 | grep DTOK
001689.389: Kernel trailer DTOK property says yes

# Kernel device tree status: Enabled

Based on tip of OpenELEC master (4e263486, changelog) and tip of XBMC master (3a87b76e, changelog) with the following modifications: Build Highlights:
  1. Add pvr.hdhomerun client
  2. CNetwork - implement IPv6
  3. dcadec v0.1.0; libcec updates
  4. Fix TrueHD passthrough
Build Details:
  1. XBMC:
    • Time sometimes moves backwards coming up from base libraries (PR:8426, 1 commit, 1 file changed)
    • [MySQL] Workaround MySQL 5.7.x query optimiser changes (PR:8393, 2 commits, 2 files changed)
    • FIX: allow to delete a default key binding (PR:8430, 1 commit, 4 files changed)
    • [PVR] Mark Created ChannnelGroups as Loaded on Persist (extra fix #16365) (PR:8445, 1 commit, 1 file changed)
  2. dcadec:
    • Set SONAME for shared library, install a symlink. (95e447ab)
    • Rename version defines and stabilize the API. (feb6ceb4)
    • Release version 0.1.0. (2449e5d0)
    • Add link to lib with the lib*.so.[0-9] pattern (5bc00958)
  3. libcec:
    • changed: added #include to make the IDE happy. not actually used when compiling (f816e4bb)
    • fixed: combo key (stop by default) in the EventGhost plugin. fixes #128 (a39a5599)
    • fixed: unused var (0eb74da4)
    • fixed: silence compiler warnings (d8795318)
    • changed: clean up device detection code a bit and replace winapi calls with CM_* calls. issue #130 (de14cd45)
    • changed: replaced lockdev by flock. closes #141 (ff86c07a)
  4. pvr.dvblink:
    • Native Kodi timers support and some fixes (PR:31, 5 commits, 30 files changed)
  5. newclock5:
    • New commits in this build:
      • AE: fix passthrough for truehd (10362ce2)
    • Commits no longer in build:
      • Fix ticket 15727, SMS input not updating CGUIKeyboardGeneric (39aa5fae)
  6. Additional commits/pull requests/changes not yet merged upstream:
    • Updated: [env] patch: Enable pvr addons, disable pvr updates
    • Added: [env] PR:4469: Add pvr hdhomerun
    • Added: [pkg] PR:7030: CNetwork - implement IPv6
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2015-11-27, 16:11)popcornmix Wrote:
(2015-11-27, 13:32)username145 Wrote: Works great in #1112, breaks (no audio when playing roms in retroarch) in #1113

This is the switch to device-tree only. Can you try adding to config.txt:
Code:
dtparam=audio=on

Thanks, that seems to have done the trick!

Is there any reason not to have that setting?
I purchased a Pi2 2 a couple of weeks ago and have been running the latest stable version 6.0.0 of openelec successfully with no issues. I have tried to upgrade to the latest test builds out of curiosity more than anything but the issue I have is that Bitstreaming does not work on any of these versions, the audio is always output as lpcm to my AVR despite the correct settings being used. I cant seem to find anybody else with the same issue by searching. Can anybody help me with that?
Post a screenshot of your audio settings.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2015-11-28, 07:54)Milhouse Wrote: Post a screenshot of your audio settings.

Image

Image
Use imgur.com to host images - it works.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
So bitstreaming (passthrough) works correctly with OpenELEC 6.0, but with these test builds you only get PCM when playing the same files that worked with OE6? Hmmm... can you login to the Pi using ssh (username: root, password: openelec) and run the following commands:
Code:
systemctl stop kodi
cd /storage/.kodi/userdata
mv guisettings.xml guisettings.xml.bak
systemctl start kodi
You will need to reconfigure your audio, re-enabling passthrough etc., but see if that helps.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
That's correct, I have tried as you suggested, like you said it re-set my audio settings and I re enabled pass-through but it is still outputting LPCM. Should I post Logs? I will need to read up on how to do it though.
Yes, posting a debug log (wiki) would be the next step.

Edit: Easiest way now that you have ssh access is to enable debug in Settings > System > Logging > Enable debug logging, play your video, then in ssh:
Code:
paste /storage/.kodi/temp/kodi.log
You'll now have a url visible in ssh, copy/paste it into a new postin this thread.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
O.K so the strangest thing just happened. I enabled de bug logging and restarted Kodi, when I played a movie with a DTS soundtrack hey presto it's working and my AVR is decoding the audioHuh I disabled logging restarted again and it's still working fine, no more problem. I will leave people much smarter than me to try and puzzle that out, Thanks very much for your help Milhouse.
Since build # 1122 I am having problems with mkv files, the screen is blank and no video,

here is the log

http://xbmclogs.com/pslauzwiq

thank you!
(2015-11-28, 10:48)faberyx Wrote: Since build # 1122 I am having problems with mkv files, the screen is blank and no video,

here is the log

http://xbmclogs.com/pslauzwiq
I noticed this too. It only seems to happen when playing a file with HD audio and the 8-channel HD audio decoding option enabled. When I switch to passthrough, playback works again.

Switching from OMX to MMAL also seems to fix the problem, but I'm still preferring OMX, because for some reason when using MMAL I always get intermittent video stuttering when playing 23.976 material.
(2015-11-27, 21:22)Milhouse Wrote:
(2015-11-27, 20:22)npuser Wrote: I asked a q there. Got this cryptic response.

http://openelec.tv/forum/71-pvr-live-tv/...-oe#152551

user responded with
http://sprunge.us/gOaa

thank you
NPuser

Good job I can just about speak cryptic. With @seo's help I've added PR:4469 which will be in tonight's build.

Thank you Milhouse. The PVR Hdhomerun works great.

This PVR pulls epg from HDHR servers and layout of the epg is very good. Looks like 'Record' option is yet to come but overall I liked what I see

No issues to report yet.

Thank you again.
Npuser
  •   
  • 1
  • 149
  • 150
  • 151(current)
  • 152
  • 153
  • 168
  •   
  Thread Closed
 
Thread Rating:
  • 10 Vote(s) - 5 Average



Logout Mark Read Team Forum Stats Members Help
OpenELEC Testbuilds for RaspberryPi (Kodi 16.0)510