Thread Closed
OpenELEC Testbuilds for RaspberryPi (Kodi 16.0)
Okay, I renamed the .kodi to .kodi.bak and rebooted. I set up pvr.mythtv and the settings for audio and video as I described above, but switched to adjust pll for the audio sync. After less than 1 hour, the video got real jerky and this is what ps shows:
http://sprunge.us/DZZi
As you can see, the lowest kodi.bin pid (444) is being quite the hog, and another thread is not far behind.
And here is a copy of the log file
http://sprunge.us/DPdO

I'm using videoplayer with mmal enabled and the default interlacing

Here is what htop shows during the liveTV playback:

Code:
1  [||||||||||||||||                                         24.0%]     Tasks: 19, 49 thr; 2 running
  2  [|||||                                                     6.2%]     Load average: 1.41 1.36 1.33
  3  [||||||||||||||||||||||||||||||||||||||||||||||||||||||||100.0%]     Uptime: 00:59:08
  4  [||||||                                                    8.2%]
  Mem[||||||||||||||||||||||||||||||||                     181/737MB]
  Swp[                                                         0/0MB]

  PID USER      PRI  NI  VIRT   RES   SHR S CPU% MEM%   TIME+  Command
  444 root       20   0  607M  143M 30900 S 143. 19.4 59:36.63 /usr/lib/kodi/kodi.bin --standalone -fs --lircdev /run/lirc/lircd
  593 root       20   0  607M  143M 30900 R 101. 19.4 33:00.01 /usr/lib/kodi/kodi.bin --standalone -fs --lircdev /run/lirc/lircd
  587 root       20   0  607M  143M 30900 S 26.4 19.4 15:02.07 /usr/lib/kodi/kodi.bin --standalone -fs --lircdev /run/lirc/lircd
  592 root       20   0  607M  143M 30900 S  2.9 19.4  1:48.14 /usr/lib/kodi/kodi.bin --standalone -fs --lircdev /run/lirc/lircd
  449 root       19  -1  607M  143M 30900 S  1.9 19.4  1:01.67 /usr/lib/kodi/kodi.bin --standalone -fs --lircdev /run/lirc/lircd
  450 root       19  -1  607M  143M 30900 S  1.4 19.4  1:03.07 /usr/lib/kodi/kodi.bin --standalone -fs --lircdev /run/lirc/lircd
  884 root       20   0  2868  2020  1752 R  1.4  0.3  0:00.89 /storage/.kodi.bak/addons/debug.tools.htop/bin/htop
  448 root       20   0  607M  143M 30900 S  1.0 19.4  0:46.21 /usr/lib/kodi/kodi.bin --standalone -fs --lircdev /run/lirc/lircd
  591 root       19  -1  607M  143M 30900 S  1.0 19.4  0:35.95 /usr/lib/kodi/kodi.bin --standalone -fs --lircdev /run/lirc/lircd
  454 root       19  -1  607M  143M 30900 S  0.5 19.4  0:12.50 /usr/lib/kodi/kodi.bin --standalone -fs --lircdev /run/lirc/lircd
  462 root       20   0  607M  143M 30900 S  0.5 19.4  0:18.78 /usr/lib/kodi/kodi.bin --standalone -fs --lircdev /run/lirc/lircd
  523 root       21   1  607M  143M 30900 S  0.5 19.4  0:13.15 /usr/lib/kodi/kodi.bin --standalone -fs --lircdev /run/lirc/lircd
  482 root       20   0  607M  143M 30900 S  0.5 19.4  0:08.95 /usr/lib/kodi/kodi.bin --standalone -fs --lircdev /run/lirc/lircd
  455 root       19  -1  607M  143M 30900 S  0.5 19.4  0:15.87 /usr/lib/kodi/kodi.bin --standalone -fs --lircdev /run/lirc/lircd
F1Help  F2Setup F3SearchF4FilterF5Tree  F6SortByF7Nice -F8Nice +F9Kill  F10Quit

Let me know if I can provide anything else.

EDIT: BTW, OMXPlayer seems to be working again. I don't know if it's because I renamed the directory or because I installed the 1201 build. If it matters, all my recording and live TV rely on MPEG2 decoding. Maybe that's the difference that I have. zaphod24 has a similar setup to me, but he may be using the HDHomerun tuners that stream H.264 whereas mine streams MPEG2 (cheaper model).
Experience: It's what you get when you were expecting something else.
  Thread Closed
 
Thread Rating:
  • 10 Vote(s) - 5 Average


Messages In This Thread
Bluetooth on #1003 - by cdvreede - 2015-10-13, 11:08
Re: RE: Bluetooth on #1003 - by Milhouse - 2015-10-13, 13:24
RE: OpenELEC Testbuilds for RaspberryPi (Kodi 16.0) - by afremont - 2015-12-02, 17:03


Logout Mark Read Team Forum Stats Members Help
OpenELEC Testbuilds for RaspberryPi (Kodi 16.0)510