•   
  • 1
  • 120
  • 121
  • 122(current)
  • 123
  • 124
  • 339
  •   
Intel VAAPI howto with Leia v18 nightly based on Ubuntu 18.04 server
(2015-11-02, 08:46)fritsch Wrote:
(2015-11-02, 03:18)Matt Devo Wrote: fritsch, before you roll out your "final" OE6+EGL build, would you mind adding some patches (from the kernel bug tracker) to 4.3 to fix the thermal management on resume from suspend? Affects quite a few boards, chromeboxes in particular. I'm building/testing now and will submit a PR to you when confirmed

Just PR them and I will pick them.

done
Reply
your original marantz.bin i have already tried with the same result. as i see now wake-on-lan not working yet on my system. i will give more info in the evening.
Reply
(2015-11-02, 10:59)fritsch Wrote: Edit: "Concerning your one crash still happens" - as long as I don't see the issue I cannot help ...which crash are you talking about, what crashes?

as i can reproduce it very clear: booting tv off / avr on. turning tv on. do my hacks to get audio "xrandr". shutdown system. following picture i get on tv: http://de.tinypic.com/view.php?pic=10h0d...jctzaERPEU

System is not shut down and is not responsable anymore. this is happening with the OE 6.0 Beta 5 and also with the OE devel build from page #1.

not sure how to get more logs because system is also not reachable anymore (network is shutted down already). when connected via ssh the crash is not showed in journalctl -f because it happend after closing network.
Reply
@MattDevo: Thanks for the PR - pushed it. I hope they will add it to 4.3.1
@the-dreamer: Nice - this does only happen if you use drm_kms_helper when overwriting EDID? It does not happen when you don't use it? If it always happens on shutdown, even without edid forced, open another bug at freedesktop and supply the screenshot - thanks.

Edit: Looking at the backtrace, please file it with intel/drm on freedesktop, please - one should not be allowed to crash the kernel no matter what happens.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
i need to use kms_helper otherwise i don't get any connected device anytime. and this happen when my tv is involved by 95 % . when it is left off everything is fine. no crash. in the evening i try to get more logs regarding detecting my tv. As i have written, my notebook "haswell icore 7" is also not detecting my tv. only my avr when tv is off. Nvidia/AMD doesn't have this problem.
Reply
Yes, please file that bug an also the initial bug with the intel people - there must be a solution out of the box for your hardware, please. This dump fixing won't solve it for the other 100 joes arround with the same issue :-). So please head over to bugs.freedesktop.org or contact vsyrjala in #intel-gfx.

On the longterm when I leave to Mars or Venus - no one will maintain such hacks anymore - therefore everything needs to go upstream and fixed properly.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
I will do. i was looking already in the sources and in two weeks i have some time i will try more debugging. maybe there will be also a patch from me if i am successful regarding edid.bin.

btw: in the oe devel build from page #1 are there known problems regarding autostart.sh? it is not executed any more even when systemctl enable kodi-autostart is executed.

fyi: my notebook is not running linux. and won't be running it in the feature.
Reply
Nothing I have changed in that regard.

Edit: What has your notebook to do with it?
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
it has an intel chipset and also don't like my tv. i remember: once i have started a live kodibuntu and didn't detected my tv. i didn't discover that time the reason.
Reply
Btw. you also don't have a BIOS screen when using that TV? But its VGA Port works, right? :-) Which model is it?
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
The notebook is not showing anything via HDMI. and it is not detected in windows. but this is not really the topic here. first i thought the hw (intel) is not liking the tv. but now i see under linux that the n3150 is able to show something on tv.

The n3150 is showing bios via hdmi and vga. vga is working all the time. i believe to remember that the syslinux message is also showing.

these are some older logs with oe 6.0 beta 5 image. i think the cpio ("*ERROR* Requesting EDID firmware "edid/edid.bin" failed (err=-2)") stuff are missing there. it is fixed now but here you can see during boot with avr on / tv off sound is working and otherwise it is not when tv is on:

http://sprunge.us/UjLW ->avr on / tv on
http://sprunge.us/SLbG ->avr on / tv off

"[drm:intel_dump_pipe_config] audio: 1, infoframes: 1" output came from "->has_audio" which should be always true when drm properties is HDMI_ON which i could trace back to the xrandr --set audio on. but it don't. ELD is always valid with 8 SAD. when the system is booting with working sound and iam enabling the tv it will preserve the audio operational state. but when xrandr is called the audio is dropped. i think because it will rely on the original edid data from line which shouldn't be because i have given the edid.bin.

as i have written, i will do more logging in the evening and add a bugreport on freedesktop
Reply
Yes - please open the bug, that needs fixing upstream.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
Small hint: https://github.com/OpenELEC/OpenELEC.tv/...992fdb94ad
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
(2015-11-02, 10:57)fritsch Wrote: "-d" is not needed.

From the howto given, do the following:
Code:
sudo apt-get install ppa-purge
sudo  ppa-purge ppa:wsnipex/vaapi
sudo ppa-purge ppa:wsnipex/mesa
sudo ppa-purge ppa:wsnipex/xbmc-fernetmenta-master

Now do the ubuntu release upgrade. After the reboot do:
Code:
sudo apt-get install deborphan
sudo apt-get remove --purge `deborphan`
sudo apt-add-repository ppa:wsnipex/vaapi
sudo apt-add-repository ppa:wsnipex/xbmc-fernetmenta-master
# Yes no mesa ppa is needed anymore
sudo apt-get dist-upgrade

Now to make sure nothing is missing, do the install command again:
Code:
sudo apt-get install ssh python-software-properties software-properties-common xorg alsa-utils mesa-utils git-core librtmp1 lirc libmad0 lm-sensors libmpeg2-4 avahi-daemon libnfs8 libva1 vainfo libva-intel-vaapi-driver linux-firmware dbus-x11 openbox pastebinit

sudo apt-get install kodi kodi-bin

After a
Code:
sudo reboot

Everything should be fine.

Thank fritsch, very helpful, as always! I will proceed accordingly!

One more question: I have two friends for whom I installed the system on n3150, they do not know a lot about all this. They are on Vivid, and they do a dist-upgrade few times a week. Will they brake their Kodi if they don't upgrade to Wily? Or it would be better if I do the upgrade to Wily for them asap?
HTPC 1: ASRock N3150DC-ITX, 8GB DDR3L, 64GB SSD, Ubuntu Server 16.04 LTS + Kodi v17 EGL
HTPC 2: RPi2 + HiFiBerry DIGI+, LibreElec
Reply
thanks for hint. but currently i am not sure if the braswell support is fully in the 4.1.12 kernel inside. with 4.1.6 there was some known crashes when hdmi is not connected but forced enable. "wait for vsync timeout" for example. in the evening i will try.
Reply
  •   
  • 1
  • 120
  • 121
  • 122(current)
  • 123
  • 124
  • 339
  •   



Logout Mark Read Team Forum Stats Members Help
Intel VAAPI howto with Leia v18 nightly based on Ubuntu 18.04 server18
This forum uses Lukasz Tkacz MyBB addons.