•   
  • 1
  • 141
  • 142
  • 143(current)
  • 144
  • 145
  • 339
  •   
Intel VAAPI howto with Leia v18 nightly based on Ubuntu 18.04 server
New build is up.

Fernet is currently rewriting the handling of RAW audio - so if you are a passthrough user - check for regressions :-)
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
no problem from my newbie experience (tested flac,dolby, dts and dts hd in passthrough mode)
Reply
(2015-11-07, 13:11)BigL-New Wrote:
(2015-11-07, 11:52)fritsch Wrote: Nope - not yet. Please go to bugs.freedesktop.org and file it accordingly if this did not already happen.

Edit: Check if your kernel contains this commit, mentioned in here: https://bugs.freedesktop.org/show_bug.cgi?id=91579
Edit2: You can try drm-intel-nightly before, please: http://kernel.ubuntu.com/~kernel-ppa/mai...nt/CHANGES
The same with drm-intel-nightly. Message is little bit more informative, but still happens:

[drm:intel_pipe_update_end [i915]] *ERROR* Atomic update failure on pipe A (start=141704 end=141705) time 255 us, min 1073, max 1079, scanline start 1067, end 1084
It looks like kernel 4.4-rc1 helped a lot with this issue - no errors during 24h playback. So it looks like 4.4 will be the way to go for smooth playback (at least on BSW).
Reply
Nice. Now I only need someone to report back _if_ 44.1 khz audio for some Onkyo / Pioneer receivers also starts to work now magically.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
Only Onkyo/Pioneer is relevant?
Reply
Or if it 44.1 khz did not work _before_ for you ... but as you ask like that - you don't have an issue :-)
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
When watching live tv and it goes to commercials I get a lot of dropped and skipped frames.
kodi log : http://paste.ubuntu.com/13334117/
Also when starting certain channels I get this in the log.
ERROR: ffmpeg[7FE92AFFD700]: [mpeg2video] Invalid frame dimensions 0x0
Is that a tvheadend problem or a ffmpeg problem?
Reply
tvheadend ... (as always) ....
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
OK I will file a issue and see what he says.
Reply
This obviously isn't of major concern to the work you're doing. But would it be possible to re introduce this into the kernel
http://forum.kodi.tv/showthread.php?tid=...pid1936114

Without it, my remote ends up with limited functionality. (Last version to work fine is the one I'm currently using. OpenELEC-Generic.x86_64-6.0-devel-20151031104725-r21512-g3421da2 )
Reply
Send a PR to upstream OpenELEC, please - that's where it belongs ... then I pick it up. No need to carry it downstream.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
(2015-11-18, 12:11)fritsch Wrote: Nice. Now I only need someone to report back _if_ 44.1 khz audio for some Onkyo / Pioneer receivers also starts to work now magically.
If someone is interested here are packages with 4.4-rc1 vanilla kernel with passthrough colours patch applied (only this single patch):

http://37.235.60.68/linux-headers-4.4.0-..._amd64.deb
http://37.235.60.68/linux-image-4.4.0-rc..._amd64.deb

To use passthrough patch in Kodi put this into ~kodi/.config/openbox/autostart (please copy, don't try to write it from screen):
Code:
OUTPUT=`xrandr -q | sed '/ connected/!d;s/ .*//;q'`
xrandr -display :0 --output $OUTPUT --set "Broadcast RGB" "Full"
xrandr -display :0 --output $OUTPUT --set "Broadcast RGB" "Video 16:235 pass-through"
xrandr -display :0 --output $OUTPUT --off ; xrandr -display :0 --output $OUTPUT --auto
/usr/bin/kodi --standalone
Big thanks goes to d0dger for providing space on web-server!
Reply
Will do.
Although they usually have it included in their kernel. And since your builds are using a more up to date version I thought I'd ask.
Thank you.
Reply

(2015-11-18, 23:20)lusephur Wrote: Without it, my remote ends up with limited functionality. (Last version to work fine is the one I'm currently using. OpenELEC-Generic.x86_64-6.0-devel-20151031104725-r21512-g3421da2 )

Are you using this remote with some x86 box? With built in bluetooth?
Reply
(2015-11-18, 23:30)scf2k Wrote:
(2015-11-18, 23:20)lusephur Wrote: Without it, my remote ends up with limited functionality. (Last version to work fine is the one I'm currently using. OpenELEC-Generic.x86_64-6.0-devel-20151031104725-r21512-g3421da2 )

Are you using this remote with some x86 box? With built in bluetooth?

Using the remote on a Asus Chromebox running Fritch's openelec builds. (Well, the Oct 31st build as the remote works fine with that one.) It's connected via the supplied dongle fromTivo (it's the slide pro model that was recently released)
Reply
  •   
  • 1
  • 141
  • 142
  • 143(current)
  • 144
  • 145
  • 339
  •   



Logout Mark Read Team Forum Stats Members Help
Intel VAAPI howto with Leia v18 nightly based on Ubuntu 18.04 server18
This forum uses Lukasz Tkacz MyBB addons.