•   
  • 1
  • 221
  • 222
  • 223(current)
  • 224
  • 225
  • 339
  •   
Intel VAAPI howto with Leia v18 nightly based on Ubuntu 18.04 server
xrand http://sprunge.us/OdCM
kodi log: http://sprunge.us/IhaH
dmesg http://sprunge.us/JJTI

first codec info show: 33 skip / 2 drop
second codec info show 80 skip / 2 drop

fyi: it is my own build based on yours from 22 feb with fix for my edid problem and allow passthrough even on realtime streams.
Reply
You get the same skips with passthrough disabled?
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
yes.
Reply
I see nothing suspicuious on the logfile ... especially not between the two codec info presses, in short: no idea.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
fernet said once, skip means the rendere is too slow... is then the cpu too slow?
Reply
Skip means: render too slow, yes - so that RenderManager is starting to skip frames.
Drop means: last resort -> decoder should throw decoded frames away ...

Check with which content it happens, if it's 1080i50 - change the deinterlacing method from MCDI to Bob(*) and see (also bilinear scaling, which should be default when you use the settings I said). If it's 720p50 - change the scaler to bilinear and see what happens.


* Bob: is done in OpenGL -> this increases CPU load, but decreases gpu load.
* VAAPI-BOB: is using VAAPI for deint.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
Hi,

can someone help here. I installed Step by Step and tried to setup TVHEadend but it does not Load. (DLL error)

Here is the log
http://paste.ubuntu.com/15275383/
http://paste.ubuntu.com/15275382/
http://paste.ubuntu.com/15275380/

And kodi.log
http://paste.ubuntu.com/15275445/

Thanks a lot for all this work

S

Edit: Is it possible to load the latest Stable with the modification from wsnipex. I guess the Kodi 17 is the reason for the issues
Reply
This thread isn't for tvheadend support. There's a tvheadend subforum however

Quote:ERROR: PVR - Add-on 'Tvheadend HTSP Client' is using an incompatible API version. XBMC minimum API version = '5.0.0', add-on API version '4.2.0'
Means you need a newer version of pvr.hts than the 3.01 you are using.
There is 3.1.0 version available which is using API version 5.0.0

ppa carries it already compiled you will need to add that repo.
ppa:team-xbmc/xbmc-nightly





(2016-03-03, 20:37)alex.ba Wrote: Hi,

can someone help here. I installed Step by Step and tried to setup TVHEadend but it does not Load. (DLL error)

Here is the log
http://paste.ubuntu.com/15275383/
http://paste.ubuntu.com/15275382/
http://paste.ubuntu.com/15275380/

And kodi.log
http://paste.ubuntu.com/15275445/

Thanks a lot for all this work

S

Edit: Is it possible to load the latest Stable with the modification from wsnipex. I guess the Kodi 17 is the reason for the issues
Reply
Hi,

Quote:This thread isn't for tvheadend support. There's a tvheadend subforum however

Quote:
ERROR: PVR - Add-on 'Tvheadend HTSP Client' is using an incompatible API version. XBMC minimum API version = '5.0.0', add-on API version '4.2.0'
Means you need a newer version of pvr.hts than the 3.01 you are using.
There is 3.1.0 version available which is using API version 5.0.0

ppa carries it already compiled you will need to add that repo.
ppa:team-xbmc/xbmc-nightly

Thanks a lot that solved it :-)

Regards,

S
Reply
I rebased and dumpfixed the build to use our new theme now ... there might be rough edges, but my schedule is pretty filled currently - so don't expect anything being fixed before next week.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
new theme?
Reply
(2016-03-03, 18:22)fritsch Wrote: * Bob: is done in OpenGL -> this increases CPU load, but decreases gpu load.
* VAAPI-BOB: is using VAAPI for deint.

After some tests:
1080p23,97 no skip at all, screen is 1080i50
720p50 bilinear scaling skip every 3-4 seconds.
1080i50:
vaapi-bob: skip every 3-4 seconds
bob: skip every 30-60 seconds
deint off: no skip.

btw: you forget to bump kernel to 4.5-rc6 on your repo :-)

and your latest image cannot start kodi:

Quote:11:43:55 T:140502727776320 NOTICE: Loaded playercorefactory configuration
11:43:55 T:140502727776320 NOTICE: Loading player core factory settings from special://masterprofile/playercorefactory.xml.
11:43:55 T:140502727776320 NOTICE: special://masterprofile/playercorefactory.xml does not exist. Skipping.
11:43:55 T:140502727776320 NOTICE: Running database version Addons22
11:43:55 T:140502727776320 FATAL: addon 'service.xbmc.versioncheck' is missing.
11:43:55 T:140502727776320 FATAL: CApplication::Create: Unable to start CAddonMgr
Reply
Quote:1080p23,97 no skip at all, screen is 1080i50 <-

Screen is 1080i50 ? - how should that work correctly?
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
(2016-03-04, 12:57)fritsch Wrote:
Quote:1080p23,97 no skip at all, screen is 1080i50 <-

Screen is 1080i50 ? - how should that work correctly?

We are talking about codec info. of course every second there is a visual skip/frame stop. but my tv is not capable of 23.97.

Image

i wanted to test to see where the problem is. but it seems there is a big bottleneck in any post processing (deint and scaling)
Reply
I will try the new build after work and see if it has fixed the "black screen and mouse pointer only"-issue. If not I will provide logs.
AppleTV 4K, LG 65E6 OLED TV, Marantz NR1606, Harmony Elite
Reply
  •   
  • 1
  • 221
  • 222
  • 223(current)
  • 224
  • 225
  • 339
  •   



Logout Mark Read Team Forum Stats Members Help
Intel VAAPI howto with Leia v18 nightly based on Ubuntu 18.04 server18
This forum uses Lukasz Tkacz MyBB addons.