Intel VAAPI howto with Leia v18 nightly based on Ubuntu 18.04 server
(2015-11-06, 00:11)rob77 Wrote:
(2015-10-04, 18:20)Sunflux Wrote: Is it fixed? No, not yet. Issue seems to be that calling the new Passthrough mode does not trigger a reinitialization like it should.

At any rate, there are 2 workarounds that work on my system:

1) set Kodi to run at something other than the system default of 60hz (might be 50hz in PAL regions). For example, setting it to 59.94 works.
2) in autostart.sh, turn the display output off and then on again, ie:

Code:
xrandr --output HDMI1 --off; xrandr --output HDMI1 --auto

I do not seem to need the "sleep 1" command as originally indicated.

Thanks Fritsch

It is the same problem we had a while ago and Sunflux came up with this fix and you applied it in to your build. I have just tried it but it doesn't seem to work for me any more. I have set my default refresh rate at 50hz and the problem goes away.

I am still interested in your xrandr --verbose output. Currently I don't turn off the displays: https://github.com/fritsch/OpenELEC.tv/b...llrange.sh

Anybody else that needs to other hack?
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply


Messages In This Thread
RE: New Era: VAAPI with EGL interoperation - by fritsch - 2015-11-06, 08:49
Live TV broken again? - by schamane - 2016-02-29, 19:56
Random crashes - by hal2100 - 2016-03-08, 22:03