•   
  • 1
  • 140
  • 141
  • 142(current)
  • 143
  • 144
  • 339
  •   
Intel VAAPI howto with Leia v18 nightly based on Ubuntu 18.04 server
For information with OpenELEC-Generic.x86_64-6.0-devel-20151115183241-r21571-gd3a99d6.tar I can boot again.

So far no freeze.

No crash but one question about memory usage, I see that the memory usage increase a lot the more files are played and even more if I use seeking ( buffering impact ?).
Once I was over 3200MB memory used of 3616MB available. Is this a normal beahaviour ? No memrory unloading ?

I restart Kodi often so It's not a big deal but what would happen I don't want to restart Kodi for months ?
Reply
As long as nothing happens, check: http://www.linuxatemyram.com/
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
(2015-11-15, 21:00)fritsch Wrote: As long as nothing happens, check: http://www.linuxatemyram.com/

Ok so no worry to have. Smile
Reply
(2015-11-15, 19:26)Jorgensen Wrote: I am currently experiencing problems with my DTS-HD MA videos. I am seeing a lot of skipped frames, both visually and from the OSD info. Previously, with the old VAAPI implementation I had no issues with these videos.

If I restart the movie, the skipped frames occurs at different times in the movie. Sometimes the skipped frames occurs every 10-20 seconds, other times there are several minutes between the skipped frames. If I disable "DTS-HD MA capable receiver", I don't see any skipped frames. Videos with Dolby True HD sound works fine. My NUC is connected to my receiver via a HDMI cable.

In the log files, I start the same movie 3 times. The second time I started the movie, the skipping was the worst.

Code:
cat kodi.log | pastebinit
http://paste.ubuntu.com/13286040/
Code:
cat /var/log/Xorg.0.log | pastebinit
http://paste.ubuntu.com/13285266/
Code:
dmesg | pastebinit
http://paste.ubuntu.com/13285268/
Code:
DISPLAY=:0 vainfo | pastebinit
libva info: VA-API version 0.38.0
libva info: va_getDriverName() returns 0
libva info: Trying to open /usr/lib/x86_64-linux-gnu/dri/i965_drv_video.so
libva info: Found init function __vaDriverInit_0_38
libva info: va_openDriver() returns 0
http://paste.ubuntu.com/13285270/
Code:
id | pastebinit
http://paste.ubuntu.com/13285271/
Code:
aplay -L | pastebinit
http://paste.ubuntu.com/13285272/

Please record a new log and let the movie play for a while. At every time you notice skips press some button on keyboard/remote. This is to place an indicator in the log. The log should have at least 3 those indicators. Maybe we can identify some pattern of whats goring wrong.
Reply
Is there a specific reason the guide tells to use lanczos3? What about spline36? Is either one more cpu or gpu heavy?
My XBMC / Kodi history.
XBMC for XBOX -> XBMC for Windows -> XBMC for Android -> Kodi for Android - > Kodi v16 OE (Amlogic) -> Kodi v17 LE (NUC 2x) -> Kodi v18.5 LE (NUC 2x)
Reply
Yes. Spline36 is too heavy (implemented). Lanczos3, also called Lanczos3 Fast is our "optimal" scaler in terms of quality vs performance.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
Thanks for the quick answer.
My XBMC / Kodi history.
XBMC for XBOX -> XBMC for Windows -> XBMC for Android -> Kodi for Android - > Kodi v16 OE (Amlogic) -> Kodi v17 LE (NUC 2x) -> Kodi v18.5 LE (NUC 2x)
Reply
(2015-11-15, 21:27)FernetMenta Wrote: Please record a new log and let the movie play for a while. At every time you notice skips press some button on keyboard/remote. This is to place an indicator in the log. The log should have at least 3 those indicators. Maybe we can identify some pattern of whats goring wrong.

I have created a new log. I started the movie and for every skip I noticed, I pressed the "Guide"(?) button twice. In general, I did not see too many skips, so I jumped to next chapter two or three times in order to provoke the skips. I saw a few more skip the third time.

You can find the log here:
Code:
cat kodi.log | pastebinit
http://paste.ubuntu.com/13292890/

Let me know if you need any additional logs or information.
Reply
Wait ... What you see now in your log is just normal - a bit of skipping introduced by the seek itself.

You tell above:
Quote:I am currently experiencing problems with my DTS-HD MA videos. I am seeing a lot of skipped frames, both visually and from the OSD info. Previously, with the old VAAPI implementation I had no issues with these videos.

^^ that's what we are interested in, especially when you see something really visible - not introduced by hammering the seek button.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
(2015-11-16, 01:26)Jorgensen Wrote:
(2015-11-15, 21:27)FernetMenta Wrote: Please record a new log and let the movie play for a while. At every time you notice skips press some button on keyboard/remote. This is to place an indicator in the log. The log should have at least 3 those indicators. Maybe we can identify some pattern of whats goring wrong.

I have created a new log. I started the movie and for every skip I noticed, I pressed the "Guide"(?) button twice. In general, I did not see too many skips, so I jumped to next chapter two or three times in order to provoke the skips. I saw a few more skip the third time.

You can find the log here:
Code:
cat kodi.log | pastebinit
http://paste.ubuntu.com/13292890/

Let me know if you need any additional logs or information.

Please record a new one without skipping chapters. When you observe noticeable skips press a button that does not trigger any action.
Reply
OK, I tried to record a new log, this time the movie only played for a couple of seconds. After that it looked like the frame rate was 0.5 FPS. I waited ~20 seconds before stopping. This resulted in restart of kodi quickly followed by a grey screen.

You can find the log here, if it is useful
http://paste.ubuntu.com/13300438/

I am a bit busy tonight, but I'll try to record a new log with the skipping behavior.
Reply
(2015-11-15, 19:47)fritsch Wrote: Rebuild images online.
Changelog:
- ffmpeg 2.8.2 with one new kodi patch to fix one HEVC UHD sample
- Fernet's master

Have fun testing.
When will it land in ppa? Last change there 3 days ago.
Reply
Here are some observations after some testing tonight. Either it breaks down as in the previous log or it works fine. However, if I stop the movie and start it over a second time, I see the skips again.

Log:
http://paste.ubuntu.com/13302485/

Unfortunately, I can't see any off my button presses. I'll connect a keyboard tomorrow and record a new log.
Reply
has anyone managed to play any HEVC 4K demos on Haswell?

I tried the below just get constant freezes, I am using the following build OpenELEC-Generic.x86_64-6.0.98-fritsch.img

Complete name : Q:\Video\HD\HD Demo & Tests\4K\WILDLIFE IN 4K (ULTRA HD) 60fps.mkv
Format : Matroska
Format version : Version 4 / Version 2
File size : 373 MiB
Duration : 3mn 27s
Overall bit rate mode : Variable
Overall bit rate : 15.1 Mbps
Writing application : Lavf55.33.100
Writing library : Lavf55.33.100

Video
ID : 1
Format : VP9
Codec ID : V_VP9
Bit rate : 14.6 Mbps
Width : 3 840 pixels
Height : 2 160 pixels
Display aspect ratio : 16:9
Frame rate mode : Variable
Default : Yes
Forced : No

download link for demo
http://ul.to/outd4mpt

http://ul.to/bep676il

8k just if anyone is intrested
http://ul.to/bep676il

Thanks
TV: Sony  65" A1E Surround: Yamaha RXA-3050 + ORB Audio Mod2 7.1.2 + SVS SB12-NSD Sub Processor: Darbee + DVDO iScan Mini Players: HDI Dune Solo4K + Apple TV4K + Vu+ Ultimo 4K NAS: Qnap TVS 871 Pro i7 16GB Ram 10GBe
Reply
Haswell uses CPU acelleration only ... it is useless for 4k. Btw. what you posted is VP9 ... which is not acclerated at all :-)
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
  •   
  • 1
  • 140
  • 141
  • 142(current)
  • 143
  • 144
  • 339
  •   



Logout Mark Read Team Forum Stats Members Help
Intel VAAPI howto with Leia v18 nightly based on Ubuntu 18.04 server18
This forum uses Lukasz Tkacz MyBB addons.