Solved -  HDMI CEC not working with Sony TV (LE7.90.005 RPi3)
#1
Edited op to update issue: new RPi3, Libreelec managed CEC for just one night.

I have a problem with getting HDMI CEC working on my Sony TV (KDL-55W829B) with [initially] Open ELEC 5.95.2 6.0 on my RPi2.

- TV does support CEC (aka HDMI Link)
- Kodi Extension DOES detect the TV and says it's connected.
- Cable is CEC enabled

But no matter what I do the TV does not list the RPi as a CEC device, so nothing works.

I have tried a new cable, even bought a CEC enabled one, but since the RPi detects the TV I don't think that is the issue. Unfortunately I have no other TVs to test it with. The TV sees my Chromcast device as CEC. I have tried different HDMI slots, removed the other HDMI cable, power cycled both units etc., anything else I can try?

My thought is that is is some mismatch between OpenELEC and the Sony firmware, but how can I move this forward? Possibly this is not the right forum, but where else can I ask?
Reply
#2
Is there anywhere in the Sony's firmware / dashboard where you have to activate CEC, or to select the device that is used for CEC?

I don't have a Sony, but on my LG TV I have to select the CEC device before it functions (my Pi shows up as an HDD recorder in the list). In my case its a sub-menu off the source selection menu, but yours will of course be different.
| Banned add-ons (wiki) | Forum rules (wiki) | VPN policy (wiki) | First time user (wiki) | FAQs (wiki) | Troubleshooting (wiki) | Add-ons (wiki) | Free content (wiki) | Debug Log (wiki) | Free Movies/TV Shows |
Reply
#3
(2015-07-16, 21:45)DarrenHill Wrote: Is there anywhere in the Sony's firmware / dashboard where you have to activate CEC, or to select the device that is used for CEC?
Yes there is a list of devices to enable, but the RPi does not show up so I can't enable CEC for it. The ChromCast device appears on the list as a possible CEC device when it is plugged in, so I think that aspect of the TV is working, but it is simply not detecting presence of the RPi at all.

Is it a problem with the Sony firmware, OpenELEC, the CEC code or all three?
Reply
#4
In Kodi goto openelec configuration addon and in there I think there's some settings you can change for CEC.
Reply
#5
I'm not exactly sure what settings are in there or what they do as I've never had to use them Sad
Reply
#6
(2015-07-16, 22:30)Steve_uk Wrote: I'm not exactly sure what settings are in there or what they do as I've never had to use them Sad

Settings > System > Input devices > CEC Adapter

(this is the normal menu settings, not the Openelec settings in the add-on).
| Banned add-ons (wiki) | Forum rules (wiki) | VPN policy (wiki) | First time user (wiki) | FAQs (wiki) | Troubleshooting (wiki) | Add-ons (wiki) | Free content (wiki) | Debug Log (wiki) | Free Movies/TV Shows |
Reply
#7
(2015-07-16, 23:12)DarrenHill Wrote:
(2015-07-16, 22:30)Steve_uk Wrote: I'm not exactly sure what settings are in there or what they do as I've never had to use them Sad

Settings > System > Input devices > CEC Adapter

(this is the normal menu settings, not the Openelec settings in the add-on).
Cheers mate like I said I couldn't remember exactly where they were just knew there were some somewhere lol
Reply
#8
So I go to the CEC settings menu (Settings > System > Input devices > CEC Adapter)
All values are the default

Enabled: Enabled
Switch source to this device of startup: Enabled
Devices to power on during startup: TV
Devices to power off during shutdown: TV
Send inactive source command on shutdown: disabled
Put devices in standby mode when activating screensaver: disabled
Wake devices when deactivating the screen saver: Enabled
When TV is switched off: ignore
Devices to also put in standby mode: disabled
Use TV language setting: enabled
Pause playback when switching to another source: enabled
Physical address: 0
COM port:

What do I need to change to persuade the TV to see the RPi as a CEC device?
Reply
#9
(2015-07-17, 09:39)DaveBlake Wrote: So I go to the CEC settings menu (Settings > System > Input devices > CEC Adapter)
All values are the default

Enabled: Enabled
Switch source to this device of startup: Enabled
Devices to power on during startup: TV
Devices to power off during shutdown: TV
Send inactive source command on shutdown: disabled
Put devices in standby mode when activating screensaver: disabled
Wake devices when deactivating the screen saver: Enabled
When TV is switched off: ignore
Devices to also put in standby mode: disabled
Use TV language setting: enabled
Pause playback when switching to another source: enabled
Physical address: 0
COM port:

What do I need to change to persuade the TV to see the RPi as a CEC device?
I'm no expert but them settings seem OK.
Do you have another CEC tv you could plug to pi into just to see if it works if it does its your tv if it doesn't its your pi
Sorry I'm only clutching at straws here but when your pi boots us do you see the pulse eight service thing pop up saying loaded?
I think that needs to be running and I think its a service addon so check in there.
You may be best turning on your debug log and restarting and then check your log and look for any errors.
Reply
#10
(2015-07-16, 22:18)DaveBlake Wrote: Yes there is a list of devices to enable, but the RPi does not show up so I can't enable CEC for it. The ChromCast device appears on the list as a possible CEC device when it is plugged in, so I think that aspect of the TV is working, but it is simply not detecting presence of the RPi at all.

Is it a problem with the Sony firmware, OpenELEC, the CEC code or all three?

Your CEC settings on the Pi looks fine (or at least the same as mine).

On your TV, what devices are listed? On my LG TV the Pi is listed as "HDD Recorder", so is there a chance that the Pi is in the list but under a name you're not recognising it by? In my case it's easy to see as it's the only other option than "Watch TV", but if I don't select it then the CEC doesn't work as the TV doesn't know to send it there.

Also have you tried all the HDMI ports on your TV? I know for some makes/models the CEC is not available on all ports, sometimes it's just HDMI1 or at least a limited sub-set of the available ports (on mine I can use CEC on HDMI1, but not HDMI2).
| Banned add-ons (wiki) | Forum rules (wiki) | VPN policy (wiki) | First time user (wiki) | FAQs (wiki) | Troubleshooting (wiki) | Add-ons (wiki) | Free content (wiki) | Debug Log (wiki) | Free Movies/TV Shows |
Reply
#11
I have sony 55w829+rpi2 (last Kodi beta) and all works fine...
(my setup rpi2 -> denon ress -> sony)
Reply
#12
Yes I get the Pulse 8 connected message when Pi boots up - Pi sees the TV. With only Pi connected the TV does not list any CEC devices, it is not mistitled but absent. Unfortunately no spare TV to test system.

(2015-07-17, 10:57)conx Wrote: I have sony 55w829+rpi2 (last Kodi beta) and all works fine...
(my setup rpi2 -> denon ress -> sony)
Conx, could you tell me the Sony firmware version you are on, version of CEC Adapter and what OpenELEC version you have? Could you try pluging RPi straight into TV without Denon in the middle. Eager to discover why yours woks and mine doesn't.
Reply
#13
I posted on the openelec forum months ago with a bloke having the same problem I couldn't help him really but someone got it working on theirs.
Have a look through here.
http://openelec.tv/forum/118-consumer-el...samsung-tv
Reply
#14
If in any way relevant, a post from a couple of years ago with similar issues:

https://community.sony.co.uk/t5/televisi...d-p/338407

It states that the RPi appears by device name when all is working - and that the 'fix' in this case was to fully power-off everything with a plug. Seems a little obvious, but what the hell, I'll mention it anyway...!
Reply
#15
Yes. Surprising how seldom we do a full power cycle on TVs these days. I've had a few issues where my Sony TV and my Onkyo amp have done odd things, but by totally powering them down at the wall I have fixed things. (Well removed the issue temporarily...)
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
HDMI CEC not working with Sony TV (LE7.90.005 RPi3)00