v15 UPnP issues with HDHomerun Extend
#1
Not sure if this is the correct location to post this, so please forgive me if it isn't.

I just upgraded my Fire TV to Kodi 15 from 14.2. I used the IPTV Simple Client to watch my HDHomerun Extend's OTA channels via a playlist made up of each channel's UPnP address. After I upgraded to version 15, the IPTV Simple Client showed the channel list with EPG info, but would not tune to any of the channels. No error or dialog box appeared. It simply did nothing on the screen.

To further troubleshoot, I tried bypassing the client and went to the HDHomerun via it's video source, (Video>Files>Add Source...>UPnP Devices>HDHomeRun DMS Tuner>Channels). It failed playing any of the channels there as well.

I then tried a fresh install of Kodi 15 on a Windows 7 SP1 x64 and went directly to add the HDHomerun as a UPnP video source and tried to access the channels, (to see if this was just a Fire TV/Android issue). They did not play on Win7 either.

Is this a known issue or do I need to adjust something in Kodi 15 that was different from 14.2?

Link to Win7 PC's logfile with debug enabled: http://xbmclogs.com/pkww2lt7h
Current equipment in my "Kodi system", v17.1:
HTPC Win 10, i5 4690K 3.5 GHz, 8GB RAM, Nvida GTX 970, 500GB SSD
Nvidia Shield TV 16GB w/ Flirc and 64GB microSD card
1st gen Fire TV Stick, (for traveling)
Qnap 431+ NAS w/ 9TB
HDHomeRun Plus/Extend
Old DTV remotes, Yatse app and Logitech Harmony Smart Control
Reply
#2
For some reason I had to regenerate my UPnP URLs when I went to Kodi v15 for my HDHomeRun Prime. The existing URLs didn't work in the playlist file that I fed to IPTV Simple Client. Since I had a custom list of channels I decided it would be faster to just use a text editor to find/replace on the existing URL with one that used HTTP instead of UPnP, but it should work with the new UPnP address as well. I don't know if it's the HDHomeRun tuner or Kodi that changed the URL path, or how that works exactly. I do know there is a dynamic nature to UPnP that can sometimes invalidate a previously saved UPnP URL, though.

EDIT: The issue affects all HDHomeRun UPnP URLs from Kodi.
Reply
#3
(2015-07-24, 00:19)Ned Scott Wrote: For some reason I had to regenerate my UPnP URLs when I went to Kodi v15 for my HDHomeRun Prime. The existing URLs didn't work in the playlist file that I fed to IPTV Simple Client. Since I had a custom list of channels I decided it would be faster to just use a text editor to find/replace on the existing URL with one that used HTTP instead of UPnP, but it should work with the new UPnP address as well. I don't know if it's the HDHomeRun tuner or Kodi that changed the URL path, or how that works exactly. I do know there is a dynamic nature to UPnP that can sometimes invalidate a previously saved UPnP URL, though.

Ned, this was extremely helpful, thank you. I couldn't figure out how to regenerate the UPnP URLs. No matter what I tried, I kept getting the same UPnP URL. So I took your suggestion and went down the HTTP route. At first, I wasn't sure how to format the HTTP URLs but I came across this document, "HDHomeRun HTTP Development Guide", and that spelled it out pretty clearly. As an added bonus, I found that I could force a particular transcoding profile from my HDHomerun as well.

Once I had the URLs updated in my m3u playlist, the IPTV Simple Client was still not working until I ran the "Clean library" command. After that, all was back to normal.

Again, thanks for your suggestion.
Current equipment in my "Kodi system", v17.1:
HTPC Win 10, i5 4690K 3.5 GHz, 8GB RAM, Nvida GTX 970, 500GB SSD
Nvidia Shield TV 16GB w/ Flirc and 64GB microSD card
1st gen Fire TV Stick, (for traveling)
Qnap 431+ NAS w/ 9TB
HDHomeRun Plus/Extend
Old DTV remotes, Yatse app and Logitech Harmony Smart Control
Reply
#4
Having the same issue....UPNP isn't working with my latest OpenELEC installs. Is there an advantage to moving to HTTP over UPNP? I.e. No reason to move back to UPNP once the bug is fixed?
Reply
#5
Not sure if there is a major difference or not. Sounds like it's more than the UPnP URLs changing. I'm away from my Prime so I can't test right now, but I'll follow up on this. Other UPnP sources seem fine. Very strange.
Reply
#6
same issue. ERROR: CCurlFile::FillBuffer - Failed: HTTP returned error 406

I mentioned here.

http://forum.kodi.tv/showthread.php?tid=232942
Reply
#7
HTTP 406 is "not acceptable". I have posted in the thread you linked.

Nick - Silicondust
Reply
#8
(2015-07-24, 16:44)sd-jafa Wrote: HTTP 406 is "not acceptable". I have posted in the thread you linked.

Nick - Silicondust

Thanks Nick, I'll make sure the devs see your post.
Reply
#9
Anyone working on a fix?
Image Lunatixz - Kodi / Beta repository
Image PseudoTV - Forum | Website | Youtube | Twitter | Help?
Reply



Logout Mark Read Team Forum Stats Members Help
UPnP issues with HDHomerun Extend2
This forum uses Lukasz Tkacz MyBB addons.