Audio no longer plays on some codecs with Isengard upgrade
#1
Hello,
I just upgraded to Isengard (kodi 15.0) today, and am no longer able to hear the audio in some videos (mpga / mpeg, as one example).
I can hear the audio in videos using AC3, and all my MP3 music works fine.

I am running on ubuntu 14.04, in the kodi environment (rather than desktop/gnome)
The hardware is current and well spec'd. (see the pastebin log for full specs)
Audio previously had been working today, prior to the upgrade.

I believe I had a similar problem in the past, but am unable to recreate what I thought was the solution. Frustratingly, with each upgrade of xbmc/kodi, my configurations get lost (audio settings, remote control mappings / keyboard.xml) abd I have to re-do them.

I have set the audio driver to the correct option (s/pdf) which sends my audio out via optical connection to my yamaha receiver that can do dolby, dolby pro logic, pcm, dts, etc.

I have tried going into the pulse audio settings and enabling the varoius formats (as per the wiki guides), going back into kodi and finding that passthrough was now visible while in expert mode. I tried passthrough in all the various combinations (starting with the one I thought most likely), but didn't have any luck with any of them. I tried turning off all the hardware decoding from the video menu, also to no benefit.

I logged the audio component, and found what may be the problem, somewhere between lines 134 and 173
http://pastebin.com/JksJVWeN

Any ideas or suggestions on how to proceed?

Thanks!
Reply
#2
I've got a similar problem. Running ubuntu 14.04 on my laptop. No longer get audio on certain videos. I'll be keeping an eye on this thread.
BBC Live Football Scores: Football scores notifications service.
script.squeezeinfo: shows what's playing on your Logitech Media Server
Reply
#3
Quote:22:43:27 T:139648697358080 ERROR: CDVDPlayerAudio:Big GrinecodeFrame - Decode Error. Skipping audio packet (-1094995529)
22:43:27 T:139648697358080 ERROR: Previous line repeats 332 times.
22:43:27 T:139648697358080 WARNING: CDVDMessageQueue(audio)::Get - asked for new data packet, with nothing available
22:43:27 T:139648697358080 ERROR: CDVDPlayerAudio:Big GrinecodeFrame - Decode Error. Skipping audio packet (-1094995529)
22:43:27 T:139648697358080 ERROR: Previous line repeats 16 times.
22:43:27 T:139648697358080 WARNING: CDVDMessageQueue(audio)::Get - asked for new data packet, with nothing available
22:43:27 T:139648697358080 ERROR: CDVDPlayerAudio:Big GrinecodeFrame - Decode Error. Skipping audio packet (-1094995529)
22:43:27 T:139648697358080 ERROR: Previous line repeats 328 times.
22:43:27 T:139648697358080 WARNING: CDVDMessageQueue(audio)::Get - asked for new data packet, with nothing available
22:43:27 T:139648697358080 ERROR: CDVDPlayerAudio:Big GrinecodeFrame - Decode Error. Skipping audio packet (-1094995529)

Please enable debugging. And a post such a broken sample and post the Debug Log again. From your log passthrough is disabled, so it uses 2 channel pcm output.

Here is a test sample: https://dl.dropboxusercontent.com/u/5572...20Test.avi
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
#4
I wonder if my issue has something to do with a corrupted file (although it affects every file that I've converted with Handbrake, and the files played on Helix ok). If I try to create a sample from the file (using ffmpeg on command line) then the audio plays in the extract.

The debug log is here: http://xbmclogs.com/p4v1i8duq
BBC Live Football Scores: Football scores notifications service.
script.squeezeinfo: shows what's playing on your Logitech Media Server
Reply
#5
Yeah that file seems nicely broken :-)
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
#6
You can try latest nightly which ships ffmpeg 2.7.1
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
#7
(2015-07-26, 15:47)fritsch Wrote: You can try latest nightly which ships ffmpeg 2.7.1
OK. Will give it a try.

Looks like I also need to fix my MythTV user jobs so they produce a file that's not broken!
BBC Live Football Scores: Football scores notifications service.
script.squeezeinfo: shows what's playing on your Logitech Media Server
Reply
#8
Hi Guys,
Same problem here.
The sample goes fine, but all my AC3/DTS are working fine. mp3 music file works fine too.
The issue is only present with some video file with mp3 sound.
These file were reading ok with Gotham and Helix and they're working with VLC
The files was created with Vidcoder (a handbrake based utility)

Encoding the sample file with same settings do the same result : sound do not play
here are the settings :
Image

Did somebody have an idea about it?

EDIT : tested with the latest nightly and the result is still the same.
Reply
#9
Hi All,

have a similar problem (opened Thread http://forum.kodi.tv/showthread.php?tid=236935)
I am using VDR to record DVB streams and then using handbrake to convert x264/mp3.

Cheers

Fred
Reply
#10
Should I create a new ticket in http://trac.kodi.tv/ ?
Reply
#11
Yes, please. Add a non working sample so we can reproduce ...
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
#12
Here, if someone wants to follow the ticket : http://trac.kodi.tv/ticket/16225
Reply
#13
I assigned it to fernet, cause currently on holidays. Only with mobile phone to go on people's nerves.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
#14
(2015-08-28, 14:56)fritsch Wrote: I assigned it to fernet, cause currently on holidays. Only with mobile phone to go on people's nerves.
Big Grin
Thanks for your help !
Reply
#15
A possible solution can be found here http://forum.kodi.tv/showthread.php?tid=...pid2095927. But the question most likely is if in the and there is a problem with Handbrake in the first instance or only Kodi.
Reply



Logout Mark Read Team Forum Stats Members Help
Audio no longer plays on some codecs with Isengard upgrade0
This forum uses Lukasz Tkacz MyBB addons.