v15 [SOLVED] SQL Problems Updating from 14 to 15
Hi there.
This happened on my FireTV but according to the log it seems like this is not even OS-specific

I just updated my Kodi on my Fire-TV using
adb install -r D:\downloads\kodi-15.0-Isengard-armeabi-v7a.apk

(installed version was 14.0 Helix)

After trying to start Kodi I just see the startup-screen for half a second before it crashes. I use the following settings to use a centralized MySQL-Database:
                                                  <to>smb://[email protected]/thumbs</to>
(Removed the passwords)

The log throws the following error on startup:
20:12:07 T:1528415712   DEBUG: Loading: /data/app-lib/org.xbmc.kodi-2/libcurl.so
20:12:07 T:1528415712  NOTICE: Running database version Addons19
20:12:07 T:1528415712   DEBUG: void CDatabaseManager::Initialize(bool), updating databases...
20:12:07 T:1528415712  NOTICE: Running database version ViewModes6
20:12:07 T:1528415712  NOTICE: Running database version Textures13
20:12:07 T:1528415712  NOTICE: Running database version MyMusic52
20:12:07 T:1528415712   ERROR: SQL: The table does not exist
                                            Query: SELECT idVersion FROM version

When I just remove my custom advancedsettings, kodi starts.

My guess would be that there has something changed in the database structure. Can I just add a column at a table somewhere or is there an update script?

Thanks in advance
I'm having the same issue with my FireTV as well on my upgrade. I also use a centralized DB on my NAS. After launch it quickly crashes. I can see it's made a new Music DB in mysql, but it is empty. I've deleted it and reverted back to 14.2.

Does anyone else have this problem and/or solution?
Ok. Solved this by myself. Might be of help for others:

I analyzed the code on git and my database to find out the following:
two new databases had been created today (MyVideos93 AND MyMusic52)

I deleted those databases (The old ones "MyMusic48" and "MyVideos90" were still there)

Then I stopped the application, removed the cache, cleared all data. Copied my config file back in and started Kodi.
The "First start" screen re-appeared and kodi started converting the database

The Databases had been created and now everything works. I just lost my SMB-Shares but the media library was intact.

I think Kodi crashes on installation at the first time before the database actions were finished
I cleared all data and cache on a fresh install. Tried to push my advanced settings but permission is denied so I launched it clean. Stopped Kodi, then pushed my advancedsettings. As soon as that file get's placed, the crash happens for me.
Did you check the databases on the NAS? Thats what did the trick for me (removing MyVideos93 and MyMusic52)
I installed Isengard 15.0 rc2 do I need to update to the New release? when I tried with Abdfire shell command it tells me "error two instances running"

What's the best way to update from RC2 to 15.0 proper if required

Thanks In advance
The topic is "SQL problems". The chances to get help might be bigger if you create a new thread for that. ( I cannot help, sorry. I am not using adbfire but raw androidsdk adb)
Has anyone tried to upgrade to Kodi using mobile go ? I tried on my fire stick but it crashed can anyone help? I tried to upgrade from 14.2.
Thread Rating:
  • 0 Vote(s) - 0 Average

Logout Mark Read Team Forum Stats Members Help
[SOLVED] SQL Problems Updating from 14 to 1500