Linux Compile Kodi /w libcec 3.0 on updated Ubuntu 14.04
#1
I always compile kodi myself, which is working fine (sometimes with a hickup Smile ).

However for some time I am working with the latest pulse-eight and latest kodi (githup) and I see Libcec is not supported anymore (checking for CEC... no)
When I was searching after a couple of months I found this thread:
http://forum.kodi.tv/showthread.php?tid=...t=libcec+3

This looks like it should work. However I also found this PR in github:
6891 (PR)

My config log looks like this:
http://paste.ubuntu.com/11940852/

What I found in it was that, I need to have:
"Package 'platform', required by 'libcec', not found"

However this is not an available package for apt-get.
Reply
#2
$ apt-cache policy libplatform-dev
libplatform-dev:
Installed: 1.0.7-1~trusty
Candidate: 1.0.7-1~trusty
Version table:
*** 1.0.7-1~trusty 0
500 http://ppa.launchpad.net/team-xbmc/unstable/ubuntu/ trusty/main amd64 Packages
500 http://ppa.launchpad.net/team-xbmc/xbmc-nightly/ubuntu/ trusty/main amd64 Packages
500 http://ppa.launchpad.net/wsnipex/kodi-git/ubuntu/ trusty/main amd64 Packages
500 http://ppa.launchpad.net/wsnipex/xbmc-fe...er/ubuntu/ trusty/main amd64 Packages
100 /var/lib/dpkg/status


its also in the team (stable) PPA, but I don't have that enabled here
Reply
#3
Whooooo, great... Installing the libplatform did the trick:

Code:
sudo apt-get install libplatform-dev

Thanks for the help, really appreciated.
(Why did I not raise the question earlier, now compiling a new kodi)
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Compile Kodi /w libcec 3.0 on updated Ubuntu 14.0400