v15 Some keys on MCE remote not registering
#1
Hello,

Since the upgrade to Kodi 15 Isengard, some keys on my Harmony remotes (configured as standard MCE) such as the OK / Select button and BACK button are no longer working. Other keys like the arrow keys are still operational.

I turned on debugging and I see the OK / Select button press being registered, it just doesn't do anything in Kodi:

22:25:31 T:140314091489216 DEBUG: Keyboard: scancode: 0xb6, sym: 0x1008ff56, unicode: 0x0000, modifier: 0x0
22:25:31 T:140314091489216 DEBUG: GetActionCode: Trying Hardy keycode for 0xf200
22:25:31 T:140314091489216 DEBUG: Previous line repeats 3 times.
22:25:31 T:140314091489216 DEBUG: OnKey: 0 (0xf200) pressed, action is
22:25:31 T:140314091489216 DEBUG: LIRC: Update - NEW at 222521:ae 0 KEY_EXIT /dev/input/event3 (KEY_EXIT)
22:25:31 T:140312705996544 INFO: AddOnLog: MythTV PVR Client: GetDeletedRecordingsAmount: No deleted recording
22:25:47 T:140314091489216 INFO: Previous line repeats 5 times.
22:25:47 T:140314091489216 DEBUG: LIRC: Update - NEW at 239456:160 0 KEY_OK /dev/input/event3 (KEY_OK)
22:25:48 T:140314091489216 DEBUG: LIRC: Update - NEW at 239956:160 0 KEY_OK /dev/input/event3 (KEY_OK)
22:25:49 T:140312705996544 INFO: AddOnLog: MythTV PVR Client: GetDeletedRecordingsAmount: No deleted recording
22:26:03 T:140314091489216 INFO: Previous line repeats 4 times.
22:26:03 T:140314091489216 DEBUG: Keyboard: scancode: 0x6f, sym: 0x0111, unicode: 0x0000, modifier: 0x0
22:26:03 T:140314091489216 DEBUG: OnKey: up (0xf080) pressed, action is Up
22:26:03 T:140314091489216 DEBUG: LIRC: Update - NEW at 255208:67 0 KEY_UP /dev/input/event3 (KEY_UP)
22:26:04 T:140312705996544 INFO: AddOnLog: MythTV PVR Client: GetDeletedRecordingsAmount: No deleted recording
22:26:04 T:140314091489216 DEBUG: Keyboard: scancode: 0x6f, sym: 0x0111, unicode: 0x0000, modifier: 0x0
22:26:04 T:140314091489216 DEBUG: OnKey: up (0xf080) pressed, action is Up
22:26:04 T:140314091489216 DEBUG: LIRC: Update - NEW at 255708:67 0 KEY_UP /dev/input/event3 (KEY_UP)
22:26:05 T:140314091489216 DEBUG: Keyboard: scancode: 0x6f, sym: 0x0111, unicode: 0x0000, modifier: 0x0
22:26:05 T:140314091489216 DEBUG: OnKey: up (0xf080) pressed, action is Up
22:26:05 T:140314091489216 DEBUG: LIRC: Update - NEW at 257325:67 0 KEY_UP /dev/input/event3 (KEY_UP)


I haven't made any changes to the configuration of the remote, and it worked fine in Kodi 14 and previous versions. Any suggestions on a fix?
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Some keys on MCE remote not registering00
This forum uses Lukasz Tkacz MyBB addons.