tvheadend Recordings Failing with 'Time Missed'
#1
Hello There,
After getting tvheadend up and running for watching live tv I thought I'd try recording. Sadly all of my recordings are failing with the code 'Time Missed' (both through Kodi and the tvheadend web interface). My dvr log gives me the following info:
Code:
{
    "start": 1438336800,
    "start_extra": 0,
    "stop": 1438338600,
    "stop_extra": 0,
    "channel": "dbe2a286b6e372438240558a473276ec",
    "channelname": "Sky News",
    "title": {
        "eng": "Sky News with Colin Brazier and..."
    },
    "subtitle": {
        "eng": "...Jayne Secker. News headlines, analysis and debate on the big stories of the day. [S]"
    },
    "description": {
        "eng": "...Jayne Secker. News headlines, analysis and debate on the big stories of the day. [S]"
    },
    "pri": 2,
    "retention": 0,
    "container": -1,
    "config_name": "97f9522cb9e262fee064ddaf8e5fb4f8",
    "owner": "htpc_Hermes",
    "creator": "htpc_Hermes",
    "filename": "/home/htpc_hermes/Videos/Recordings/Sky-News-with-Colin-Brazier-and....ts",
    "errorcode": 0,
    "errors": 0,
    "data_errors": 0,
    "dvb_eid": 73,
    "noresched": false,
    "autorec": "",
    "timerec": "",
    "content_type": 2,
    "broadcast": 47123
}
This was just trying to record a random program through the web interface. All of my other attempts give similar logs.
Any ideas?

Cheers, Bez
Reply
#2
See what's in the debug log on the back end - open up the webUI and slick the arrows in the bottom right, then click the cog. You'll see tvheadend's debug messages, and they'll be written to syslog at the same time.

Assuming you're looking at unencrypted channels (which Sky News is AFAIK), my guess would be permissions of some kind - either in the access rules for this user or with the target directory.
Reply
#3
I've tried again and the syslog says this:
Code:
Jul 31 17:19:16 Hermes tvheadend[812]: pass: /home/htpc_hermes/Videos/Recordings/Iain-Dale.ts: Unable to create file, open failed -- Permission denied
I deliberately set the save path to one where access shouldn't be a problem. How would one solve this?

Thanks, Bez
Reply
#4
Check the permissions on the parent folders - assuming you're running tvh as hts, su to hts and see if you can create a file in that directory, or do some rigid ls -la -ing to check that owner or group has rwx to the directories - most likely Videos and Recordings.

Is it a local disc or a remote mount?
Reply
#5
Fixed it, thanks!
It seems that despite the hts group having write permissions to the folder I still had to add them manually. Weird, but fixed.
Reply
#6
I guess that write, while it allows you to create a file, isn't enough; you need read to list the contents, and execute to move through/traverse the directory. So, you could have rw- to Recordings, but can't get there if you don't have x to Videos (for example - YMMV, obviously).

Glad you fixed it, though.
Reply
#7
I am having the exact same problem, can anyone please explain how to fix in ...plain English step by step lol
Not a linux expert i m afraid ...i can follow directions though, and i try to learn Smile


EDIT: OK i have fixed the problem via ...network LOL
Accessed from a windows pc, created a folder, gave read-write permissions to "everyone", and have set the recording folder to that folder. Problem fixed, recording works fine.
Reply



Logout Mark Read Team Forum Stats Members Help
tvheadend Recordings Failing with 'Time Missed'0
This forum uses Lukasz Tkacz MyBB addons.