CEOMR MediaCenter 2.1 Skin
#1
CEOMR MediaCenter 2.1pre Skin

-> http://www.megaupload.com/?d=TXWQQS6M

i am sure that there are many bugs please help me to find them...

at teh moment i have got problems with SettingsProfile.xml and SettingsCategory.xml [button and listcontrol animation]

cheers ceomr
Reply
#2
Finally an update to my favorite skin!

Will try it ASAP.

Cheers

gg
Reply
#3
When i play a video I am getting a blue line across the top 1/3 of the screen...about an inch wide across the whole screen...any ideas?
Reply
#4
Quote:When i play a video I am getting a blue line across the top 1/3 of the screen...about an inch wide across the whole screen...any ideas?

to solve the problem
you have to edit the VideoFullScreen.xml
and change the bluebar.png id

old:
Quote:<control type="image" id="1">

new:
Code:
<control type="image" id="0">
      <description>bar image</description>
      <posx>0</posx>
      <posy>54</posy>
      <width>720</width>
      <height>65</height>
      <texture>bluebar.png</texture>
      <colorkey>0</colorkey>

it will be added with next update :-)

thanks for the feedback

cheers ceomr
Reply
#5
ceomr Wrote:at teh moment i have got problems with SettingsProfile.xml and SettingsCategory.xml [button and listcontrol animation]

cheers ceomr

want to be more specific as to what the problem is and maybe I can help even if you want to ask in PM and not here
Also I can't download it to even look because megaupload tells me the download limit is exceded
Reply
#6
CEOMR MediaCenter 2.1pre Skin 04.12.2006

http://www.konsolenumbau.at/Upload.rar

________________________________

Quote:want to be more specific as to what the problem is and maybe

i have got the following problem with button-slide-effect in SettingsCategory.xml

the buttons get cropped after focus effect

Code:
<animation effect="slide" time="150" start="0,0" end="-10,0" acceleration="-1.3" delay="0" condition="!Skin.HasSetting(animation)">Focus</animation>
    <animation effect="slide" time="150" start="-10,0" end="0,0" acceleration="-1.3" delay="0" condition="!Skin.HasSetting(animation)">UnFocus</animation>

cheers ceomr
Reply
#7
OK seems this is a problem with the new grouplist type creating an actual window that the buttons get displayed in instead of drawing them on the desktop.
As far as I know there is no solution to it right now but I think jmarshall needs to add a <controloffsetx> and a <controloffsety> to the group list so people can still do these sort of animations. If he dosn't read this I'll ask him next time I see him
Reply
#8
Yeah - the grouplist sets the viewport around the controls (ostensibly for when the controls are scrolling).

The reason is that controls are currently resized (in width) to the size of the grouplist in the case of a vertical list (their heights are probably resized in the case of a horizontal grouplist, though I'm not 100% sure), and their posx and posy are set so that they form a list. Obviously the issue here is the posx and width (in particular) being forced.

The only reason that this occurs is because settingscategory.xml requires it for many skins, as the various control types there are not sized correctly by default.

I could remove this constraint (allowing the <posx> and <width> to be left alone, and taken offset from the grouplist) but this will kill backward compatibility, and would also force you to place the controls within the list itself (which makes sense anyway).

My proposal is as follows:

1. If skin version < 2.1, do it as it is done now.

2. Else, leave <posx> and <width> untouched.

Those skins that have already specified version 2.1 will need to be updated to suit.

Does this sound ok?

Cheers,
Jonathan
Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.


Image
Reply
#9
Honestly jmarshall I'd be happy with just adding a <border> tag to all controls that have viewports so like in the example of this skin when his buttons get focused, and slide back 10 pixels if he had a border of 10 then it would still show instead of getting cut off due to the view port edge.

I also ran into the same problem with the new panel type and having a larger overlapping thumb when your in the top row the top gets cut off same with being on the left right and bottom being able to specify a border that it starts / finishes drawing from would suit and note break compatabilty because if its not there it just uses 0
Reply
#10
The problem with that is that the viewport is there for a reason: It's there for when we are scrolling (we want it to chop things off nicely).

While it would be fine for left/right (as they are not the issue in a vertical grouplist) any vertical border could be rather strange looking, with half-controls visible, or some parts showing up when scrolling but then disappearing when the scrolling ends.

For the panel, for instance, if you had no space between thumbs, and no label whatsoever, and then have the focused thumb larger (overlapping) then if you had a border, it would show the focused thumb fine no matter where you are, but if you scroll down (so icons all move up) the first row of icons would be displayed in the border area until the scroll completes, whereby they'd magically disappear. A starting offset or something would be the only way around that (so that partial thumbs are always displayed in the top/bottom border area). This makes things more complicated both code-wise and skin-wise. Ofcourse, if it's unavoidable, then so be it. The current stuff is quite elegant in it's simplicity - I don't want it to become another buttonscroller!

If any other ideas are coming I'd be more than happy to hear them!

Cheers
Jonathan
Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.


Image
Reply
#11
Ok I installed the skin and it says that the skin is incompatible we require skins of version 2.00 or higher.

Not sure of what to do here. I can't remember my build date but it is pretty recent atleast in mid november T3ch build.
Reply
#12
ok maybe I was wrong it is a oct 28, 2006 build (GasGIver)
Reply
#13
Ok I installed the new skin per included instructions. It says that the skin is incompatible must be version 2.00 or higher.

I am running build OCT 28, 2006, (Gasgiver)
Reply
#14
ooops
Reply
#15
Very nice additions since 2.0! However I have found german words in "My Programs" section while I have set English as the language.
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
CEOMR MediaCenter 2.1 Skin00