• 1
  • 272
  • 273
  • 274(current)
  • 275
  • 276
  • 309
Release skin helper service
(2020-05-16, 18:08)AnonTester Wrote: @nonJon fix added to the PR

Saw that. Much obliged!
Reply
Hi, I have a lot of problems with the entire SKIN-HELPER set


Non stop problem
If the skin helper widget works correctly, the skin heper service does not work and vice versa

Can anyone help me solve this problem

Log: https://paste.kodi.tv/yeyecepoho.kodi

Thank you.
Reply
Need a Hint!

Problem with Remote Extrafanart. Did waist hours nd couldnt get this to Work.

i've set as recomended '
xml:
<onload condition="true">Skin.SetBool(SkinHelper.EnableExtraFanart)</onload>
in Home.xml

and
xml:
$INFO[Window(Home).Property(SkinHelper.ListItem.Art.ExtraFanArt)]
in a multiimage Control.
In Theory easy. But This way i get only Extrafanart from the Local "Extrafanart-Folder".

so i've added
xml:
<onload condition="true">Skin.SetBool(SkinHelper.EnableExtendedArt)</onload>
to,
but noch change.

i've added the SkinHelper property to a Label controll, to see what it returns. And it returns only the Path to the Local Folder! (no Remote Extrafanart)
i had a look at other skins where Remote Extrafanart works, but couldnt finde out what them do differenttly(?/!)
does it have to be so hard? What do i have to do, to display Remote Extrafanart? (Kodi Leia 18.5/18.7 and Skinhelper from the beta repository)

so why? doesnt that work?
Reply
Try,

$INFO[Window(Home).Property(SkinHelper.Player.Art.ExtraFanArt)]


<variable name="YourExtaFanarVar">
     <value condition="!String.IsEmpty(Window(Home).Property(SkinHelper.Player.Art.ExtraFanArt))">$INFO[Window(Home).Property(SkinHelper.Player.Art.ExtraFanArt)]</value>
     <value condition="!String.IsEmpty(Window(Home).Property(SkinHelper.ListItem.Art.ExtraFanArt))">$INFO[Window(Home).Property(SkinHelper.ListItem.Art.ExtraFanArt)]</value>
     <value>$INFO[ListItem.Art(fanart)]</value>
</variable>
Reply
Hi

Novice looking for some help

I'm trying to get script.module.metadatautils working with Matrix

In one case I get the following error:
listitem = xbmcgui.ListItem(label=label, iconImage=thumb, label2=item["overview"])
TypeError: 'iconImage' is an invalid keyword argument for this function

I understand that iconImage has been replaced by setArt in Kodi 19.

What I can't fathom out is how to change the line of code above to work.

Any help appreciated
Reply
(2020-06-01, 01:08)Atamans Wrote: Hi, I have a lot of problems with the entire SKIN-HELPER set


Non stop problem
If the skin helper widget works correctly, the skin heper service does not work and vice versa

Can anyone help me solve this problem

Log: https://paste.kodi.tv/yeyecepoho.kodi

Thank you.

Try this out that fixes the last error from your log. https://forum.kodi.tv/showthread.php?tid...pid2933557
Reply
thanks dude,
I will check it immediately
Reply
(2020-07-06, 10:50)berkhornet Wrote: Hi

Novice looking for some help

I'm trying to get script.module.metadatautils working with Matrix

In one case I get the following error:
listitem = xbmcgui.ListItem(label=label, iconImage=thumb, label2=item["overview"])
TypeError: 'iconImage' is an invalid keyword argument for this function

I understand that iconImage has been replaced by setArt in Kodi 19.

What I can't fathom out is how to change the line of code above to work.

Any help appreciated
Did you not try
Code:
listitem = xbmcgui.ListItem(label=label, label2=item["overview"])
?


scott s.
.
Reply
(2020-07-06, 16:29)scott967 Wrote:
(2020-07-06, 10:50)berkhornet Wrote: Hi

Novice looking for some help

I'm trying to get script.module.metadatautils working with Matrix

In one case I get the following error:
listitem = xbmcgui.ListItem(label=label, iconImage=thumb, label2=item["overview"])
TypeError: 'iconImage' is an invalid keyword argument for this function

I understand that iconImage has been replaced by setArt in Kodi 19.

What I can't fathom out is how to change the line of code above to work.

Any help appreciated
Did you not try
Code:
listitem = xbmcgui.ListItem(label=label, label2=item["overview"])
?


scott s.
.

Many thanks for tip. Why didn’t I think of that?

That’s moved me along a bit.
Reply
Hey

I downloaded this through the add_ons section on Kodi. I love it, thanks so much! I just have one problem, but I might be being stupid. I was using it perfectly fine and it was showing under next episodes the episode after the one I had most recently watched even though I had not watched the first season on Kodi but then I cleared my library completely, cleaned it and reupdated it but it now seems like it no longer works the way before. If for example you start watching season 2 of a tv show and you finish episode 1, before it would have season 2 episode 2 under next episode now instead it tells me that the next episode is in fact season 1 episode 1. Obviously I can mark all episodes before my point as watched (and did do that in the end) but it doesnt work very well for a lot of shows, where I might dip in and out. This could also just be the way it is supposed to work but I remember pretty clearly it working the other way before. Any help would be greatly appreciated! Thanks again for this basically essential add on.
I should note also that I am using Kody Leia 19.

Thank you!
Reply
Please can anyone help with what I am sure is a simple problem. I have just upgraded to Kodi 18 and MQ8 skin but I cannot seem to export the skin settings.  I get the following message "Skin Helper Backup      Error while executing, please check Kodi.log"

The full log is here egefaqeqoj.kodi (paste)

Any help would be appreciated
Reply
(2020-09-29, 17:58)perspicacia Wrote: Please can anyone help with what I am sure is a simple problem. I have just upgraded to Kodi 18 and MQ8 skin but I cannot seem to export the skin settings.  I get the following message "Skin Helper Backup      Error while executing, please check Kodi.log"

The full log is here egefaqeqoj.kodi (paste)

Any help would be appreciated
You use some bad version of skin helper skinbackup 1.0.22. ?!Huh?
Use version 1.0.19 from https://github.com/kodi-community-addons that version working on mine Android.

I have some free time, and will do some maintenance in https://github.com/kodi-community-addons .
I will close all "issues" and pull request to create version with some fixes in new branch "leia".

Master branch will be ready for python 3 (base will be new leia branch,) and open for pull request.

Some of fixed part will be part of new branch:
- Usage: $INFO[Window(Home).Property(NAME-OF-PROPERTY)] for pvr and music widget don't show cache when open dialogs.
- $INFO[Window(Home).Property(SkinHelper.Player...don't show art and info for internet stream.
- alow info from theaudiodb using part without api keys (now is restricted only for patron user)
- add some new art and label in scrapers
- pvr will use all cache info and art, not just art.
-.....
XBoxMediaCenter (Kodi Matrix ) 19.3 , AndroidBox -Matrix Skin AeonMQ6
Reply
(2020-10-01, 10:10)Angelinas Wrote:
(2020-09-29, 17:58)perspicacia Wrote: Please can anyone help with what I am sure is a simple problem. I have just upgraded to Kodi 18 and MQ8 skin but I cannot seem to export the skin settings.  I get the following message "Skin Helper Backup      Error while executing, please check Kodi.log"

The full log is here egefaqeqoj.kodi (paste)

Any help would be appreciated
You use some bad version of skin helper skinbackup 1.0.22. ?!Huh?
Use version 1.0.19 from https://github.com/kodi-community-addons that version working on mine Android.

I have some free time, and will do some maintenance in https://github.com/kodi-community-addons .
I will close all "issues" and pull request to create version with some fixes in new branch "leia".

Master branch will be ready for python 3 (base will be new leia branch,) and open for pull request.

Some of fixed part will be part of new branch:
- Usage: $INFO[Window(Home).Property(NAME-OF-PROPERTY)] for pvr and music widget don't show cache when open dialogs.
- $INFO[Window(Home).Property(SkinHelper.Player...don't show art and info for internet stream.
- alow info from theaudiodb using part without api keys (now is restricted only for patron user)
- add some new art and label in scrapers
- pvr will use all cache info and art, not just art.
-.....
Thanks for the advice. Unfortunately uninstalled and then installed v1. 0.19 but still have same problem
Reply
(2020-10-01, 19:29)perspicacia Wrote:
(2020-10-01, 10:10)Angelinas Wrote:
(2020-09-29, 17:58)perspicacia Wrote: Please can anyone help with what I am sure is a simple problem. I have just upgraded to Kodi 18 and MQ8 skin but I cannot seem to export the skin settings.  I get the following message "Skin Helper Backup      Error while executing, please check Kodi.log"

The full log is here egefaqeqoj.kodi (paste)

Any help would be appreciated
You use some bad version of skin helper skinbackup 1.0.22. ?!Huh?
Use version 1.0.19 from https://github.com/kodi-community-addons that version working on mine Android.

I have some free time, and will do some maintenance in https://github.com/kodi-community-addons .
I will close all "issues" and pull request to create version with some fixes in new branch "leia".

Master branch will be ready for python 3 (base will be new leia branch,) and open for pull request.

Some of fixed part will be part of new branch:
- Usage: $INFO[Window(Home).Property(NAME-OF-PROPERTY)] for pvr and music widget don't show cache when open dialogs.
- $INFO[Window(Home).Property(SkinHelper.Player...don't show art and info for internet stream.
- alow info from theaudiodb using part without api keys (now is restricted only for patron user)
- add some new art and label in scrapers
- pvr will use all cache info and art, not just art.
-.....
Thanks for the advice. Unfortunately uninstalled and then installed v1. 0.19 but still have same problem

Hi Guys. Awesome addon, but I'm having exactly the same problem with Kodi 18.8 on Android 9 on my Air96 box - get a Skin Helper Backup error ;-(

I've tried different versions, but always get an error - cannot backup or restore.
Reply
Try the version of the PR I opened back in February with various fixes and Kodi19 compatibility. It should be compatible with both Kodi 18 and 19, but I don't use Kodi 18.

Source v1.0.25:
https://github.com/AnonTester/script.ski...skinbackup

Also in my repo:
https://github.com/AnonTester/kodi-repo/...anontester

@Angelinas if you've got some time to look at the various kodi-community addons, plese don't just close all PRs and invalidate the work put in by others, but look at them and merge where appropriate. I spent quite some time on several to get them working again, all PR'd.
Got an error message or something not working as it should? Provide a full Debug log (wiki) via paste.kodi.tv
Reply
  • 1
  • 272
  • 273
  • 274(current)
  • 275
  • 276
  • 309

Logout Mark Read Team Forum Stats Members Help
skin helper service18
This forum uses Lukasz Tkacz MyBB addons.