•   
  • 1
  • 13
  • 14
  • 15(current)
  • 16
  • 17
  • 270
  •   
Release skin helper service
(2015-09-11, 09:43)jurialmunkey Wrote:
(2015-09-11, 09:32)marcelveldt Wrote:
(2015-09-11, 03:06)jurialmunkey Wrote: I'm not sure if I'm doing something wrong? It doesn't seem to be working (on Isengard if that matters). Here's my button in skinshortcuts:
Code:
<control type="button" id="9701" description="Select Color">
  <width>100%</width>
  <label>Select color</label>
  <onclick>RunScript(script.skin.helper.service,action=colorpicker,shortcutproperty=tilecolor)</onclick>
  <include>Defs_OptionButton</include>
</control>

I put <label>$INFO[ListItem.Property(tilecolor)]</label> in a label control to test and it doesn't seem to be set.

Your code is just fine. Actually your log even indicates it has set the property.
If you open script-skinshortcuts-includes.xml after it has been built, can you see the property been added ?
No can't see it being set in there.

Working fine in my setup. I copied your exact button code and see this in my script-skinshortcuts-includes.xml:

<property name="tile​color">ff008000</property>
<property name="tile​color.name">office green</property>

You are sure you went back to home so it would build the menu ?
Reply
(2015-09-11, 01:51)marcelveldt Wrote: Both requests are now added to the code, available on Git.
I didn't really test it so please do so ;-)

Thanks Marcel Big Grin

Well, made some quick tests. Don't know if that's me or some tunes in the script but I get none of the new backup options to work.

I tried this with import :

Code:
<onclick>RunScript(script.skin.helper.service,action=restore,silent=extras\ColorShemes\KOver_ColorScheme_Default.zip)</onclick>

Returns this in log :

Code:
09:32:01 T:7528  NOTICE: Skin Helper Service --> ERROR while restoring backup ! --> [Errno 2] No such file or directory: u'C:\\Users\\jerome.MTLSA\\AppData\\Roaming\\Kodi\\cache\\KOVER_COLORSCHEME_DEFAULT.ZIP'

DialogBusy.xml is stuck there and the log stops here

I tried export the same way :

Code:
<onclick condition="StringCompare(Container(9400).ListItem.Property(NumTemp),MODEL1)">RunScript(script.skin.helper.service, action=backup, filter=MODEL1, silent=C:\test\test.zip)</onclick>

Returns this

Code:
09:56:41 T:8332   ERROR: XFILE::CDirectory::GetDirectory - Error getting zip://C%3a%5cTEST%5cTEST.ZIP/
09:56:41 T:8332  NOTICE: Skin Helper Service --> ERROR while creating backup ! --> [Errno 22] invalid mode ('wb') or filename: u'C:\\Users\\Jayz2K\\AppData\\Roaming\\Kodi\\cache\\C:\\TEST\\TEST.ZIP.zip'
09:56:41 T:8332   ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
                                             - NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
                                            Error Type: <type 'exceptions.IOError'>
                                            Error Contents: [Errno 22] invalid mode ('wb') or filename: u'C:\\Users\\Jayz2K\\AppData\\Roaming\\Kodi\\cache\\C:\\TEST\\TEST.ZIP.zip'
                                            Traceback (most recent call last):
                                              File "C:\Users\Jayz2K\AppData\Roaming\Kodi\addons\script.skin.helper.service-master\default.py", line 132, in <module>
                                                Main()
                                              File "C:\Users\Jayz2K\AppData\Roaming\Kodi\addons\script.skin.helper.service-master\default.py", line 119, in __init__
                                                backup.backup(filter,silent,promptfilename.lower())
                                              File "C:\Users\Jayz2K\AppData\Roaming\Kodi\addons\script.skin.helper.service-master\resources\lib\BackupRestore.py", line 143, in backup
                                                zip(temp_path,zip_temp)
                                              File "C:\Users\Jayz2K\AppData\Roaming\Kodi\addons\script.skin.helper.service-master\resources\lib\BackupRestore.py", line 267, in zip
                                                zf = zipfile.ZipFile("%s.zip" % (dst), "w", zipfile.ZIP_DEFLATED)
                                              File "C:\Program Files (x86)\Kodi\system\python\Lib\zipfile.py", line 756, in __init__
                                                self.fp = open(file, modeDict[mode])
                                            IOError: [Errno 22] invalid mode ('wb') or filename: u'C:\\Users\\Jayz2K\\AppData\\Roaming\\Kodi\\cache\\C:\\TEST\\TEST.ZIP.zip'
                                            -->End of Python script error report<--

And for export name entry prompt, It backups the normal way without the DialogKeyboard.xml opening for prompt.
I also activated the DebugInfo and I don't see it opening during all the process.

Here's the code :

Code:
<onclick condition="StringCompare(Container(9400).ListItem.Property(NumTemp),MODEL1)">RunScript(script.skin.helper.service, action=backup, filter=MODEL1, promptfilename=true)</onclick>

Hope that helps
[Skin] KOver - V1.1.0 Stable (Repo version)
[WIP] ReKOver - Skinning tool project

If I've been helpful or you like my work, hit "THANK USER" button ;) ...
Reply
(2015-09-11, 10:06)Jayz2K Wrote: Well, made some quick tests. Don't know if that's me or some tunes in the script but I get none of the new backup options to work.

Thanks for testing. Can you try with latest Git ? I fixed some stuff.
Also note that you must provide the VFS path...

So special://skin/extras/ColorShemes​/KOver_ColorScheme_Default.zip
Reply
Erm, yeah, sry for the VFS path.

Here's my new attempts :

Code:
<onclick>RunScript(script.skin.helper.service,action=restore,silent=special://skin/extras/colorschemes/kover_colorccheme_default.zip)</onclick>
and
Code:
<onclick condition="StringCompare(Container(9400).ListItem.Property(NumTemp),MODEL1)">RunScript(script.skin.helper.service,action=backup,filter=MODEL1,silent=special://skin/extras/test.zip))</onclick>

Returns invalid path in Log (tried it several times with renaming the zip mybackup.zip, moving it straight in extras/ ... no luck)

Code:
11:17:06 T:5492  NOTICE: Skin Helper Service --> ERROR while creating backup ! --> Path invalid. Make sure you provide the FULL path, for example special://skin/extras/mybackup.zip

Also tried again for export with name entry prompt, same result as before with the same command.
[Skin] KOver - V1.1.0 Stable (Repo version)
[WIP] ReKOver - Skinning tool project

If I've been helpful or you like my work, hit "THANK USER" button ;) ...
Reply
(2015-09-11, 10:01)marcelveldt Wrote:
(2015-09-11, 09:43)jurialmunkey Wrote:
(2015-09-11, 09:32)marcelveldt Wrote: Your code is just fine. Actually your log even indicates it has set the property.
If you open script-skinshortcuts-includes.xml after it has been built, can you see the property been added ?
No can't see it being set in there.

Working fine in my setup. I copied your exact button code and see this in my script-skinshortcuts-includes.xml:

<property name="tile​color">ff008000</property>
<property name="tile​color.name">office green</property>

You are sure you went back to home so it would build the menu ?
Figured out the problem. I was using a window close fade out animation in the colour picker that was interfering with the script setting the property properly.
Reply
(2015-09-11, 12:04)jurialmunkey Wrote: Figured out the problem. I was using a window close fade out animation in the colour picker that was interfering with the script setting the property properly.
Aha! Yeah, in that case I think the previous window will be kept longer active in memory.
Good catch. Do you want me to fix something for it or did you add a condition in the animation ?
Reply
Marcel, sorry for asking again, but I have to find a way to arrange my widgets, and assign defaults.
currently I can't make it, and i'm almost sure its just a syntax error or somthing, but what I did is to copy your overrides.xml from the git, and try to add my custom widgets.
ill show you an example of one widget (Recent Movies) and I need your help to assign it correctly.
http://pastebin.com/ybBGXMb6
see line 61 please.
the purpose is to assign it to the movies menu as default.
after ill do it, I will add by myself all the rest...

The code above is actually add the Recent Movies to the dialog, but when clicked, nothing is set. I added a label with:
Code:
<label>widgetType: $INFO[Container(9000).ListItem.Property(widgetType)] [CR]widgetTarget: $INFO[Container(9000).ListItem.Property(widgetTarget)] [CR]Path: $INFO[Container(9000).ListItem.Property(widgetPath)] [CR]Widget: $INFO[Container(9000).ListItem.Property(Widget)] [CR]Type: $INFO[Container(9000).ListItem.Property(widgetType)]</label>
to check the properties, and all of them are empty.
I need Property(widget) to be assigned, and the Property(widgetPath) to fill with the content, (as your saw before I use the widgetPath in the "content" tag.)

10x Again...
Phenomenal™ Skin • ForumWebsiteGitHub
Reply
(2015-09-11, 12:13)tomer953 Wrote: Marcel, sorry for asking again, but I have to find a way to arrange my widgets, and assign defaults.
currently I can't make it, and i'm almost sure its just a syntax error or somthing, but what I did is to copy your overrides.xml from the git, and try to add my custom widgets.

Use this (adjust to your needs):

PHP Code:
<widgetdefaultnode defaultID="movies" group="mainmenu" label="$ADDON[script.skin.helper.service 32003]" type="movies" path="plugin://script.skin.helper.service/?action=RECOMMENDEDMOVIES&amp;reload=$INFO[Window(Home).Property(widgetreload)]target="video">recommendedmovies</widgetdefaultnode>
    <
widgetdefaultnode defaultID="tvshows" group="mainmenu" label="31228" type="episodes" path="plugin://script.skin.helper.service/?action=nextepisodes&amp;reload=$INFO[Window(Home).Property(widgetreload)]target="video">nextepisodes</widgetdefaultnode>
    <
widgetdefaultnode defaultID="music" group="mainmenu" label="359" type="albums" path="special://skin/extras/widgetplaylists/recentalbums.xsp" target="music">recentalbums</widgetdefaultnode>
    <
widgetdefaultnode defaultID="musicvideos" group="mainmenu" label="20390" type="musicvideos" path="videodb://recentlyaddedmusicvideos/" target="video">recentmusicvideos</widgetdefaultnode>
    <
widgetdefaultnode defaultID="plugin.video.youtube" group="mainmenu" label="31563" type="video" path="plugin://plugin.video.youtube/special/popular_right_now/" target="video">popularyoutube</widgetdefaultnode>
    <
widgetdefaultnode defaultID="livetv" group="mainmenu" label="19017" type="pvr" path="plugin://script.skin.helper.service/?action=pvrrecordings&amp;limit=25&amp;reload=$INFO[Window(home).Property(widgetreload2)]target="video">tvrecordings</widgetdefaultnode>
    <
widgetdefaultnode defaultID="weather" group="mainmenu" label="8" type="static" path="$INCLUDE[WeatherWidget]target="static">weather</widgetdefaultnode>
    <
widgetdefaultnode defaultID="settings" group="mainmenu" label="130" type="static" path="$INCLUDE[SystemInfoWidget]target="static">systeminfo</widgetdefaultnode
Reply
(2015-09-11, 12:17)marcelveldt Wrote:
(2015-09-11, 12:13)tomer953 Wrote: Marcel, sorry for asking again, but I have to find a way to arrange my widgets, and assign defaults.
currently I can't make it, and i'm almost sure its just a syntax error or somthing, but what I did is to copy your overrides.xml from the git, and try to add my custom widgets.

Use this (adjust to your needs):
10x for the quick reply. I take the first line and
I added it inside the "</widget-groupings>" and nothing happened (not appear in the dialog picker, and not set the default when reset)
when I put it out from that tag, It still not availble in the picker, but when reset It worked perfect.. (assigned all the properties)
how do I add it to the dialog?

Code:
    </widget-groupings>
        <widgetdefaultnode defaultID="movies" group="mainmenu" label="31500" type="movies" path="plugin://service.library.data.provider?type=recentmovies&amp;reload=$INFO[Window(Home).Property(recentmovies)]" target="video">RecentMovies</widgetdefaultnode>
Phenomenal™ Skin • ForumWebsiteGitHub
Reply
Marcel, out of interest what is your plan for submittal to the Kodi repo of this script?
Reply
(2015-09-11, 12:40)tomer953 Wrote: 10x for the quick reply. I take the first line and
I added it inside the "</widget-groupings>" and nothing happened (not appear in the dialog picker, and not set the default when reset)
when I put it out from that tag, It still not availble in the picker, but when reset It worked perfect.. (assigned all the properties)
how do I add it to the dialog?

Code:
    </widget-groupings>
        <widgetdefaultnode defaultID="movies" group="mainmenu" label="31500" type="movies" path="plugin://service.library.data.provider?type=recentmovies&amp;reload=$INFO[Window(Home).Property(recentmovies)]" target="video">RecentMovies</widgetdefaultnode>

<widgetdefaultnode > has nothing to do with the widgets that are shown to the user. It's only used to set the default widget for a menu item. To customise the widgets that are shown, either use <widget /> elements (outside of the widget-groupings, which will show up in the <content>widgets</content> group and can be set as menu default with the simpler <widgetdefault /> elements, or with a <shortcut /> element within the widget-groupings (which requires a widgetdefaultnode element if you also want to set it as default.)

Details of syntax for all of these (actually, possibly not for <shortcut />'s) are in the documentation included with Skin Shortcuts - Advanced Usage.txt, section "Overrides.xml", part 4 (widgets).
Reply
oh, I think I get it now... so I can play with the <content>widgets</content> location, and use my old method [widget and widgetdefault tags] with with the <widget-groupings> and nodes combined..
for a quick test, it seems to be working well! thanks.

Marcel, Always wondered if it will be possible to backup\restore shortcuts ?
Phenomenal™ Skin • ForumWebsiteGitHub
Reply
(2015-09-11, 13:58)tomer953 Wrote: oh, I think I get it now... so I can play with the <content>widgets</content> location, and use my old method [widget and widgetdefault tags] with with the <widget-groupings> and nodes combined..
for a quick test, it seems to be working well! thanks.

Marcel, Always wondered if it will be possible to backup\restore shortcuts ?

The backup function of this script will also backup/restore skin shortcuts
Reply
yes I know, which is great, but no way to filter just to skinshortcuts? want to pass my menus to other machine using different skin\same skin diff theme...
possible ?

Edit:
forgot to mention that there are unicode errors while restore
http://pastebin.com/1nh9zK8y
Phenomenal™ Skin • ForumWebsiteGitHub
Reply
also the Restore Theme dialog is not find .theme files
Code:
RunScript(script.skin.helper.service,action=restorecolortheme)
the choose and save theme actions is working fine.
Phenomenal™ Skin • ForumWebsiteGitHub
Reply
  •   
  • 1
  • 13
  • 14
  • 15(current)
  • 16
  • 17
  • 270
  •   
 
Thread Rating:
  • 18 Vote(s) - 4.56 Average



Logout Mark Read Team Forum Stats Members Help
skin helper service4.5618