•   
  • 1
  • 262
  • 263
  • 264
  • 265
  • 266(current)
Release -  skin helper service
(2018-11-28, 17:49)Angelinas Wrote:
(2018-11-28, 15:08)tiku100 Wrote: I don't know why, but every time I try to install skin.helper.service my Kodi 18 Leia RC2 (32 bits) on Android crashes. Only way to run Kodi again is deleting the folder from addon_data.

Last two lines in logfile don't give any important info:

14:02:45.501 T:18446744072669354352  NOTICE: Skin Helper Service --> Starting WebService on port 52307
14:02:45.503 T:18446744072782117232  NOTICE: Skin Helper Service --> Skin Helper Service version 1.1.26~alpha started
You have all future version Smile

SHS
version is 1.1.24
https://github.com/marcelveldt/script.sk.../addon.xml

Kodi
version of Kodi nightis is Kodi 18 Leia RC1
http://mirrors.kodi.tv/releases/android/arm/ 
 Oh! That worked!!! Thanks, mate! Big Grin

Replacing the addon.xml content avoids the crash!

And yes, haha, I'm using a build directly downloaded from the nightly channel. Concretely, this build:

17:31:48.005 T:18446744072974522736  NOTICE: Starting Kodi (18.0-RC2 Git:20181126-b851870). Platform: Android ARM 32-bit

I still have a problem, though. Mmm, SHS no longer crashes, but when I'm trying to install Titan MOD skin for Leia, the skin does not recognise the SHS version that is required and replaces it with version 1.0.0, leading to a new crash, obviously. If I edit the addons.xml file again with the content on your link, Kodi does not crash, but when installing Titan MOD skins asks again for the SHS version required...

So, Am i facing an endless loop here? I tried to edit the version info on the addon.xml file with no success:

<addon id="script.skin.helper.service" name="Skin Helper Service" version="1.0.0" provider-name="marcelveldt">

Sorry for being so "troublesome" and, of course, sorry for my English. I'm trying my best Smile
Reply
(2018-11-28, 15:08)tiku100 Wrote: There's another one, skin.helper.service unofficial, but can't install because of missing dependencies...
Hey, just jumping in. Theoretically it should work if you've installed both the newer unoffical and CherryPy 17.4 version from my post. The newer unofficial version by me uses a newer CherryPy version so that could be it. I'm currently using my own brewed version and it seems to work out fine.

Replacing the addon.xml could be the reason why you're getting issues with Titan MOD as you're essentially changing the add-on information and dependency info which could bring in mismatches.
Reply
(2018-11-28, 18:52)tiku100 Wrote:
(2018-11-28, 17:49)Angelinas Wrote:
(2018-11-28, 15:08)tiku100 Wrote: I don't know why, but every time I try to install skin.helper.service my Kodi 18 Leia RC2 (32 bits) on Android crashes. Only way to run Kodi again is deleting the folder from addon_data.

Last two lines in logfile don't give any important info:

14:02:45.501 T:18446744072669354352  NOTICE: Skin Helper Service --> Starting WebService on port 52307
14:02:45.503 T:18446744072782117232  NOTICE: Skin Helper Service --> Skin Helper Service version 1.1.26~alpha started
You have all future version Smile

SHS
version is 1.1.24
https://github.com/marcelveldt/script.sk.../addon.xml

Kodi
version of Kodi nightis is Kodi 18 Leia RC1
http://mirrors.kodi.tv/releases/android/arm/ 
 Oh! That worked!!! Thanks, mate! Big Grin

Replacing the addon.xml content avoids the crash!

And yes, haha, I'm using a build directly downloaded from the nightly channel. Concretely, this build:

17:31:48.005 T:18446744072974522736  NOTICE: Starting Kodi (18.0-RC2 Git:20181126-b851870). Platform: Android ARM 32-bit

I still have a problem, though. Mmm, SHS no longer crashes, but when I'm trying to install Titan MOD skin for Leia, the skin does not recognise the SHS version that is required and replaces it with version 1.0.0, leading to a new crash, obviously. If I edit the addons.xml file again with the content on your link, Kodi does not crash, but when installing Titan MOD skins asks again for the SHS version required...

So, Am i facing an endless loop here? I tried to edit the version info on the addon.xml file with no success:

<addon id="script.skin.helper.service" name="Skin Helper Service" version="1.0.0" provider-name="marcelveldt">

Sorry for being so "troublesome" and, of course, sorry for my English. I'm trying my best Smile

Hi, as i read you want to use the skin.titan.mod for leia.

For that you essentially need the skinhelper.service version in my repo (wich is 1.1.25)
The reason is that it has the 2 new functions wich are needed for the skin.
Tv show online yt lookup,cast listing netflix videoinfo)
Also some updated bolean conditions to get some functions work with Kodi leia.
(Its just working in krypton and leia)
(See changelog)


You should be able to install the other cherry py module after that manually, if needed.

I never faced the cherry py issues.

Maybe
- try a clean install of Kodi
- install marduks kodi repo from zip (repo ddl: http://marduklev.github.io/repository.ma...-1.0.3.zip )
- install marcelveldt beta repo via marduks repo)
- install the titan skin mod
Reply
(2018-11-16, 01:45)TheTimeWalker Wrote: Hey guys!

Like some of you I've had issues with the Skin Helper Service not working on UWP platforms. The good news is that I was actually able to fix this by removing the import from cheroot in the cherrypy addon dependency. The interesting thing is that this is needed to prevent socket inheritance but there was actually a catch where it instead made a dummy function. This somehow didn't work out for the add-on so I'm forcing that instead.

You can get the zip file here: https://github.com/TheTimeWalker/script....master.zip
Just overwrite the current cherrypy installation with that and there should be no error on boot
You Sir are a Legend.. This has been my problem since day one on Xbox..
Learn to enjoy every minute of your life. Be happy now. Don't wait for something outside of yourself to make you happy in the future. Think how really precious is the time you have to spend, whether it's at work or with your family. Every minute should be enjoyed and savored.
Reply
I'm seeing this thrown into the logs on 1.1.24 version, should I try and install .26 alpha?
Quote:00:26:30.528 T:151073547504   ERROR: Unhandled exception in thread started by
00:26:30.528 T:151073547504   ERROR: <bound method ListItemMonitor.delayed_flush of <ListItemMonitor(Thread-1, started 150978114800)>>
00:26:30.529 T:151073547504   ERROR: Traceback (most recent call last):
00:26:30.529 T:151073547504   ERROR:   File "/storage/emulated/0/Android/data/org.xbmc.kodi/files/.kodi/addons/script.skin.helper.service/resources/lib/listitem_monitor.py", line 402, in delayed_flush
00:26:30.533 T:151073547504   ERROR: self.reset_win_props()
00:26:30.533 T:151073547504   ERROR:   File "/storage/emulated/0/Android/data/org.xbmc.kodi/files/.kodi/addons/script.skin.helper.service/resources/lib/listitem_monitor.py", line 469, in reset_win_props
00:26:30.534 T:151073547504   ERROR: self.metadatautils.process_method_on_list(self.win.clearProperty, self.all_window_props.iterkeys())
00:26:30.534 T:151073547504   ERROR:   File "/storage/emulated/0/Android/data/org.xbmc.kodi/files/.kodi/addons/script.module.metadatautils/lib/metadatautils.py", line 281, in process_method_on_list
00:26:30.536 T:151073547504   ERROR: return self._process_method_on_list(*args, **kwargs)
00:26:30.536 T:151073547504   ERROR:   File "/storage/emulated/0/Android/data/org.xbmc.kodi/files/.kodi/addons/script.module.metadatautils/lib/helpers/utils.py", line 189, in process_method_on_list
00:26:30.537 T:151073547504   ERROR: all_items = [method_to_run(item) for item in items]
00:26:30.537 T:151073547504   ERROR: RuntimeError
00:26:30.537 T:151073547504   ERROR: :
00:26:30.538 T:151073547504   ERROR: dictionary changed size during iteration
Reply
  •   
  • 1
  • 262
  • 263
  • 264
  • 265
  • 266(current)
 
Thread Rating:
  • 17 Vote(s) - 4.53 Average



Logout Mark Read Team Forum Stats Members Help
skin helper service4.5317