XBMC 12.3 (Frodo) + Win 10: Broken SMB Shares
#1
Ok, the short of it is that after upgrading my main PC to Win 10, all my HTPC's started reporting that my movie and TV shows were missing (and did I want to remove them from my library).

So I went to edit the source, navigated to SMB share, and realize it won't connect anymore. it occurs to me that Win 10 replaced my login name and password with my Microsoft Account (Windows Live ID). So I type in my Live login (email + password), and no luck. I then try my MS Account alias + password... no luck.

So I go into user settings and I disconnect windows from MS Live and convert my admin account to a local account.

Now, back at the HTPC, I can actually browse the shared folders when I select my PC through SMB. Yay, the connection is working! or is it...

I have 10 drive shares. 2 of the shared drives are internal (SATA connected) and the other 8 are in external drive bays (USB 3.0 connection). Oddly, the two internal drives seem to be able to connect perfectly fine. The 8 external drives (where my media is) refuse to connect. It tells me "Invalid Argument" when I select these drives.

Googling this leads to a few pages about registry edits. Granted, they are specifically for Win 8, but as there isn't much info for Win 10 these days, I tried them. The first entails popping the IRPStackSize up and the second revolved around enabling access to SMB without authorization. Neither seemed to make a difference.

In frustration I rolled back the Win 10 install to Win 7, and immediately all my drives were accessible via XBMC again.

Now, the extra details:
Yes, I am running Frodo 12.3, installed via OpenElec. I have not moved to Kodi as the skin I use, Aeon Nox, has had *many* features removed from it since the version I have. Until I can get a Kodi setup that doesn't require giving up features I used to have, I don't plan on upgrading. Either way, the problem appears to be windows rather than XBMC/Kodi.

I have a laptop running Win10, so when I have free time I plan to share a media folder on it and see if I can get any of my HTPC's to recognize it. That said, I'm not sure how good this plan is, as I *was* able to get internal drives to show up just fine in XBMC. I have no idea why every single drive in the external bay was having problems (the permissions and settings on those shares were identical to the internal drives).

I will likely have to continue messing with it on my main machine. I'm posting here in hopes of finding others who may have had similar problems. Thanks!
Reply
#2
(2015-08-18, 16:11)exoscoriae Wrote: Ok, the short of it is that after upgrading my main PC to Win 10, all my HTPC's started reporting that my movie and TV shows were missing (and did I want to remove them from my library).

So I went to edit the source, navigated to SMB share, and realize it won't connect anymore. it occurs to me that Win 10 replaced my login name and password with my Microsoft Account (Windows Live ID). So I type in my Live login (email + password), and no luck. I then try my MS Account alias + password... no luck.

So I go into user settings and I disconnect windows from MS Live and convert my admin account to a local account.

Now, back at the HTPC, I can actually browse the shared folders when I select my PC through SMB. Yay, the connection is working! or is it...

I have 10 drive shares. 2 of the shared drives are internal (SATA connected) and the other 8 are in external drive bays (USB 3.0 connection). Oddly, the two internal drives seem to be able to connect perfectly fine. The 8 external drives (where my media is) refuse to connect. It tells me "Invalid Argument" when I select these drives.

Googling this leads to a few pages about registry edits. Granted, they are specifically for Win 8, but as there isn't much info for Win 10 these days, I tried them. The first entails popping the IRPStackSize up and the second revolved around enabling access to SMB without authorization. Neither seemed to make a difference.

In frustration I rolled back the Win 10 install to Win 7, and immediately all my drives were accessible via XBMC again.

Now, the extra details:
Yes, I am running Frodo 12.3, installed via OpenElec. I have not moved to Kodi as the skin I use, Aeon Nox, has had *many* features removed from it since the version I have. Until I can get a Kodi setup that doesn't require giving up features I used to have, I don't plan on upgrading. Either way, the problem appears to be windows rather than XBMC/Kodi.

I have a laptop running Win10, so when I have free time I plan to share a media folder on it and see if I can get any of my HTPC's to recognize it. That said, I'm not sure how good this plan is, as I *was* able to get internal drives to show up just fine in XBMC. I have no idea why every single drive in the external bay was having problems (the permissions and settings on those shares were identical to the internal drives).

I will likely have to continue messing with it on my main machine. I'm posting here in hopes of finding others who may have had similar problems. Thanks!

Had the same problem when upgrading to Win 10 on my laptop. I worked around it by mapping the drives and accessing them locally. Since I have seen similar messages posted in other forums it would appear that windows 10 has a problem with SMB.
Reply
#3
Unfortunately mapping locally wouldn't be an option in my situation. My HTPC's run OpenElec/Linux. While I'm sure a linux expert might have a few tricks up their sleeve, as far as I know, when accessing windows shares on a Linux box, SMB is to go-to solution.

I suppose if my media machines ran windows I could do something like that, but then they would suffer playback quality. The whole reason I run OpenElec was due to poor performance on the boxes in a windows environment.
Reply
#4
The username and password will be of the device where the share is stored.

Make sure you have the correct IP's set and the correct drive letters.
Media_Center_Master (wiki) || First_time_user (wiki) || Kodi Store || T-shirts: Villian, Protest, Graffiti, Emoji, Black on Black
Reply
#5
To clarify:
I was able to login and see the SMB's shared drives/folder
I was also able to then set the source to any shared drive that was hooked up via SATA inside the machine (D:, etc)
However my media is stored on drives that are in an external drive bay
Even though the internal and external drives are shared identically, when trying to open one as the video source XBMX reports "Invalid Argument".

So I know the login name & password are correct and working (once downgrading the Win10 machine to a local account and getting away from the Windows Live ID, which I still have no idea how one can use that with SMB).
The problem is that for some reason Win 10 handles some shared drives differently than others. In my case, the only difference I can see is their physical location and how they are connected to the computer. regardless however, the machine should treat all of the hard drives the same. There is no valid excuse for it to work with internal SATA drives but not external SB 3.0 drives.
Reply
#6
Your right it shouldn't make a difference what type of cable it's connected with as long as Windows can see it. Maybe it's a Frodo issue?

If you list the skin features/xbmc features that you like or think are gone, maybe a dev can give a yes or no and maybe why they are gone.
Media_Center_Master (wiki) || First_time_user (wiki) || Kodi Store || T-shirts: Villian, Protest, Graffiti, Emoji, Black on Black
Reply
#7
Unfortunately, I already tried that. This is in the release thread for Aeon Nox 5:
"so I know a lot of stuff is missing and/or different from 4.x.x. In order to create a resource friendly and usable gui, not everything from v4 could be added to v5. I had to make choices of what to include and not to include and I did that on basis of the views / options / features I myself use.
This means that the choice had to be made to rid options and redundant views out of the skin. So if you miss your favorite view / option or functionality, you'll have to make a mod to bring those back.
You'll see some elements of the touch skin Droid that I made return here."

Essentially, every view I used to use is gone, and the author's answer to it is to "go make a mod" to bring it back. If I had that ability, I wouldn't be asking for it, I'd be doing it. Everything that made that skin great is missing. Live backgrounds, lots of flexibility in setting up the media browser, etc...I suppose I should just try and find a new Kodi skin that works, but it is still a huge hassle to change my entire media server software (reinstall openelec on all 6 of my boxes) just because Windows 10 shits the bed when it comes to SMB.

Thats the whole reason I haven't really worried about going to KODI. It wasn't worth all that time and effort just to go to a skin that forced me to make compromises when everything worked fine as is.
Reply
#8
Win10 works perfectly fine and can SMB with multiple other devices I have with Kodi. Please try the SMB wiki (in my sig) and see if that helps.
Media_Center_Master (wiki) || First_time_user (wiki) || Kodi Store || T-shirts: Villian, Protest, Graffiti, Emoji, Black on Black
Reply
#9
I had the same problem when I upgraded my server to windows 10 - my HTPC could no longer access the shares.

It turned out that the guest account status is turned off in Win 10 as a security measure. When I turned it back on everything was as before.

Have a look at the Guest account status using the Local Group Policy Editor
Run gpedit.msc and then navigate to:

Computer Configuration - Windows Settings - Security Settings - Local Policies - Security Options - Account: Guest account status

Make sure it is enabled
Reply
#10
(2015-08-20, 10:18)MadScientist Wrote: I had the same problem when I upgraded my server to windows 10 - my HTPC could no longer access the shares.

It turned out that the guest account status is turned off in Win 10 as a security measure. When I turned it back on everything was as before.

Have a look at the Guest account status using the Local Group Policy Editor
Run gpedit.msc and then navigate to:

Computer Configuration - Windows Settings - Security Settings - Local Policies - Security Options - Account: Guest account status

Make sure it is enabled

You are the real MVP! Totally fixed my issue. My newly upgraded Windows 10 machine is the server and all other devices connect to it. A Fire TV, (2) Fire Sticks, Fire HD7, and 2 laptops. Changing this setting fixed it right away for me.
Reply
#11
Lightbulb 
(2015-08-20, 10:18)MadScientist Wrote: I had the same problem when I upgraded my server to windows 10 - my HTPC could no longer access the shares.

It turned out that the guest account status is turned off in Win 10 as a security measure. When I turned it back on everything was as before.

Have a look at the Guest account status using the Local Group Policy Editor
Run gpedit.msc and then navigate to:

Computer Configuration - Windows Settings - Security Settings - Local Policies - Security Options - Account: Guest account status

Make sure it is enabled

If you don't have Windows 10 Pro but rather Windows 10 Home (like myself), which doesn't have gpedit.msc available, you can enable successful sharing by disabling password-protected sharing for guest accounts as follows:

  1. Go to Control Panel\All Control Panel Items\Network and Sharing Center\Advanced sharing settings
  2. Scroll down to All Networks
  3. Scroll down to Password protected sharing
  4. Select the Turn off password protected sharing
  5. Click on Save changes

Also, I noticed that you (unfortunately) cannot have your main administrator account set up with your Microsoft account - you have to create a local admin account and add share permissions for that account specifically (you may be able to add an additional local administrator account and give that particular account the necessary permissions, but I'm too tired/lazy to go test that now).

Bob's your uncle and stuff.
Reply
#12
I had tried disabling password protected sharing.

As mentioned above, I could see and browse my network just fine. I simply couldn't connect to certain drive shares, even though the share settings on the host machine were identical between all the shares. The only difference I was able to identify was that drives connected internally via SATA were perfectly fine, but drives that resided in an external USB bay gave the "Invalid Argument" error.
Reply
#13
One possible work around is to use symbolic links (using MKLINK /J). You could create links in one of your internal drive shares connecting to each of your USB drive shares. You could then point Kodi at these links and access your external shares via the internal drives. I've actually used this method and it work well.
Reply
#14
I actually came across this issue differently and have a theory. I'm running Windows 10, upgraded from Windows 8.1, using a local account. Everything worked perfectly fine.

Then, my wife asked me if I could record "something", which requires recording a stream. I know Windows 10 comes with built-in screen recording via the Xbox app. Unfortunately, the Xbox app needs you to login with a Microsoft account. But it doesn't really establish that by logging into the app, you are actually changing your computer login account from a local to a Microsoft account. The only evidence you get of this is when it asks you for your local account password. But it doesn't make it clear that you're actually messing with your computer login.

Now, the Xbox app does an awesome job recording, but it's limited to 2 hours max. Still, it works really well. Of course, once I rebooted the computer, that's when I realized the problem as the computer wouldn't auto-login. Easy enough fix. And Kodi worked just fine. Until I tried to mark something as watched, which failed. And then I discovered the same errors in the log files regarding authentication. No changes to Kodi would make this work properly. I could still access the sources just fine from within Kodi, and watch whatever I wanted to, but I couldn't change the watch status or get rid of these errors. The only solution was to remove the shares on the computer (not tied to Kodi, I had them just setup for accessing the shares from Windows infrequently) and reboot.

So my theory is that the way Windows stores credentials for Windows shares is different depending on whether it's a local account or Microsoft account. And this conflicts with how Kodi access SMB.
Reply
#15
Sorry, did you ever solve this? Having similar issues and have tried regedits and al setting changes. Still getting invalid argument
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
XBMC 12.3 (Frodo) + Win 10: Broken SMB Shares00