•   
  • 1
  • 3
  • 4
  • 5(current)
  • 6
  • 7
  •   
  Thread Closed
Solved [JAPAN only] HTTP 502 Bad Gateway error for most of add-ons, scripts, and skins
#61
Things haven't changed here - 502 error all the way.
#62
I live in Japan (population 126 million) too, I think a large number of Kodi users and potential Kodi users do. I have the same issue - same type of log entries. curl fails with 502 error - bad gateway on specific dependencies when installing some plugins from the Kodi repository.

I went to Kodi repository in Chrome on Windows 7 to down the required dependencie that failed - in this case
http://mirrors.kodi.tv/addons/isengard/r...-1.0.0.zip
and when I click on it in the browser to download I get get "502 Bad Gateway nginx/1.8.0"

I know how to Google so I will find a different mirror and try it but you are not serve the masses in Japan at the moment, just thought you might want to know.

Thanks for the awesome best media player software that I use on a daily basis and would like to reccomend to my (non-techy) friends.

Best regards,
Ray Mercer
#63
it's kind of incredible that a mirror redirect issue can drag on for so long.
Do the maintainers even know about this issue? Is anyone even looking at it?
#64
I installed Kodi on a new iPad (non jailbroken) in Japan and suffered this error as I do on my HTPC installation. I took the iPad with me on a trip to the US and was able to successfully install all the add-ons I wanted while there. So this is issue clearly has nothing to do with how one has Kodi set up.


(2016-01-17, 14:38)raymer Wrote: Thanks for the awesome best media player software that I use on a daily basis and would like to reccomend to my (non-techy) friends.
It is not possible to do that as long as issues like this remain. Finding alternate mirrors or using VPN's is not something for non-techies.

(2016-01-17, 16:45)farcus Wrote: it's kind of incredible that a mirror redirect issue can drag on for so long.
Do the maintainers even know about this issue? Is anyone even looking at it?
Indeed it is.
#65
(2016-01-17, 21:30)msfc Wrote:
(2016-01-17, 16:45)farcus Wrote: it's kind of incredible that a mirror redirect issue can drag on for so long.
Do the maintainers even know about this issue? Is anyone even looking at it?
Indeed it is.
Sometimes yes. Remember no one is getting paid to do all this.
Read/follow the forum rules.
For troubleshooting and bug reporting, read this first
Interested in seeing some YouTube videos about Kodi? Go here and subscribe
#66
What needs to be done to fix this? Have a new host? I would offer to host, but, really I think that just updating a record to point our asian resolves to a server in europe would fix it.
Basically us here in Japan (and I think elsewhere in Asia) really can no longer use Kodi because we can't install even the most basic addons.
#67
Here is some background:
The mirror redirector mirrors.kodi.tv runs a piece of software called mirrorbits which uses geoip information to lookup where you are coming from and then redirects to the mirror that is closest.
As far as I can see all of our mirrors (all the possible mirrors that you could get redirected to) are working correctly, but apparently for some people in Japan it bugs out and you guys end up with a 502 issue.

At the moment it is completely unclear to me where this issue comes from, what causes it and where exactly it occurs.
Additionally, I am not able to reproduce it and I can not enable debugging on this machine because at approx 5000-10000 redirects per second the logging overhead is enormous.

The speed at which the number of connecting clients is growing is causing some problems as well :/

Image
#68
(2016-01-25, 16:59)Kib Wrote: Additionally, I am not able to reproduce it . . .

this is kind of surprising to me as I have been able to consistently produce the 502 error over four different isps (asahinet, OCN, softbank/yahoo, biglobe) and in three different geographic locations within Japan (Ehime, Akita & Kanto)
#69
(2016-01-25, 18:14)farcus Wrote:
(2016-01-25, 16:59)Kib Wrote: Additionally, I am not able to reproduce it . . .

this is kind of surprising to me as I have been able to consistently produce the 502 error over four different isps (asahinet, OCN, softbank/yahoo, biglobe) and in three different geographic locations within Japan (Ehime, Akita & Kanto)

nobody from the team is from japan and it doesn't happen to anybody else as it seems.
#70
I'd like someone in Japan to test right now
#71
(2016-01-26, 15:22)Kib Wrote: I'd like someone in Japan to test right now

following this link
http://mirrors.kodi.tv/addons/isengard/r...-1.0.0.zip

I'm still getting
Quote:502 Bad Gateway

nginx/1.8.0

this is at 22:38 local time (13:38 GMT)

edit: I can browse up to this point (or any other part of the mirror)
http://mirrors.kodi.tv/addons/isengard/r...nds.amber/
but any file download triggers the 502
#72
Quote:I'd like someone in Japan to test right now

Quote:following this link
http://mirrors.kodi.tv/addons/isengard/r...-1.0.0.zip

I'm still getting
502 Bad Gateway
nginx/1.8.0

I am in Kanagawa prefecture, Yokosuka city (just south of Tokyo) and I get the same thing with Chrome on Windows. The link above shows 502 Bad Gateway.

-Regards,
Ray Mercer
#73
working now.
Let me check some other links and my raspbpi OSMC install
#74
Ok it seems my change did work after al, at least for some people in Japan.
I just checked with someone in chat who was good enough to roll out a test server in Japan for a sec and do some testing.
All behaved normally, and except for there not being any downloadservers near Japan, the redirection still worked and downloads as well.

If it still does not work for you, please download the html page you get when you navigate to this specific url and pastebin or upload it somewhere. (this will publish your ip address to the world, so if you feel unsure about that, don't)
#75
further testing on OSMC / Raspberry Pi2B
I have been able to successfully install a number of addons that previously I was unable to due to the 502 error.
so - has something changed/fixed or is this just a small window where the stars have aligned to let me install some stuff?

edit: oh - @Kib, just noticed your post above mine.
So thanks - seems to be working well for me at the moment. :-)
Nice work
  •   
  • 1
  • 3
  • 4
  • 5(current)
  • 6
  • 7
  •   
  Thread Closed
 
Thread Rating:
  • 1 Vote(s) - 5 Average



Logout Mark Read Team Forum Stats Members Help
[JAPAN only] HTTP 502 Bad Gateway error for most of add-ons, scripts, and skins51