Solved [JAPAN only] HTTP 502 Bad Gateway error for most of add-ons, scripts, and skins
#34
I have the same issue (I live in Japan).

Log from Kodi
======
11:53:05 T:11596 DEBUG: CCurlFile::Open - effective URL: <http://trumpetti.atm.tut.fi/xbmc/addons/gotham/service.subtitles.subscenter/icon.png>
11:53:05 T:11620 ERROR: CCurlFile::FillBuffer - Failed: HTTP returned error 502
11:53:05 T:11620 ERROR: CCurlFile::Open failed with code 502 for http://mirrors.kodi.tv/addons/gotham/met...-1.1.2.zip
11:53:05 T:11620 ERROR: CAddonInstallJob[metadata.common.movieposterdb.com]: failed to download special://home/addons/packages/metadata.common.movieposterdb.com-1.1.2.zip
11:53:05 T:11620 ERROR: CAddonInstallJob[metadata.universal]: failed to install dependency metadata.common.movieposterdb.com
======

I tried directly from Chrome to access http://mirrors.kodi.tv/addons/gotham/met...-1.1.2.zip same issue.
I tried with a VPN (IP from France) and it worked.

DNS request to mirrors.kodi.tv points to 89.16.176.16.
I tried with my ISP's DNS and with the google's DNS (8.8.8.8),same result.

Here is the wireshark trace between my computer and 89.16.176.16:

========
GET /addons/gotham/metadata.common.movieposterdb.com/metadata.common.movieposterdb.com-1.1.2.zip HTTP/1.1
Host: mirrors.kodi.tv
Connection: keep-alive
Cache-Control: max-age=0
Accept: text/html,application/xhtml+xml,application/xml;q=0.9,image/webp,*/*;q=0.8
Upgrade-Insecure-Requests: 1
User-Agent: Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/46.0.2490.80 Safari/537.36
Accept-Encoding: gzip, deflate
Accept-Language: fr,en-US;q=0.8,en;q=0.6,ja;q=0.4
Cookie: mybb[lastvisit]=1447121061; mybb[threadread]=a%3A4%3A%7Bi%3A237787%3Bi%3A1447116117%3Bi%3A194545%3Bi%3A1447118260%3Bi%3A183114%3Bi%3A1447121061%3Bi%3A237874%3Bi%3A1447123932%3B%7D; mybb[lastactive]=1447124127; loginattempts=1; mybbuser=71319_eGKj3QkPh1jTpv4Tdul7zwn3dsgJP7gZARwCwJDj5QxbFlkBd8; sid=554e3b5616a9a54a88a89821ab16dfc6; _ga=GA1.2.1030180076.1447036983

HTTP/1.1 502 Bad Gateway
Server: nginx/1.8.0
Date: Tue, 10 Nov 2015 02:58:09 GMT
Content-Type: text/html
Content-Length: 574
Connection: keep-alive

<html>
<head><title>502 Bad Gateway</title></head>
<body bgcolor="white">
<center><h1>502 Bad Gateway</h1></center>
<hr><center>nginx/1.8.0</center>
</body>
</html>
<!-- a padding to disable MSIE and Chrome friendly error page -->
<!-- a padding to disable MSIE and Chrome friendly error page -->
<!-- a padding to disable MSIE and Chrome friendly error page -->
<!-- a padding to disable MSIE and Chrome friendly error page -->
<!-- a padding to disable MSIE and Chrome friendly error page -->
<!-- a padding to disable MSIE and Chrome friendly error page -->

=======


Messages In This Thread
RE: Keep getting HTTP 502 Bad Gateway error for most of add-ons, scripts, and skins - by Ragebond - 2015-11-10, 05:22


Logout Mark Read Team Forum Stats Members Help
[JAPAN only] HTTP 502 Bad Gateway error for most of add-ons, scripts, and skins1
This forum uses Lukasz Tkacz MyBB addons.