Record iptv (from epg)

  Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
pan_klobouk Offline
Junior Member
Posts: 3
Joined: Mar 2017
Reputation: 0
Post: #46
Just unzip and copy whole folder pvr.iptvsimple to /home/osmc/.kodi/addons/
https://github.com/rkubera/pvr.iptvsimple/releases
find quote
leisan Offline
Junior Member
Posts: 17
Joined: Jan 2017
Reputation: 0
Post: #47
(2017-03-09 10:46)pan_klobouk Wrote:  Just unzip and copy whole folder pvr.iptvsimple to /home/osmc/.kodi/addons/
https://github.com/rkubera/pvr.iptvsimple/releases

Thanks for helping me but in that folder I only have four folders in the path that you say:

Movies
Music
Pictures
TV Showns

I don't have the ".kodi" folder. Can you help me?

[Image: 35a87yt.jpg]
find quote
leisan Offline
Junior Member
Posts: 17
Joined: Jan 2017
Reputation: 0
Post: #48
Ok, the problem was that the folder was hidden. I installed the addon but now I have a new problem. I need to configure the addon to record but the folder "rtmpdumb" and "ffmpeg" don't exist in OSMC. I install this addon in LibreElec with the path to folders, but in OSMC the folders that I need don't exist in "/usr/bin".

Can you help me?

This is the capture of the configuration in LibreElec.

[Image: 33wm8o5.jpg]

The recording in LibreElec don't work, that's why I'm installing the addon in OSMC.
(This post was last modified: 2017-03-09 18:01 by leisan.)
find quote
pan_klobouk Offline
Junior Member
Posts: 3
Joined: Mar 2017
Reputation: 0
Post: #49
You have to connect via putty to osmc and install required packages:

sudo apt-get update
sudo apt-get install rtmpdump libav-tools

Next you have to set ffpmeg binary path to: /usr/bin/avconv
rtmpdump you have correct
find quote
leisan Offline
Junior Member
Posts: 17
Joined: Jan 2017
Reputation: 0
Post: #50
(2017-03-10 17:34)pan_klobouk Wrote:  You have to connect via putty to osmc and install required packages:

sudo apt-get update
sudo apt-get install rtmpdump libav-tools

Next you have to set ffpmeg binary path to: /usr/bin/avconv
rtmpdump you have correct

Thanks a lot, now is recording perfect but I have 2 new problems. In the sub-menu of LIVE TV, is the shorcut "recordings". If I navigate with the file explorer of OSMC I see the files of recordings but when I open the shorcut of "recordings" of submenu of LIVE TV, I don't see any files, is empty. What path I have to put in addon of PVR IPTV SIMPLE CLIENT to see the files here:

[Image: 359kfhj.jpg]

The other problem is that the video quality of recordings are very bad. The recordings are very pixelated. The option to configure the video quality is "recompression params" no? What I have to put to increase the quality of video?
(This post was last modified: 2017-03-10 19:03 by leisan.)
find quote
Philipp91 Offline
Junior Member
Posts: 3
Joined: Mar 2017
Reputation: 0
Post: #51
I have the same problem as leisan, I can't find the finished recordings in the respective menu. The file in the recordings folder is created, though.

In addition, timeshift doesn't work for me (I press pause but nothing happens). Should that be working?

Lastly, I tried to compile the rkubera/pvr.iptvsimple repo for Windows, but it due to some weird Unicode stuff. See my post here http://forum.kodi.tv/showthread.php?tid=...pid2550900 if you can help.
find quote
leisan Offline
Junior Member
Posts: 17
Joined: Jan 2017
Reputation: 0
Post: #52
(2017-03-18 20:04)Philipp91 Wrote:  I have the same problem as leisan, I can't find the finished recordings in the respective menu. The file in the recordings folder is created, though.

In addition, timeshift doesn't work for me (I press pause but nothing happens). Should that be working?

Lastly, I tried to compile the rkubera/pvr.iptvsimple repo for Windows, but it due to some weird Unicode stuff. See my post here http://forum.kodi.tv/showthread.php?tid=...pid2550900 if you can help.

I hope someone can help us with our problem. You know how to increase the video quality in reecordings?
find quote
azh1000 Offline
Junior Member
Posts: 4
Joined: Mar 2017
Reputation: 0
Post: #53
On Kodi 17 I have a different problem.

Running LibreElec 8.0.0 (Kodi 17) and I installed the Ubuntu version on top of the default version.
Plugin is working and I can start a recording.

Using SSH I can see that the file is recording in the correct folder. When the recording ends the file vanishes from the file system.
Any ideas?
find quote
azh1000 Offline
Junior Member
Posts: 4
Joined: Mar 2017
Reputation: 0
Post: #54
I can see the following in the logs. Why does it delete the file right after stopping?

19:33:11.809 T:140411898951424 NOTICE: AddOnLog: PVR IPTV Simple Client: Stopping recording News [New!]
19:33:11.810 T:140411898951424 NOTICE: AddOnLog: PVR IPTV Simple Client: Updated job entry News [New!]
19:33:14.002 T:140412245227264 NOTICE: AddOnLog: PVR IPTV Simple Client: Try to delete recording News [New!]
19:33:14.003 T:140412245227264 NOTICE: AddOnLog: PVR IPTV Simple Client: Deleted job entry News [New!]
find quote
rkubera Offline
Junior Member
Posts: 9
Joined: Jan 2017
Reputation: 0
Post: #55
Hi.
@leisan - recordings folder is not supported by this add-on. Find your recordings using "Videos" please.
For better quality add to recompression params for ffmpeg: -vcodec h264 or -vcodec libx264 please (you can check properly codecs using shell command:
ffmpeg -encoders)

@azh1000
Your log seems to be fine, but add-on not connected properly to source (bad address? stream cannot be viewed 2x in the same moment from the same ip? ). Check, if file size is increases during video recording. Recording will be deleted only if no data was received from the source.
Regards,
Radek.
(This post was last modified: 2017-03-25 12:54 by rkubera.)
find quote
leisan Offline
Junior Member
Posts: 17
Joined: Jan 2017
Reputation: 0
Post: #56
(2017-03-25 12:33)rkubera Wrote:  Hi.
@leisan - recordings folder is not supported by this add-on. Find your recordings using "Videos" please.
For better quality add to recompression params for ffmpeg: -vcodec h264 or -vcodec libx264 please (you can check properly codecs using shell command:
ffmpeg -encoders)
Regards,
Radek.

Hi Radek, thanks for the info. I'm trying with the new params but I have new problems. In the param what I have to put? By default is

"-ar 44100"

I try with this:

"-ar 44100 -vcodec h264" - Result: Start recording, creates a file that is deleted when the recording stop. The addon don't "open" the TV channel that is recording. It's recording nothing.
"-ar 44100 -vcodec libx264" - Result: Start recording, creates a file and stop the recording. The file that generate is a black vídeo, no TV is recorded. With this param the addon opens the TV channel.

The only param that works the recording is the default param, "-ar 44100", but the video quality is very low. I am doying something wrong? Can you help me please? Thanks.
(This post was last modified: 2017-03-25 23:21 by leisan.)
find quote
azh1000 Offline
Junior Member
Posts: 4
Joined: Mar 2017
Reputation: 0
Post: #57
(2017-03-25 12:33)rkubera Wrote:  @azh1000
Your log seems to be fine, but add-on not connected properly to source (bad address? stream cannot be viewed 2x in the same moment from the same ip? ). Check, if file size is increases during video recording. Recording will be deleted only if no data was received from the source.
Regards,
Radek.

Thanks for replying back.

I can confirm that
1) the file size is increasing as recording is happening.
2) the file is there right until recording stops -> then vanishes
3) This happens for both instant and epg recordings (so all recordings)

This is happening with libreelec 8.0.0, Kodi 17.0
find quote
DaniloslWag Offline
Junior Member
Posts: 5
Joined: Mar 2017
Reputation: 0
Post: #58
Да, действительно. Это было и со мной. Можем пообщаться на эту тему. Здесь или в PM.
find quote
DarrenHill Offline
Team-Kodi Minion
Posts: 5,932
Joined: Oct 2014
Reputation: 150
Location: UK, except when I'm not.
Post: #59
The forum is English language only please, and as yet your account does not have PM priviledges.

| Banned add-ons (wiki) | Forum rules (wiki) | First time user (wiki) | FAQs (wiki) | Troubleshooting (wiki) | Add-ons (wiki) | Free content (wiki) | Debug Log (wiki) | Free Movies/TV Shows
find quote
rkubera Offline
Junior Member
Posts: 9
Joined: Jan 2017
Reputation: 0
Post: #60
@azh1000
I cannot reproduce your problem, but I prepared new test package for osmc and openelcec/libelec:
https://github.com/rkubera/pvr.iptvsimpl...g/osmctest
In this package i removed all lines with files deletion and replaced this with log notice "Warning - recording can be corrupted".

Please replace old package with new one, restart kodi and try again.
After recording check if recording is ok and send me info from log, please.
If will be fine i will add this changes to the repository.

@leisan
It seems your ffmpeg (avconv) not supports h264 encoder correctly. Try another codec (maybe mpeg2?)
Please read ffmpeg(avconv) documentation - add-on only get stream from ffmpeg and store it on the filesystem.
Try to find in kodi log recording shell command (it is started from: "Starting ffmpeg: ..." on the log file) and run it from command line:
- you can check recording messages and find best ffmpeg (avconv) recording parameters
- after them set new parameters in kodi add-on configuration.

Regards,
Radek.
(This post was last modified: 2017-03-26 17:47 by rkubera.)
find quote