[AirPlay][Warning] Don't update to iOS9 if you want AirPlay to Kodi

  Thread Rating:
  • 3 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
Memphiz Offline
Kodi MVP
Posts: 16,097
Joined: Feb 2011
Reputation: 227
Location: germany
Post: #241
Did you turn off video and picture setup in kodi - settings - services - airplay ? (Ensure to have expert settings level turned on for this setting)

AppleTV4/iPhone/iPod/iPad: HowTo find debug logs and everything else which the devs like so much: click here
HowTo setup NFS for Kodi: NFS (wiki)
HowTo configure avahi (zeroconf): Avahi_Zeroconf (wiki)
READ THE IOS FAQ!: iOS FAQ (wiki)
find quote
pierino84 Offline
Junior Member
Posts: 3
Joined: Dec 2016
Reputation: 0
Post: #242
(2017-01-01 16:12)Memphiz Wrote:  Did you turn off video and picture setup in kodi - settings - services - airplay ? (Ensure to have expert settings level turned on for this setting)

It is now working as expected, thank you very much for your suggestion!
find quote
DaveClay Offline
Junior Member
Posts: 1
Joined: Jan 2017
Reputation: 0
Post: #243
Sorry. I'm a total newb, but I'm psyched to find out about Kodi. Just installed Jarvis on my Fire stick. Just want to airplay songs, but I turned on the airplay setting, turned off the pix and video support setting, and still, neither my iphone 6 (iOS 10.2) nor iTunes on my macbook (OSX 10.12.2) seems to recognize an airplay target. Tried turning everything off and on again to no avail. Will airplay only run through the Kodi app or something? Apologies if this is too vague a question to be answered, but any help would be appreciated.
find quote
Mettbrot Offline
Senior Member
Posts: 280
Joined: Jan 2011
Reputation: 4
Location: Aachen
Post: #244
In order for Aiplay to work you have to enable zeroconf (Settings > Services >General) support in Kodi settings. Also, if you run Kodi on a Windows Machine, you have to install iTunes to get the Bonjur Process running on which Airplay relies.
find quote
espressionist Offline
Junior Member
Posts: 1
Joined: Mar 2017
Reputation: 0
Post: #245
(2017-01-03 02:18)pierino84 Wrote:  
(2017-01-01 16:12)Memphiz Wrote:  Did you turn off video and picture setup in kodi - settings - services - airplay ? (Ensure to have expert settings level turned on for this setting)

It is now working as expected, thank you very much for your suggestion!

Had the exact same problem and was troubleshooting for more than 2 days with various tools (including wireshark UndecidedSad:sniffleSmile
worked as a charm!
find quote
Post Reply