•   
  • 1
  • 45
  • 46
  • 47(current)
  • 48
  • 49
  • 134
  •   
WeTek Core (24p HD Netflix / HD Audio / Lollipop / OpenELEC / 4K / HEVC)
i've tested now with mx player and it's the same
For me it's working normally
Forced it to run 24p.
Reply
Not sure if it makes any difference, but mine is set to 1080p50 as I am in the uk. It all plays nice and smooth here with auto switching.
Reply
(2015-12-17, 22:17)lstar337 Wrote: Not sure if it makes any difference, but mine is set to 1080p50 as I am in the uk. It all plays nice and smooth here with auto switching.

I´m from Spain yo theorically I must put in 108050P, but is more laggy with the mouse that 60P
Reply
(2015-12-17, 19:38)wrxtasy Wrote: This could possibly work for you: (Note the Kodi GUI will be pretty slow, as you have probably found out)
Set the Android GUI to 60Hz or best resolution.
Automatic refresh rate On

Now find the Android Refresh Rate Switch App > and highlight Kodi
What this does is switch you TV to 24p movie Mode before Kodi starts.

Now in Kodi Settings > System > Video > Adjust Display Refresh rate > Start/Stop

With this setting you will be able to play other files not just 23.976fps ones.
Its a workaround but will work until a permanent solution is found.

This works! Confused

I don't understand why I have to do this workaround while other people can make Kodi to work fine without the workaround.

Is there any explanation for this? And more important, is there a permanent solution? Kodi GUI is pretty slow at 24p

Thanks wrxtasy
Reply
After my initial review, which were all 1-2 min test clips, I did more thorough tests today... and found some issues:

This is under Android OS:
  • 23.976 plays at "23.97" (as indicated by my PJ), but I see micro speed-ups (judders) about every 42 seconds, pretty consistently. This is with Kodi set to 'adjust refresh rate' and 24Hz not forced via refresh rate switcher app (as recommended for Kodi). I watched a 23.976 movie for about 45 mins.
  • With 23.976, what's odd through is when I played actpower's rolling end credits clip, the first time I noticed frame skips/jumps every 40 seconds or so, but when I stopped, then played it again for the full 4 minutes, it seemed smooth.
  • Plan to watch more 23.976 content and make sure if the micro speed-ups/judders are always present on various videos; can't say for centain now based on above.
  • Tested audio channel mapping issues further with DD5.1 and 7.1 THD/MA clips (channel check clips from Dolby and DTS)
    - With standard DD5.1, in my 7.1 set-up, the rear surround bits play via the side speakers (not correct, should be rears)
    - With DTS-HD MA 5.1, the surrounds play correctly via the rears, and center & LFE are present as well
    - Don't have a standard DTS 5.1 channel-check clip, but I'm guessing it'd play correctly as well
    - With any 7.1 HD audio, the sides/rears are swapped, and there's no center and no LFE (so, channel mapping is definitely screwed up)
Now, onto OpenELEC:
  • Tested with WeTek's Kodi 16 image here.
  • UI starts in 720p, so switched to 1080p.
  • In audio settings, there are no passthrough options, so enabled the '8-channel DTS-HD audio decoding' option (same as with Kodi 16/17 on Raspberry Pi and nVidia Shield) as that's all there was.
  • Core refused to connect to my SMB and NFS shares. Tries multiple times, but no luck. There's some network connectivity issue in this OE build.
  • Attached USB hard drive with test clips, and tried standard DD/DTS and TrueHD/DTS-MA clips... no audio from any of them!
  • 3D MVC and 3D ISO's play in 2D mode, as via Android OS. So, I believe droidelec is mistaken Core can now play MVC, in 3D mode anyway. Unless, there's a different OE build that I should be using?
  • Didn't bother to test further as already too many major issues with OpenELEC, in this build anyway.
[H]i-[d]eft [M]edia [K]een [V]ideosaurus
My Family Room Theater
Reply
hdmkv: I've got android box envy!

Thanks for posting your detailed review. I would agree that for the money the WeTek core is a quality product with excellent community support. I'm just experiencing challenges navigating through the regular Android environment as I prefer Android TV.

Time to spend a little more quality time with the WeTek core to see where it fits into my Home Theatre setup.

Does anyone know why I cannot see the deinterlacing settings in KODI 15.2 under the video options?

Peace
Reply
(2015-12-17, 23:33)hdmkv Wrote: Now, onto OpenELEC:
hdmkv, please test my recently fixed 24p OpenELEC 6.0.0 found here. You may find smoother video sync results compared to the ones WeTek are supplying:
(this may still have the OpenELEC MAC address Network connectivity issue, mine setup is fine tho)
wrxtasy's OpenELEC 6.0.0 Kodi 15.2 final

My 23.976fps video sync test clips I use are found here: (watch the top line of scrolling vertical bars for smoothness)

Video FPS Sync Testing Clips



@slot47 > the reason you don't see any de-interlacing options is because Kodi loses all control of video manipulation once video is sent to the AMLogic Hardware decoder. If you disable all Hardware acceleration, I believe the deinterlacing options would again popup.



Questions for those WeTek Core Users having inconsistent 23.976fps video sync problems with Android OS ?

- When you set Kodi to Refresh Rate Switch using this option:
Settings > Videos > Playback > Adjust Display Refresh Rate > On start/stop (only choose start/stop)

did you also set a delay before starting 23.976fps video playback, like I have suggested previously:
- Pause during refresh rate change > 1 or 2 seconds (or greater)

Mine is set at 2 seconds as my TV is slow to switch Refresh Rates.

What may be happening is the AMLogic supplied Linux Kernel used in the Android OS, is having problems syncing the HDMI clocks (required for 24p Frame Rate Automation), during a TV refresh rate switching phase and just defaults to outputting 23.976fps video at 24Hz. This then leads to the inevitable 41 second video frame glitch some people are seeing.

Every users TV is different and some will Refresh Rate Switch and stabilise and sync quicker than others.

Reply
I don´t have tested yet the trick to force 24P to whole Kodi App, but do you say that the problem will be solved with the "pause during refresh rate change" option?. This will make sense, but it is related to Core, not to Kodi itself. My TV takes more of 2 seconds to change the resolution, and the projector more. I will test this today to see what happens...
Reply
No this is not just the Core, but the way ALL AMLogic devices that switch the TV's refresh rate and use the HDMI clocks to sync 23.976fps video output operate.
You need to set a delay depending on how slow your TV is switching into its 24p movie mode.

That is exactly what this setting was designed for in the first place, every media player platform is different with the way underlying features operate in the OS.

You cannot generalise and say just because A platform does this then B platform should be exactly the same when they are using different hardware.

Reply
Ok, I have tested:

1) Set a delay of six seconds (more time that the TV change the resolution) and play the test file...DON´T WORK. The jumps are there

2) Force Kodi to 24P and play the test file: SUCESS. Don´t jump at all

So I don´t know if it´s a Kodi or a Core problem, but this are my results.

I repeat. No other device I own make this annoying thing. My displays play PERFECTLY 23.976FPS, so don´t blame me with the Amlogic issue or whatever...I demonstrate that there is a PROBLEM. You can say that you can say, I have lost a lot of time testing this and not enjoying any movie in TWO WEEKS.

When next Monday I receive the Minix NEO U1 will test again, to see what happens.
Reply
Just as a head up with this 24p syncing issue.

WeTek have found the problem and it relates to the order Android Kodi video playback is started before switching TV refresh rates and resolution on Android AMlogic Frame Rate Automation Kernels.

As some people have found, forcing 24p video output, and a TV to switch before Android Kodi video playback starts fixes the 24p sync playback problem (you have to disable Kodi Refresh Rate switch too)..

In the interim, until the Android Kodi code itself is patched, I suggest running the Android OS and Kodi GUI at 60Hz and:

set Kodi to Refresh Rate Switch using this option:
Settings > Videos > Playback > Adjust Display Refresh Rate > Off

My personal OpenELEC has no such 24p issues. Its a different beast running Linux flavoured Kodi underneath.

Reply
(2015-12-18, 12:08)wrxtasy Wrote: set Kodi to Refresh Rate Switch using this option:
Settings > Videos > Playback > Adjust Display Refresh Rate > Off

Well, IMO, there is not much sense in activating both the Kodi refresh rate switch and the aml one.
It's one or the other.
Reply
I thought the order was Kodi signals > TV refresh rate switch to 24p > Kernel with Frame Rate Automation > 24p Video playback (23Hz mode) ?

How else do you get your TV into 24p mode Automatically ?

Reply
What I don't understand is why some people have this issue and some other's don't. If it's a problem related to Kodi and Amlogic communication, I would expect most of the users to find this issue.
Reply
(2015-12-18, 12:24)wrxtasy Wrote: I thought the order was Kodi signals > TV refresh rate switch to 24p > Kernel with Frame Rate Automation > 24p Video playback (23Hz mode) ?

How else do you get your TV into 24p mode Automatically ?
The AML also switch to 24p, afaik.
That's how it works on U1, where security is not even enabled for kodi switching.
Reply
  •   
  • 1
  • 45
  • 46
  • 47(current)
  • 48
  • 49
  • 134
  •   
 
Thread Rating:
  • 4 Vote(s) - 4.75 Average



Logout Mark Read Team Forum Stats Members Help
WeTek Core (24p HD Netflix / HD Audio / Lollipop / OpenELEC / 4K / HEVC)4.754