•   
  • 1
  • 86
  • 87
  • 88(current)
  • 89
  • 90
  • 134
  •   
WeTek Core (24p HD Netflix / HD Audio / Lollipop / OpenELEC / 4K / HEVC)
(2016-02-08, 19:09)fritsch Wrote:
(2016-02-08, 18:42)Boydford Wrote:
(2016-02-08, 18:14)fritsch Wrote: "with the passthrough stutter"? What are you running? Stutter with these builds - no stutter with the other builds? This is a thread about Wetek Core, right?

Hi, sorry I'm just skimming forums looking at the s905 development...I have a minix u1, which I notice a few posts back that someone was testing ur builds on. I was just interested if ur build, although for wetek would work.

A team colleague has run the code on those and it seemed to have worked ... currently building a new version: http://jenkins.kodi.tv/job/Android-ARM/7122/ give those a test, please. I think you need whatever newest firmware on the U1 available. Basically I want to write generic code - this amlogic special foobar is going on my nerves :-)

Appreciate it thanks...the minix Xbmc specific build does not work as they say...will give it try thanks
Reply
Yeah, please wait for the updated build: http://mirrors.kodi.tv/test-builds/andro...bi-v7a.apk

Edit: On my Marantz

DTS-HD okay
TrueHD okay
AC3 Okay
DTS Okay
EAC3: No sound yet

Btw. everything runs fine even with Adjust Refreshrate to match video. The additional buffer has helped a lot. As there is still one or two crackles at the beginning I try to give a bit more :-)
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
Excellent fritsch, I am going to test now.
Reply
@fritsch

Weird things:

1st play of file with DTS-HD audio track give so many interrupts

2nd time less interrupts

3rd time just one time interrupt, after that all perfect, but after 3 minutes and 20 seconds, again AVR loose signal and again locked signal.

Log is here

When enable automatic frame switch I cant get audio from file with DTS-HD track, while get audio from file with TrueHD track, but again is not stable, AVR loosing signal.

Log is updated.
Reply
I am quite happy it syncs at all and keeps it "somehow" ... there is nothing left I can do in that regard - As you know AMLCodec itself needs a rewrite, sync is pure luck as of now in master.

Best is: Use samples that you can sw decode with hd audio ...
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
Let me try to turn off amcodec and then play.

EDIT: Hurray! Plays perfect and no more interrupts in sound and signal to AVR is stable!
Reply
Forget that for hd content ...

Edit: Btw. with Framerate Automation turned off - all is fine for you, too?
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
Well, I am confused now, as I played 1080p HD .iso file without issue with turned off amcodec ?

With or without framerate automation when enable amcodec + this Kodi it cause this issues. Let me make short video.
Reply
(2016-02-08, 21:16)droidelec Wrote: Well, I am confused now, as I played 1080p HD .iso file without issue with turned off amcodec ?

With or without framerate automation when enable amcodec + this Kodi it cause this issues. Let me make short video.

There is somewhere a discussion on github about what needs to be fixed with AMLCodec, not only on android, but also on linux - it would be nice if your team could make the start here as I really lack the time to do so in my spare time.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
Yes, codesnake is already on it.

Log:

https://www.dropbox.com/s/87p2jytutknxcy...1.log?dl=0

Video:

https://www.dropbox.com/s/qq48w9rbm2y3i6...1.mov?dl=0
Reply
on mini mx s905 (assuming its HAL unpatched or whatever since i have no HD audio passthrough options) this lastest build breaks DTS passthrough, i get Dolby Digital output but nothing with DTS.
Main System - HTPC - Intel I3 6300 - Asrock z170 - 16 GB DDR4 - 128gb SSD - 65" UHD HDR Sony Android TV - Pioneer VSX 1130-K - 7.2.2 speakers
Other devices currently in use - 55" 3D UHD LG TV - 2 Fire TV's - Nexus Player - MiniMX s905 - Voyo Vmac Mini
Ubuntu Server - 12 TB NAS - MYSQL - Torrent Box
Reply
(2016-02-08, 21:24)dukester Wrote: on mini mx s905 (assuming its HAL unpatched or whatever since i have no HD audio passthrough options) this lastest build breaks DTS passthrough, i get Dolby Digital output but nothing with DTS.

No Debug Log, no issue ...
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
For the records, on S905 I have no problems with DTS, not with any other format, just with EAC3 that is a known issue right now.
I'm installing the kodi-20160208-76875b1-androidtestv3-armeabi-v7a.apk on my Core now to try it here as well.
Reply
(2016-02-08, 21:33)ChristianTroy Wrote: For the records, on S905 I have no problems with DTS, not with any other format, just with EAC3 that is a known issue right now.
I'm installing the kodi-20160208-76875b1-androidtestv3-armeabi-v7a.apk on my Core now to try it here as well.

What happens with EAC3? Can you post a log? (not a .rar please - something web readable).
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
I will do it tomorrow morning now there's my people watching TV, basically it turns on the DD+ sign on the AVR and the audio plays stuttering and farting/popping

I ended the tests on Core:
* AC3 ok
* DTS ok
* EAC3 nok (not even light on)
* TrueHD nok (stutters like on rc3 with koying patch but there doing "echo 0 > /sys/class/tv/policy_fr_auto" fixes it, here it has no effect, btw the link with the avr is stable)
* DTS-HD nok (stutters and when it happens the link with the avr is lost and re-negotiated)

As droidelec said, using MediaCodec TrueHD and DTS-HD work fine, but I get crappy playback from time to time using that, like if for some frames it plays in slow motion. That is weird because the codec used (it calls the amlogic omx codecs), are used by other apps, like youtube, netflix, etc. and there I never saw something like that
Reply
  •   
  • 1
  • 86
  • 87
  • 88(current)
  • 89
  • 90
  • 134
  •   
 
Thread Rating:
  • 4 Vote(s) - 4.75 Average



Logout Mark Read Team Forum Stats Members Help
WeTek Core (24p HD Netflix / HD Audio / Lollipop / OpenELEC / 4K / HEVC)4.754