Due to maintenance, our forum will be offline for a short while on Monday June 1st, around 22:00 UTC.

4k HEVC Decode in Linux - App Adjustment Needed?
#1
Hi All,

I noticed the rest of the chain for VDPAU HEVC decode was marked stable in last month or so:
NVidia Driver support has fixed most of the bugs 2 releases ago (Including what held back FFMPEG)
libvdpau support is good in V1.2+
FFMPEG support is no longer marked as experimental

Are any app changes needed? Is Kodi 16 likely to support 4K HEVC decode?
Reply
#2
it already does
Reply
#3
Just Installed Kodi 16 Alpha 3 along with Libvdpau 1.1.1 and the Nvidia 355.12 driver. Doesn't seem to be any hardware HEVC decode support though (Using an Nvidia Geforce 960). Do I need to do something else to enable the support? Or is the Ubunutu package not built with a new enough version of FFMPEG?
Reply
#4
make sure your libvdpau has hevc support. IIRC 1.1.1 is not enough
Reply
#5
I cant find a version newer than 1.1.1 here: http://people.freedesktop.org/~aplattner/vdpau/?C=M;O=A.

Also tried the nightly build (20/09/15) and it also does not seem to accelerate HEVC either, Kodi does detect HEVC but then seems to send it to the cpu, I get about 3fps on the 2 2.0Ghz Opteron cores within my VM.

vdpauinfo:
http://pastebin.com/uqxMbYeQ

Is there something I'm missing which is not yet merged?
Reply
#6
Debug Log please

and moving to linux support
Reply
#7
(2015-09-20, 10:32)Krobar Wrote: I cant find a version newer than 1.1.1 here: http://people.freedesktop.org/~aplattner/vdpau/?C=M;O=A.

Also tried the nightly build (20/09/15) and it also does not seem to accelerate HEVC either, Kodi does detect HEVC but then seems to send it to the cpu, I get about 3fps on the 2 2.0Ghz Opteron cores within my VM.

vdpauinfo:
http://pastebin.com/uqxMbYeQ

Is there something I'm missing which is not yet merged?

No all is fine. Was reported working by PhillipI that did the ffmpeg work. Your Debug Log will tell us.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
#8
Thanks for the replies, here is my log:
http://pastebin.com/2VBGfeGm
Reply
#9
Retry and don't cut the important parts.

Btw. As you are at it, your 24.0 and your 23.976 hz mode is totally wrong. Nvidia needs an xorg.conf to get those correct. But that has nothing to do with HEVC.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
#10
Here is the entire log file:
http://pastebin.com/xNqEneph
Reply
#11
btw. you run this in a virtual machine?
Quote:09:12:18 T:2999007104 NOTICE: Host CPU: QEMU Virtual CPU version 2.2.0, 2 cores available

Does VDPAU work for h264? For completeness also post a mediainfo of this file ...
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
#12
Hi,

Yes, run it in a KVM VM with VFIO passthrough of the video card. H264 acceleration definitely works, I get 15-20% across both cores with a 40mbit file when vdpau is enabled. If I disable vdpau then CPU climbs to 70-100% with severe drops in frame rate.

Mediainfo for the 3 sample files I have tried:
http://pastebin.com/bxs5cM9M
Reply
#13
Post a log with you playing h264 - for now I see no indication of any vdpau actually working in your logs.

Here is a 4k hevc file that works on my system: http://www.libde265.org/hevc-bitstreams/...-cfg02.mkv
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
#14
Here is a log of H264 With and Without VDPAU:
http://pastebin.com/mBsCwxCj

Thanks for the Link, will give the file a try tomorrow.
Reply
#15
Quote:18:59:12 T:2680138560 NOTICE: VDPAU Decoder capabilities:
18:59:12 T:2680138560 NOTICE: name level macbs width height
18:59:12 T:2680138560 NOTICE: ------------------------------------
18:59:12 T:2680138560 NOTICE: MPEG1 0 65536 4080 4080
18:59:12 T:2680138560 NOTICE: MPEG2_SIMPLE 3 65536 4080 4080
18:59:12 T:2680138560 NOTICE: MPEG2_MAIN 3 65536 4080 4080
18:59:12 T:2680138560 NOTICE: H264_BASELINE 41 65536 4096 4096
18:59:12 T:2680138560 NOTICE: H264_MAIN 41 65536 4096 4096
18:59:12 T:2680138560 NOTICE: H264_HIGH 41 65536 4096 4096
18:59:12 T:2680138560 NOTICE: VC1_SIMPLE 1 8190 2048 2048
18:59:12 T:2680138560 NOTICE: VC1_MAIN 2 8190 2048 2048
18:59:12 T:2680138560 NOTICE: VC1_ADVANCED 4 8190 2048 2048
18:59:12 T:2680138560 NOTICE: MPEG4_PART2_ASP 5 8192 2048 2048

Compiled against wrong VDPAU version?
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
4k HEVC Decode in Linux - App Adjustment Needed?00
This forum uses Lukasz Tkacz MyBB addons.