•  Previous
  • 1
  • 99
  • 100
  • 101
  • 102
  • 103(current)
 
Thread Rating:
  • 8 Vote(s) - 4.13 Average
Release - New plugin "iPlayer WWW"
(2017-10-17, 00:49)antisect Wrote:
(2017-10-17, 00:08)renzz Wrote:
(2017-10-16, 19:59)CaptainT Wrote: I am sorry to say, but I think you are getting an experimental website again. It all works well for me.
Please try deleting the file iplayer.cookies in your Kodi profile folder under userdata->addon_data->plugin.video.iplayerwww

I deleted that file (and rebooted) but unfortunately I'm still getting the same error.

i also deleted the iplayer.cookies and am still getting the error Eek

Looks like the experiments are over and this now affects all of us. Stupid me only saw your posts after I released 3.0.16 and 2.5.24, so I will need another round of releases to fix this. Nevertheless, it should be an easy fix and I will get right to it. Long story short: I now also get the same error.

Edit: The fix is done and on it's way to the repo. So Highlights should be back for you by tomorrow or so.
Reply
(2017-10-20, 21:36)CaptainT Wrote: Looks like the experiments are over and this now affects all of us. Stupid me only saw your posts after I released 3.0.16 and 2.5.24, so I will need another round of releases to fix this. Nevertheless, it should be an easy fix and I will get right to it. Long story short: I now also get the same error.

Edit: The fix is done and on it's way to the repo. So Highlights should be back for you by tomorrow or so.

Thanks CaptainT, I appreciate the effort, even if it has become a bit Whack-A-Mole lately Confused  I'll give it a try later and report back.
Reply
(2017-10-21, 10:28)renzz Wrote:
(2017-10-20, 21:36)CaptainT Wrote: Looks like the experiments are over and this now affects all of us. Stupid me only saw your posts after I released 3.0.16 and 2.5.24, so I will need another round of releases to fix this. Nevertheless, it should be an easy fix and I will get right to it. Long story short: I now also get the same error.

Edit: The fix is done and on it's way to the repo. So Highlights should be back for you by tomorrow or so.

Thanks CaptainT, I appreciate the effort, even if it has become a bit Whack-A-Mole lately Confused  I'll give it a try later and report back.

3.0.17 seems to fix both the Highlights and Categories issues, however, the 'Added' and 'Watching' links no longer work - I just get the "error - check the log' popup. The log shows: https://pastebin.com/raw/ZfiVCMXi

Mod-edit: please use a pastebin website for your snippets and log files.
Reply
(2017-10-21, 11:23)renzz Wrote: 3.0.17 seems to fix both the Highlights and Categories issues, however, the 'Added' and 'Watching' links no longer work - I just get the "error - check the log' popup. The log shows: https://pastebin.com/raw/ZfiVCMXi

Mod-edit: please use a pastebin website for your snippets and log files.

This is unrelated to the changes in 3.0.17. I can duplicate the problem. They must have changed the login mechanism once again. I currently cannot estimate if this is an easy fix or a more complex one. I will update as soon as I have more details, but I first need to take care of some (non-Kodi related) stuff.
Reply
(2017-10-23, 17:18)CaptainT Wrote:
(2017-10-21, 11:23)renzz Wrote: 3.0.17 seems to fix both the Highlights and Categories issues, however, the 'Added' and 'Watching' links no longer work - I just get the "error - check the log' popup. The log shows: https://pastebin.com/raw/ZfiVCMXi

Mod-edit: please use a pastebin website for your snippets and log files.

This is unrelated to the changes in 3.0.17. I can duplicate the problem. They must have changed the login mechanism once again. I currently cannot estimate if this is an easy fix or a more complex one. I will update as soon as I have more details, but I first need to take care of some (non-Kodi related) stuff.

OK, I think I figured why the sign in process fails. This is a minor change once again. However, Added and Watching still doesn't work for me, neither in a browser, nor in Kodi. Thus, I am not sure there is a problem with my account or with Added and Watching itself.

Are you able to edit the add-on on your own for a test? If so, please go to the resources\lib subdirectory of your add-on installation and open ipwww_common.py in a text editor. Assuming you are on 3.0.17 please change line 174 of the file from:


Code:
   p = re.compile('form method="post" action="([^""]*)"')

to

Code:
   p = re.compile('form action="([^""]*)" method="post"')

save the file and try signin in again in Kodi.

The sign-in process should work now, please let me know if you also get correct content in Added and Watching. If so, I will release this change soon, otherwise something bigger is broken at the moment. Please report back here.

If you are unable to edit the file, just also let me know and I will prepare a beta version for you to test.

For sake of clarification: What happened is, that they simply reversed the order of arguments in an HTML element. This has no influence on the function of a website at all, but breaks the add-on as it relies on a certain order to match correctly. If this simple change fixes the add-on, I will try to find a more robust solution which can cope with small changes like this better.
Reply
(2017-10-23, 20:05)CaptainT Wrote: The sign-in process should work now, please let me know if you also get correct content in Added and Watching. If so, I will release this change soon, otherwise something bigger is broken at the moment. Please report back here.

If you are unable to edit the file, just also let me know and I will prepare a beta version for you to test.

For sake of clarification: What happened is, that they simply reversed the order of arguments in an HTML element. This has no influence on the function of a website at all, but breaks the add-on as it relies on a certain order to match correctly. If this simple change fixes the add-on, I will try to find a more robust solution which can cope with small changes like this better.

I've made the edit and it does now sign me in and I can see my Added and Watched list. However, I cannot play anything - I get

Code:
Invalid URL /iplayer/episodes/xxxxxx: No schema supplied. Perhaps you meant
http://iplayer/episodes/xxxxxx

Also, Highlights is now not showing anything, so it looks like they've changed something again which has broken your previous fix  Confused
Reply
(2017-10-24, 11:08)renzz Wrote: I've made the edit and it does now sign me in and I can see my Added and Watched list. However, I cannot play anything - I get

Code:
Invalid URL /iplayer/episodes/xxxxxx: No schema supplied. Perhaps you meant
http://iplayer/episodes/xxxxxx

Also, Highlights is now not showing anything, so it looks like they've changed something again which has broken your previous fix  Confused

This is starting to annoy me. They fiddled with Highlights again, lots of small changes, that broke almost everything. They even added duplicates of group links, which need to be removed. Plus, I still cannot get Added and Watching to work. Must be something wrong on my end.  Stare

Since I am not sure about the changes to Added and Watching, I prepared a beta release on Github. If somebody would be so kind and download it from here, install it manually and give it a try, this would be most appreciated. If all goes well, I will be happy to release it officially.
Reply
(2017-10-26, 21:48)CaptainT Wrote: Since I am not sure about the changes to Added and Watching, I prepared a beta release on Github. If somebody would be so kind and download it from here, install it manually and give it a try, this would be most appreciated. If all goes well, I will be happy to release it officially.

The beta is working for me. I'm not a regular user of the highlights sections, but I do see programs there. The 'added' section is what I use most and it's working well.
Reply
(2017-10-27, 04:39)oattes Wrote:
(2017-10-26, 21:48)CaptainT Wrote: Since I am not sure about the changes to Added and Watching, I prepared a beta release on Github. If somebody would be so kind and download it from here, install it manually and give it a try, this would be most appreciated. If all goes well, I will be happy to release it officially.

The beta is working for me. I'm not a regular user of the highlights sections, but I do see programs there. The 'added' section is what I use most and it's working well.

OK, thanks for the test. I hope you also played back one or two programmes from Added.

Releases are on their way to the official repo and should arrive automatically. However, I recommend everyone who installed the beta to uninstall it manually and then pull the final release from the official repo again.
Reply
(2017-10-27, 06:20)CaptainT Wrote: OK, thanks for the test. I hope you also played back one or two programmes from Added.

Releases are on their way to the official repo and should arrive automatically. However, I recommend everyone who installed the beta to uninstall it manually and then pull the final release from the official repo again.

All working ok for me now. I can see and play stuff from Highlights and Added/Watching.

Thanks again CaptainT.
Reply
(2017-10-27, 06:20)CaptainT Wrote: oattes


The beta is working for me. I'm not a regular user of the highlights sections, but I do see programs there. The 'added' section is what I use most and it's working well.

OK, thanks for the test. I hope you also played back one or two programmes from Added.

Releases are on their way to the official repo and should arrive automatically. However, I recommend everyone who installed the beta to uninstall it manually and then pull the final release from the official repo again.

Release from the repo installed. Everything looks good (still). And, yes, I did play back several programs from both Added and Highlights (overall and by channel).

Thank you very much for your constant support and tracking the wily Beeb and their constant thrashing.  Wink
Reply
Is this addon working OK on the rpi using libreelec? Haven't run the addon for a while but I just get a blank screen and no errors in the log. Works fine on an Intel NUC with libreelec. I removed /storage/.kodi/userdata/addon_data/plugin.video.iplayerwww but still the same problem.
Reply
(2017-11-10, 16:34)plinkyplonky Wrote: Is this addon working OK on the rpi using libreelec? Haven't run the addon for a while but I just get a blank screen and no errors in the log. Works fine on an Intel NUC with libreelec. I removed /storage/.kodi/userdata/addon_data/plugin.video.iplayerwww but still the same problem.

I run it daily on a Slice box which is basically an RPi3 in a fancy case. There are no issues specific to LE, and if there were I'd get them resolved quickly.
Reply
(2017-11-10, 16:59)chewitt Wrote:
(2017-11-10, 16:34)plinkyplonky Wrote: Is this addon working OK on the rpi using libreelec? Haven't run the addon for a while but I just get a blank screen and no errors in the log. Works fine on an Intel NUC with libreelec. I removed /storage/.kodi/userdata/addon_data/plugin.video.iplayerwww but still the same problem.

I run it daily on a Slice box which is basically an RPi3 in a fancy case. There are no issues specific to LE, and if there were I'd get them resolved quickly. 

 

Same here, l run a Slice as well, all working fine thanks to all involved. :-)
​​​​​​​Kevin.
Reply
I wiped my complete .kodi directory and started again, iplayer-www then worked OK.
Reply
  •  Previous
  • 1
  • 99
  • 100
  • 101
  • 102
  • 103(current)
 
Thread Rating:
  • 8 Vote(s) - 4.13 Average



Logout Mark Read Team Forum Stats Members Help
New plugin "iPlayer WWW"4.138