Warning Kodi is not running on iOS9 - This is for developers only!
I think there's a general touch issue with the file manager on nightly builds that is most likely unrelated to iOS9.
The problem with "adding sources" in the file manager is that you need a double click and that's (as far as I know) not mapped for touch devices.

You can add sources if you have a bluetooth keyboard. just hit enter on the keyboard to get the "add sources" dialogue.

But that doesn't help much as adding repositories doesn't work.

as txprestige said adding an unzipped repository directly to the addon folder via ifunbox works but it doesn't seem to work via itunes file sharing.
2finger swipe left is a global "back" gesture - that file manager problem is present in normal nightlies as well and unrelated to my ios9 branch i think...
AppleTV4/iPhone/iPod/iPad: HowTo find debug logs and everything else which the devs like so much: click here
HowTo setup NFS for Kodi: NFS (wiki)
HowTo configure avahi (zeroconf): Avahi_Zeroconf (wiki)
can't figure out why Xcode will not sign the entitlements to kodi when archiving for web installation outside the app store. i can select my distribution profile but after archiving is succeeded 0 entitlements are signed and when i try to download it from my site it always comes up with a done or retry could not download

any help would be great if its something i can do
see Codesign.command
what do i edit in this file to make entitlements signed to my provisioning profile I've selected ?

Has anyone here actually even made an archive with there provision profile and tested it from a web install on any iOS 9 devices?
Keep getting 4 fail errors in the Xcode archive process of an ipa file selecting my iPhone Distribution code signing and its related provision profile. No entitlements are being signed in the end before actually packaging the ipa file. Any help would appreciated. Thanks in advance.
(2015-09-21, 23:58)BigCheese Wrote: hm....
dyld: Library not loaded: @executable_path/Frameworks/libsmbclient.dylib
Referenced from: /var/mobile/Containers/Bundle/Application/B14FF6A1-2295-49D7-A7B9-27926C2017D1/Kodi.app/Kodi
Reason: no suitable image found. Did find:
/var/mobile/Containers/Bundle/Application/B14FF6A1-2295-49D7-A7B9-27926C2017D1/Kodi.app/Frameworks/libsmbclient.dylib: mmap() error 1 at address=0x04AE8000, size=0x003C4000 segment=__TEXT in Segment::map() mapping /var/mobile/Containers/Bundle/Application/B14FF6A1-2295-49D7-A7B9-27926C2017D1/Kodi.app/Frameworks/libsmbclient.dylib
/private/var/mobile/Containers/Bundle/Application/B14FF6A1-2295-49D7-A7B9-27926C2017D1/Kodi.app/Frameworks/libsmbclient.dylib: mmap() error 1 at address=0x05058000, size=0x003C4000 segment=__TEXT in Segment::map() mapping /private/var/mobile/Containers/Bundle/Application/B14FF6A1-2295-49D7-A7B9-27926C2017D1/Kodi.app/Frameworks/libsmbclient.dylib

seems not to work out of the box with the described steps...

update: ok, found this: http://forum.kodi.tv/showthread.php?tid=...pid1817250 ... will try to update the depends again

update2: ok, it was the code signing... now working Smile great!!

What was the problem you found with code signing. I'm having the same issue. Any insight would be appreciated.

Sorry, forgot to leave the extra details that may help

OS: Yosemite
XCode: 7.1
SDK: 9.1
Device: iPad Air running iOS 9.1

UPDATE 2: See my post below, got it working sort of. Launches on my iPad Air but only when running it from XCode. But hey, it's getting better Smile
(2015-09-26, 03:20)MrMC Wrote: see Codesign.command

Codesign.command file indicates the Iphone developer profile is being looked at for signing although this does not show anything about provision profiles and if I edit the iPhone developer text with all others example:
iOS developer
iOS distribution
Iphone distribution

It rather fails out with 5 red errors or succeeds with 4 red errors but never signs any entitlements for my archive and will keep failing if I attempt to install my archived ipa over the web. Fails with a Done/Retry prompt.
I've tried to switch targets for my build to iOS 9 and iOS 8 and still no luck.

If I edit the codesign.command files text "iPhone Developer" with anything I believe the errors come up as an missing " ' " on line 31 and missing EOF.

If anyone here has actually succeeded in a archive build with there provision profile attached to entitlements and has tested and installed there archive via the web. Please elaborate on any info needed to edit and fix this codesign provision issue.

Thank you
(2015-09-22, 14:12)Memphiz Wrote: runnerr is right - it should read != in the install_name_tool branch.

I have added a commit to my repo

$ git pull
to get the change.

@txprestige - any chance you can double check this on an older ios version (different device?) i mean that bug you described via 1.?

@belltechdave as long as you only have one developer identity its ok to select "iOS Developer" because it will use your developer certificate. Changing the provisionimng profile doesn't influence the signing. You see if the full sign step is done if you look into the after build phase output in Xcode - it will show multiple outputs for signing. If i n doubt you always can alter this if condition so that it also does a full sign with your set identity (even if it is different from "iOS Developer"):


Was having the same issue running Yosemite, XCode 7.1 and iOS 9.1 on iPad Air. Switched Target build to 8.0, added the changes Memphiz made to the 3 files and switched from using iPhone Developer: <appleID> to the generic iOS Developer and it finally launched on my iPad Air. Only issue now is it only runs when I start it from XCode tethered.

UPDATE: @Memphiz you rock bro.

His other temporary fix worked on running Kodi uneathered to XCode. If you have that issue see his post here: Fix for not working untethered cause of Video Toolbox
I poked into making an archive for deployment. Oh what a mess Smile This will take some time to resolve.

There are oh so many things wrong, 600+ warnings but 90 percent of those are from building arm64 and the now enforced GCC_WARN_64_TO_32_BIT_CONVERSION.
I also had some problems with the code signing, and it turned out to be caused by me having multiple developer certificates. (one expired developer program certificate and one free)

When running the code signing command from Codesign.command manually, I got the following output:

$codesign -fvvv -s "iPhone Developer" -i org.xbmc.kodi-ios `find ${CODESIGNING_FOLDER_PATH} -name "*.dylib" -type f` ${CODESIGNING_FOLDER_PATH}
iPhone Developer: ambiguous (matches "iPhone Developer: [email protected] (SS3V2XXXXX)" and "iPhone Developer: [email protected] (JTZP2XXXXX)" in /Users/xxxx/Library/Keychains/login.keychain)

Solved this by deleting one of the certificates in the keychain, and then the signing worked fine and Kodi started fine on my non-jailbroken Ipad 4.

I've also (with my very limited git and xcode experience) managed to backport Memphiz IOS9 fixes + the mainline XCODE7 commits to the 15.2rc2-Isengard branch and I'm now running Isengard on my Ipad as well. (Probably just got lucky Wink)

The only issue is that I get the message "INFO: VideoToolBox decoder not available." in the log, but all videos are playing fine anyways. So maybe it's a false message?

EDIT: I'm of course not expecting support for this very unsupported configuration.

Great work Memphiz!
(2015-10-01, 14:04)MrMC Wrote: I poked into making an archive for deployment. Oh what a mess Smile This will take some time to resolve.

There are oh so many things wrong, 600+ warnings but 90 percent of those are from building arm64 and the now enforced GCC_WARN_64_TO_32_BIT_CONVERSION.

Thank you for looking at it and confirming it wasn't Anything I could do. Do you how long it would take to correct the archive problem? If anyone is working on it currently ?

Any chance of sharing patch against 15.2rc2-Isengard branch ?

Managed to get code from 16.0 running, but as everyone else have issue with adding sources.

@Memphiz successfully build Kodi for iOS 9 .. and both Jarvis 16.0 Alpha 4 & Isengard 15.2 RC 3 .. Thanks for the patches... Awesome work as usual..

Logout Mark Read Team Forum Stats Members Help
Warning Kodi is not running on iOS9 - This is for developers only!1
This forum uses Lukasz Tkacz MyBB addons.