Mediaportal TV service crash on backend when FF on android Kodi
#1
Twice in a few days (the last time after reinstalling Kodi) whilst recording a tv show I tried to watch the show delayed via Kodi on my androidbox and suddenly Kodi froze.
I looked on my server-pc and started mediaportal tv server configuration to search for the problem. I got a message "tv service not running, start it now?".

Also in windows logs I see an error. On Mediaportal forum I got this response about it (I uploaded the windows logs completely):
"Unfortunately the Windows log files don't seem to add any information. I mean, I can see that the TV service stopped unexpectedly.....
Usually I'd expect to see a stack trace in the application event log that gives the reason for what happened. However, I can't see anything there. So, I'm unable to determine what caused the problem. It's a mystery."

There's nothing to be seen in any Mediaportal logs.
On the Mediaportal forum I was instructed to post here.

You can download the Kodi logs from the second freeze (occurred at 20:53) and windows eventlog printscreen here:
http://we.tl/NLGKoxNmxf

Help appreciated,

Wim
Reply
#2
Well, from your kodi log file, I can only see a normal connect attempt to the TV Server backend:

Code:
20:56:25 T:1851239792   ERROR: AddOnLog: MediaPortal PVR Client: Socket::connect 192.168.2.1:9596
20:56:25 T:1851239792   ERROR: AddOnLog: MediaPortal PVR Client: Socket::connect: (errno=110) (null)
20:56:25 T:1851239792   ERROR: AddOnLog: MediaPortal PVR Client: Could not connect to MediaPortal TV Server backend

It just could not connect because the TV Server crashed 3 minutes earlier (if the frontend and backend times are in sync), so nothing special here.
Playback of an in-progress recording only involves read-only access to the recording .ts file, so there is no TV server interaction involved there.

I would also expect a stack trace in the TV server logs. The only other TV Server crashes without log info I have seen in the past were due to a crashed TV card driver (in ancient TV Server versions).

Conclusion is that I also have no idea.
Developer of the MediaPortal PVR addon and retired developer of the Argus-TV PVR-addon.
http://www.scintilla.utwente.nl/~marcelg/xbmc
Reply
#3
First of all thanks for the quick response!

I checked the times, the android box is about half a minute before the backend so that's within the 3 minutes timeframe, meaning the tv server crashed first. If I understand you correct, this would explain the Kodi freeze.

(2015-09-22, 19:28)margro Wrote: Playback of an in-progress recording only involves read-only access to the recording .ts file, so there is no TV server interaction involved there.
I don't completely understand this: Kodi crashed because it couldn't connect to the tv server, but there is no tv server interaction involved when playing back an in-progress recording?

Just to be complete, these are the mediaportal backend logs:
http://we.tl/etZZLK2xdI

In the mean time I tried diabling the add-on "advanced wake on lan" and prevented the backend from going to sleep (this last thing probably didn't make a difference) and now I can't reproduce the problem anymore!
I guess the add-on may have caused the problem. As a matter of fact, it wasn't working properly anyway (wasn't keeping the backend awake), so maybe there is something wrong with it.
I'll have to test some more and I will get back.
(do you happen to know of an alternative way to have Kodi keep the backend awake?)

Thanks,

Wim
Reply
#4
I have seen something similar on OpenELEC on raspberry pi using the 16 test builds. I reverted back to 15 and the crashes stopped.

I assumed that there was incompatibility between the updated plugin api on the OpenELEC test and the server plugin.

I had a few recordings fail as a result, which didn't make me popular at home, so my testing opportunities are limited.
Reply
#5
With the addon disabled, on the first test I got the problem again:

I recorded a show (Tijd voor MAX & Hallo Nederland) and started to watch it time-shifted. When I FF, Kodi froze and the tv server has crashed. This time I think it happened when the buffer had reached its end.

Mediaportal Logs
http://we.tl/5Vp0yVLGnX

Kodi Logs:
http://xbmclogs.com/pcyznysgp
http://xbmclogs.com/pfuht15yt

At what time do the logs give notice of the crashing of tvserver?

Wim

EDIT:
is this the entry?
18:20:58 T:1786806096 ERROR: AddOnLog: MediaPortal PVR Client: Socket:Confusedend - failed to send data
Windows log entry is from 18:20:51. That's about the same time.
Reply
#6
(2015-09-22, 21:19)cleo Wrote: In the mean time I tried diabling the add-on "advanced wake on lan" and prevented the backend from going to sleep (this last thing probably didn't make a difference) and now I can't reproduce the problem anymore!
I guess the add-on may have caused the problem. As a matter of fact, it wasn't working properly anyway (wasn't keeping the backend awake), so maybe there is something wrong with it.
I'll have to test some more and I will get back.

Well, here I am. I think I found what caused it. It wasn't the addon that I disabled that prevented the problem from happening in the above test, it's that I rebooted my androidbox before this test.

I found out that when I'm in Kodi, I put the androidbox to sleep, wake it again (it comes back with Kodi), playback a recording-in-progress and then FF, Kodi freezes AND Mediaportal TV Service on the backend crashes.
The problem doesn't happen when I quit Kodi before putting the box to sleep.

http://xbmclogs.com/prppri2du
http://xbmclogs.com/pyy3j2720

The crash happened about 9:45.


Wim
Reply



Logout Mark Read Team Forum Stats Members Help
Mediaportal TV service crash on backend when FF on android Kodi0
This forum uses Lukasz Tkacz MyBB addons.