• 1(current)
  • 2
  • 3
  • 4
  • 5
  • 8
  • Next 
 
Thread Rating:
  • 2 Vote(s) - 3 Average
Release - Black Glass Nova 5.x for Kodi 16.x Jarvis
#1
Black Glass Nova 5.x - Jarvis

Here is the home page of the skin on GitHub:

https://github.com/Tgxcorporation/skin.blackglassnova


If you like this skin and you want to help a little bit, you can donate here:

Image
Reply
#2
Hi TGX - it's been a while! Because everything you have done is running so well!!

I have been V5.0 running with no issues on two systems with Jarvis development builds- one on a Windows machine (from virtually the first 16 beta) and one on an OpenELEC, running on Odroid C1+
I could be mistaken, but I believe on the latter, I updated to BGN directly from the Kodi repo after fresh install of OpenELEC.

Now I just updated my Linux system to the new Jarvis RC1 release and it will not update BGN to v5.
It actually is running with the v4.5 - I tried switching to Confluence, then loading from zip from GitHub;(it will not update from the Kodi repo)
it fails for required dependency

Edit - never mind!
I tried updating my other Linux test vehicle to v116rc1 & when started it automatically updated to BGNv5.0
I went back to first machine & manually updated the Kodi Repo - as soon as I did that it updated the BGN
So somehow on that system the Kodi Repo did not get updated so not all the v16 changes were incorporated

Sorry for false alarm - it's all good now
Reply
#3
(2016-01-23, 19:20)DEcosse Wrote: It actually is running with the v4.5 - I tried switching to Confluence, then loading from zip from GitHub;

If you wish to test the current version on Github, you need these addons (and minimal version required) to be installed before the skin:

Code:
<import addon="script.grab.fanart" version="0.12.8"/>
<import addon="script.favourites" version="3.2.0"/>
<import addon="service.skin.widgets" version="0.0.27"/>
<import addon="script.skinshortcuts" version="0.2.4"/>
<import addon="script.skin.helper.service" version="0.0.11"/>
<import addon="resource.images.weatherfanart.single" version="0.0.4"/>
<import addon="resource.images.weathericons.transparent" version="0.0.4"/>

Tgx
Reply
#4
Sorry to inquire again!
I have a problem with the customization on ONE system only (running kodi 16RC1 on Linux)
I know it is neither an OS or Kodi or BGN functionality issue, as I have another Linux system running same, and using the same add-on sub-menu direct that works just fine!
And it also directed to same location on the previous revision without issue

I think somehow the BGN has become corrupted and no matter what I attempt, cannot seem to resolve this issue:
When I try to create a custom link to one particular add-on/sub-menu it will not direct to the correct spot
- I just get a single 'back' arrow in the field when it is launched;
I have tried this with a new main menu item and also as a new 'sub-menu' item under favourites;

e.g. add -> set label name -> set action -> then drill down through
add-ons
video add-ons
'selected add-on'
TV Shows
My Collection
Select link to here*

*under that, there is the list of all the shows listed in that library
If I point to one of these specific shows instead of the complete library, then it will successfully go there;
If I pick an alternative library from the same level as the 'my collection' e.g. folder called 'watchlist' it will successfully execute to there
if I pick the next level up it will also go to that level from the menu shortcut & I can select the 'my collection' from there also

It's as if that specific shortcut is being prohibited .........

This worked on this particular platform before the upgrade to 16 - however note my post above where I initially had issue in completing the upgrade;

I have tried re-installing Kodi and also re-installing BGN and also the specific add-on and also have 'restored' from my other Linux machine
no avail - for some reason that shortcut is simply not being administered

Where can I find the folder to delete (or the file where I can look for that specific link?)

Thanks for your help!

p.s. I also deleted the 'script-skinshortcuts' folder and indeed the home menus was reset to default
But again, it will not link to that specific library!

p.s #2 I rolled the Kodi back to 15.2; without changing anything else, the link now became active
I then upgraded back to 16rc1 and have same issue again - link does not complete to the designated library

EDIT - p.s. #3 - ended up just deleting Kodi completely and reinstalling - goes quite quickly if you have back-up to restore all add-ons etc
and now back to normal
perhaps just for interest you might be able to shiinesome light onwhat I could have done? (but ok if not!)
Reply
#5
I'm having a look at this issue soon.
It could be a skinshortcut bug specific of the Jarvis version or it could be some change in the skinshortcut addon that needs to be addressed in skin code.

Tgx
Reply
#6
I think the only difference, @Tgx, between my systems is that one had this link already established in 15.2 before the update (the one that didn't work) and the other was upgraded and THEN the link was added.
By deleting the Kodi completely in the problem system I effectively re-emulated a non-upgrade type of install similar to the one that worked to begin with.
What was bizarre however was that deleting the script-shortcuts folder did not eliminate the issue
We must also note that the initial upgrade of the v16 clearly had some other issue (whether related I can't say) - as it would not initially go to v5.0 on the BGN (as per my earlier post)
I maybe created a unique set of circumstances that prompted this issue - whether anyone else would see it is questionable.
Reply
#7
I've made some tests and on my system (Mac Jarvis rc1) everything is ok.
I think your issue is something related to the skinshortcuts addon and the partial incompatibility of its settings from the Isengard to the Jarvis version.
Sorry, but in this case i cannot do anything.
You'd better ask in the skinshortcut addon support thread.

Tgx
Reply
#8
So another problem with the custom menu:
This has appeared on three separate systems - presumably after an update as all had been working correctly:

As described in post #4 I have shortcut to a custom list of linked shows - the problem as reported in post #4 was eliminated after I re-installed.
i.e. the custom shortcut menu was working perfectly
Now - when I open that shortcut, I still see all my shows populated in that library (I use the Panel View and all the artwork is perfectly displayed for each show);
but when I try to open one of those links, it gives me an error. (NONE of the links will open)
However - if I go directly to the add-on and open that (same) custom library from there, (instead of the main menu shortcut) the listed shows execute flawlessly.
so - if I open that library from my main menu - favourites - sub-menu - custom library shortcut link vs add-on - custom library, the two lists look identical, with exactly the same content displayed;
the difference is that those links in that library work when accessed directly from the add-on, but do not when via the custom home page link.

This was same machine I had the problem indicated in post #4; however I then went to another machine (openelec, also running BGN Skin with same custom menu config) and a third machine (Windows) and all now have exact same problem
Again - these machines had these shortcuts working properly until recently.
Reply
#9
I've just tried myself and now the home menu editor does not work with Black Glass Nova.
Something has changed in the skin shortcuts addon.
I'm working on it.

Thanks

Tgx
Reply
#10
OK, thanks again for your ongoing support.
Reply
#11
You make any inroads on this one TGX?
It's not a show-stopper was totally spoiled by that one-click shortcut when it was working Big Grin
Reply
#12
I'm close to an official release. You can always upgrade to developing version on Github.

Tgx
Reply
#13
I tried that & it still does not work
Some more information however:
It appears to only 'not work' for one particular shortcut from one add-on;
The 'special' thing about that list, is it is actually sourced from a 'remote' location
i.e. if I add a show to that list, it will appear in my 'collection' for that add-on on ALL my systems, without having to add it independently.
(It's using trakt.tv to maintain that list)

Now - when I open that shortcut from the created shortcut from the custom home menu, I can now see that the 'list' displayed, is actually an older version, that does not contain the latest additions
(and as before, when I try to open one of the shows from that list, it errors)
But if I go to that same list, directly from the add-on itself, I DO see the latest additions and the links work directly.
i.e. the home menu shortcut appears to be pointing to an 'outdated' list, rather than the current one??
One more thing I notice is that when I create the shortcut and scroll through the levels to get to that collection, the collection 'list' (from where I select 'create shortcut to here) actually shows the full populated list; however again, when I launch it from the home shortcut, the 'old' (incomplete) list is displayed.
Everything looks fine as I am creating the shortcut, but it does not seem to 'apply' it correctly.

I'll be honest and say this is a non-supported Add-on (so I don't want to be specific), which uses trakt.tv to maintain the list, and understand if you don't pursue this further
However something has undoubtedly changed, as this shortcut previously worked perfectly, but now is broken.

One question - where is this data stored?
I am trying to delete all previous BGN to start again - but when I think I have deleted all and re-install BGN from zip (from the Github repo) then when the home page comes up, my custom links are still there
So what directory/file contains those so I can delete?
Reply
#14
It happened me once with the plexbmc addon. I can definitely say that this depends on the addon itself.
In fact, it does not happen anymore since i've started using an updated version of the addon.

However, if you want to reset your home layout to defaults and know where data is stored:

https://github.com/Tgxcorporation/skin.b...-home-menu

Tgx
Reply
#15
So I deleted the script.skinshortcuts folder and indeed the home menu was reset;
I then re-created my shortcut link and it produced the exact same (older revision) of my list when the shortcut was launched
i.e. it has only 19 items in there, vs 28 when I launch that collection directly from the add-on.
I know it cannot be going to the remote host since the list that launches appears to be something it has stored locally (from something created before the subsequent items were added);
further if I compare that abbreviated list (that the shortcut launches) with another machine, it is quite different from the one created in the shortcut there
i.e. different machines have a different sub-set of the master list in the 'shortcut' version of the list, so I would have to believe these are stored locally and specific to that local machine.
(whereas the list launched directly from the add-on is complete in both instances and if I add another item on one machine, it will then be included in another machine)
So the question that holds the clue is, where is that abbreviated list possibly coming from? I'm sure it has to be local ......
I think there is a good possibility that this only changed during one of the Kodi 16 beta updates (although I know originally it was working fine with early 16 betas)
Reply
  • 1(current)
  • 2
  • 3
  • 4
  • 5
  • 8
  • Next 



Black Glass Nova 5.x for Kodi 16.x Jarvis32