Bug TVServerKodi causes a crash for TVservice
#13
I seem to still be experiencing this problem, i have been trying to figure it out for a couple weeks now. MP can play channels but I could not get my kodi clients to play anything. I am also experiencing an issue with having to restart the TV Service over and over. That is what led me here.

My set up is MP running on a Win10 computer that is serving several RaspberryPI clients running OSMC/Kodi. MP on the Win10 server work perfectly fine. I can tune to and watch channels. Everything seems to be set up correctly. Reviewing the TVService log pasted below, shows that the TVSerivce keep shutting down.

http://pastebin.com/At0h9fFJ - TVService Log

Then on the client side this same error keeps repeating

17:41:53 T:6796 ERROR: AddOnLog: MediaPortal PVR Client: MPTV::Socket::ReadLine: (Winsock error=10054) Connection reset by peer
17:41:53 T:6796 ERROR: AddOnLog: MediaPortal PVR Client: SendCommand - Failed.
17:41:53 T:6796 ERROR: AddOnLog: MediaPortal PVR Client: SendCommand2: reconnect failed.
17:41:54 T:6796 ERROR: AddOnLog: MediaPortal PVR Client: Socket::connect 192.168.1.5:9596
17:41:54 T:6796 ERROR: AddOnLog: MediaPortal PVR Client: Socket::connect: (Winsock error=10061) Connection refused
17:41:54 T:6796 ERROR: AddOnLog: MediaPortal PVR Client: Could not connect to MediaPortal TV Server backend
17:41:54 T:6796 ERROR: AddOnLog: MediaPortal PVR Client: Socket:Confusedend: (Winsock error=10057) WSA Error
17:41:54 T:6796 ERROR: AddOnLog: MediaPortal PVR Client: Socket:Confusedend - failed to send data
17:41:55 T:6796 ERROR: AddOnLog: MediaPortal PVR Client: Socket::connect 192.168.1.5:9596
17:41:55 T:6796 ERROR: AddOnLog: MediaPortal PVR Client: Socket::connect: (Winsock error=10061) Connection refused
17:41:55 T:6796 ERROR: AddOnLog: MediaPortal PVR Client: Could not connect to MediaPortal TV Server backend
17:41:55 T:6796 ERROR: AddOnLog: MediaPortal PVR Client: SendCommand2: reconnect failed.
17:41:55 T:6796 ERROR: AddOnLog: MediaPortal PVR Client: Socket:Confusedend: (Winsock error=10057) WSA Error
17:41:55 T:6796 ERROR: AddOnLog: MediaPortal PVR Client: Socket:Confusedend - failed to send data


When I try to play Live TV i get this in the client log:
17:12:08 T:6192 NOTICE: DVDPlayer: Opening: pvr://channels/tv/All channels/pvr.mediaportal.tvserver_182.pvr
17:12:08 T:6192 WARNING: CDVDMessageQueue(player):Tongueut MSGQ_NOT_INITIALIZED
17:12:08 T:4580 NOTICE: Thread DVDPlayer start, auto delete: false
17:12:08 T:4580 NOTICE: Creating InputStream
17:12:08 T:4580 NOTICE: AddOnLog: MediaPortal PVR Client: Open Live stream for channel uid=182
17:12:50 T:4580 ERROR: AddOnLog: MediaPortal PVR Client: SendCommand - Failed.
17:12:50 T:4580 ERROR: AddOnLog: MediaPortal PVR Client: Could not start the timeshift for channel uid=182. Reason:
17:12:50 T:4580 ERROR: AddOnLog: MediaPortal PVR Client: GetLiveStreamURL for uid=182 returned no URL
17:12:50 T:4580 ERROR: CDVDInputStreamPVRManager::Open - error opening []


Here is the complete client log

http://pastebin.com/gUfs9GgZ

Any help would be greatly appreciated. Thank you
Reply


Messages In This Thread
RE: TVServerKodi causes a crash for TVservice - by Aslan2120 - 2015-12-13, 04:11


Logout Mark Read Team Forum Stats Members Help
TVServerKodi causes a crash for TVservice0
This forum uses Lukasz Tkacz MyBB addons.