Playback of recordings fails
#1
Hello

When i try and watch a recorded programme the picture freezes for about 10secs and then it stops and goes back to the TV recordings menu. It started happening a couple of weeks ago.
This happens using Windows, OSX and Kodibuntu.
I'm using -
Kodi 15.2
HTS Tvheadend 4.1-971~g5192186
PVR addon - 2.1.18
Please see link for log (Windows Kodi) - http://we.tl/CaGbgKR8AP
Thank you

Baisey
Reply
#2
Your tvh backend is only two days old, so did you have this problem previously and tried to upgrade to see if it fixed things?

There were some changes to the HTSP API on November 5th... depending on how you upgrade, that *might* be relevant (I don't know that, so I may be leading you in completely the wrong direction...).

I'd test by seeing if the recorded programmes play correctly over a share/source/mapped drive - just to see that they're okay. If you build your own tvheadend, you could try either try updating to the very latest (when the API spec has been bumped up, so maybe you'd get an error) or try reverting to 374ab83 or earlier to see if the problem goes away.

Another thought... looking at your log, you have some errors around halfway that look like Kodi simply isn't getting the data from the backend quickly enough. What's tvh running on, how's it connected to your clients? Anything changed there at all? Anything happening on that back end (e.g. disc or network access) that could be causing a bottleneck?

All a bit of guesswork, though...
Reply
#3
Hello. Thanks for the reply.
Its been happening for a couple of weeks maybe a month. l update TVH every few days so its been updated a lot of times since it started.
I update by using synaptic and whatever version is on the bintray server, same goes for the pvr addon. I didn't build anything myself.
I've played the recordings (vlc) over a share and there's no problem at all.
The log was made on a wifi connected laptop. I know there can be issues connecting like that and playback does stutter every now and again. The problem also occurs on the server (kodibuntu) using local host client, a windows machine connected via gigabit ethernet and 2 laptops (win and osx).
It happens on the server when im watching a SD recording and nothing else is connected or being recorded.
Ill take a look at the API change. Im sure I saw it mentioned on the activity bit of TVH website earlier.
Thank you
Reply
#4
Grab a debug log from the tvheadend side at the same time - web interface, bottom right, arrows, cog - see if the server is seeing anything odd when it happens. Replicating it on the same system eliminates a lot, so maybe a new debug log from Kodi at the same time as the tvh log is the way to go...
Reply
#5
I also have issues with recordings and also I update tvheadend often. Version 955 of tvheadend worked for me but the last one's not. TVHeadend bug #3296 is about this behavior, bit it is hard to reproduce with good traces. tvheadend --trace dvr shows minor information.
Reply



Logout Mark Read Team Forum Stats Members Help
Playback of recordings fails0
This forum uses Lukasz Tkacz MyBB addons.