Unable to install Mediaportal PVR addon on OpenElec 6.0
#1
I just set up a new Kodi (15.2) box based on OpenElec 6.0. All is well except that I can't get the Mediaportal PVR addon to install.

Firstly, if I go to the Kodi add-on repository there is no PVR section showing, but I can search and find the add-on.

However when I install it, nothing happens. No errors on screen, but this appears in the log

Code:
Failed to open source https://raw.github.com/codesnake/openelec-addons/6.0/amlogic/arm/addons.xml

Has anyone managed to get this working?
Reply
#2
They are in the openelec repo, not the kodi repo.
If I have helped you or increased your knowledge, click the 'thumbs up' button to give thanks :) (People with less than 20 posts won't see the "thumbs up" button.)
Reply
#3
(2015-12-04, 22:23)ctrlz Wrote: Has anyone managed to get this working?

Not very helpful, but yes, I have this working on two OpenElec boxes (RPi2 and PC).
Reply
#4
I think the problem is the OpenElec repo is not properly installed on this box. When I select it nothing happens, and in the logs I see "Error getting addons://repository.openelec.tv"

So how do I reinstall the OpenElec repo?
Reply
#5
Its built in to openelec.
If I have helped you or increased your knowledge, click the 'thumbs up' button to give thanks :) (People with less than 20 posts won't see the "thumbs up" button.)
Reply
#6
Yes but like I say, in my case it does not work, so I need to find a workaround.
Reply
#7
What hardware and exact openelec version?
If I have helped you or increased your knowledge, click the 'thumbs up' button to give thanks :) (People with less than 20 posts won't see the "thumbs up" button.)
Reply
#8
Also, do you see oenelec mediacentre os add-ons when you go into 'install from repository'?
If I have helped you or increased your knowledge, click the 'thumbs up' button to give thanks :) (People with less than 20 posts won't see the "thumbs up" button.)
Reply
#9
It's a Venz V3 box. Cpuinfo is:

ARMv7 Processor rev 1 (v7l)
Amlogic Meson8B

Full release info is:

NAME="TLBB-OE"
VERSION="devel-20151024015058-r21849-g5f39fed"
ID="openelec"
VERSION_ID="6.0"
PRETTY_NAME="TLBB-OE (unofficial) - Version: devel-20151024015058-r21849-g5f39fed"
HOME_URL="http://www.openelec.tv"
BUG_REPORT_URL="https://github.com/OpenELEC/OpenELEC.tv"
BUILD_ID="5f39fed3c9a1ac5e77eeb1901c5cd0f31272098b"
OPENELEC_ARCH="TLBB.arm"
OPENELEC_BUILD="unofficial"

I do see "OpenElec MediaCenter OS Add-Ons" as an option when I go into "Install from repository" but unfortunately when I select it, nothing happens. If I then go in the logs, that's when I see the "Error getting addons://repository.openelec.tv" message.

If I go to "All Repositories" and search for the MediaPortal PVR add-on, it is found. But again if I select it, nothing happens. If I then look at the logs again, I see the message "Failed to open source https://raw.github.com/codesnake/openele...addons.xml".

I connected to the box via SSH and looked at the addon.xml file in the /usr/share/kodi/addons/repository.openelec.tv folder and it points to the github location I just mentioned, which doesn't seem to be a valid location...
Reply
#10
Is that an official OpenELEC build? If not, their repo probably won't have a compiled addon for you.
If I have helped you or increased your knowledge, click the 'thumbs up' button to give thanks :) (People with less than 20 posts won't see the "thumbs up" button.)
Reply
#11
I don't know to be honest but it does say "unoffical" in the info above so maybe that confirms it and could be my issue.

That's frustrating, I will have to get in touch with the manufacturer of the box, unless for the time being I can find a zip download of the Mediaportal PVR addon.
Reply
#12
Well it has to be compiled for your architecture. The RPI or wetek ones may work.
If I have helped you or increased your knowledge, click the 'thumbs up' button to give thanks :) (People with less than 20 posts won't see the "thumbs up" button.)
Reply
#13
In the end I got in touch with the manufacturer of the box and they were able to supply an OpenElec update that fixed the repo. All working fine now!
Reply



Logout Mark Read Team Forum Stats Members Help
Unable to install Mediaportal PVR addon on OpenElec 6.00
This forum uses Lukasz Tkacz MyBB addons.