•   
  • 1
  • 117
  • 118
  • 119(current)
  • 120
  • 121
  • 146
  •   
OpenELEC Testbuilds for RaspberryPi (Kodi 17.0)
The solution that worked for me:

1) Revert to 322
2) Disable all PVR addons
3) Upgrade to 324
4) Happiness will return to your life
(2016-03-25, 18:13)Hoopla Wrote: The solution that worked for me:

1) Revert to 322
2) Disable all PVR addons
3) Upgrade to 324
4) Happiness will return to your life

If you have a recent Addons21.db then deleting Addons22.db before attempting the above should work.

If however you don't have a recent Addons21.db I'd suggest the following slightly more involved solution:
1) Revert to #0219 (after this build, creating a new Addons2*.db takes a very long time)
2) Build #0219 will create Addons21.db with all "system" (PVR etc.) addons disabled, while enabling your own third-party addons
3) Upgrade to #0324+, which will upgrade Addons21.db to Addons22.db
4) Enable the "Input Stream" add-on if you want to use Amazon Prime etc. - you'll need to reboot one more time for inputstream.mpd to function correctly

There's an alternative fix to the startup delay in the next build (#0325) but I think it may still require either of the above solutions to get back to a fully working system.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
New OpenELEC.tv Krypton build #0325: RPi / RPi2
(Supercedes previous build)

Code:
# uname -a
Linux rpi512 4.4.6 #1 Fri Mar 25 21:42:15 GMT 2016 armv6l GNU/Linux

# vcgencmd version
Mar 24 2016 12:49:34
Copyright (c) 2012 Broadcom
version e16cd015026a8bda22bb50dc30b30ce07f52a202 (clean) (release)

# lsb_release
OpenELEC (Milhouse) - Version: devel-20160325214122-#0325-g0026734 [Build #0325]

# vcdbg log msg 2>&1 | grep DTOK
002490.353: Kernel trailer DTOK property says yes

# Kernel device tree status: Enabled

Based on tip of OpenELEC.tv master (0026734b, changelog) and tip of XBMC master (00a92f8d, changelog) with the following modifications:
  • Includes newclock5 patches
  • Excludes the OpenELEC linux-01-RPi_support patch in favour of sourcing these and possibly more recent patches directly from kernel branch rpi-4.4.y
  • Default setting for "Show RSS Feed" changed to disabled (new installs only) [patch details]
  • Disabled "Total Duration" in Confluence (see build #0221 for details)
  • Includes latest bcm2835-driver master (046effa1, ahead +10)
  • Includes latest dcadec master (0e074384, ahead +139)
  • Includes latest kodi-platform master (92583ef9, ahead +2)
  • Includes latest libcec master (6d68d212)
  • Includes latest libnfs master (3c26ce1e, ahead +13)
  • Includes latest p8-platform master (041a8c6c, ahead +1)
  • Includes latest addons: inputstream.mpd (2ebae493), peripheral.joystick (76b7c40a, +48), pvr.argustv (c05bf4ff, +23), pvr.demo (32ef5073, +19), pvr.dvblink (cc11bedb, +18), pvr.dvbviewer (48b0089e, +20), pvr.filmon (188ef9ab, +25), pvr.hdhomerun (4f3a3949, +30), pvr.hts (303920d8, +62), pvr.iptvsimple (d4fcb214, +25), pvr.mediaportal.tvserver (5815d770, +50), pvr.mythtv (ada1427b, +34), pvr.nextpvr (d41be111, +25), pvr.njoy (af1d68ea, +17), pvr.pctv (f60f00a9, +23), pvr.stalker (27630dde, +26), pvr.vbox (329fd13d, +25), pvr.vdr.vnsi (162dcdd6, +34), pvr.vuplus (135f1b03, +21), pvr.wmc (f0c62cfc, +30)
  • Includes commits from xbmc/fix_system_addon_enabling_alt, ahead +2 (tamland)
  • Includes commits from service.openelec.settings/, ahead +1 (OpenELEC)
  • Include [env] e7cbe9cb: xf86-video-intel: explicitely disable TearFree and TripleBuffer
  • Include [env] ed774729: Intel: Implement Passthrough-Range
  • Include [env] 3a6268c9: VAAPI: Enable EGL
  • Include [env] 98c65e6a: Kodi: Use Limited Range by default
  • Include [env] compare: ffmpeg: Additional Jarvis 2.8.x patches
  • Include [env] patch: Clean Kodi view cache on startup
  • Include [env] patch: Fix system keyboard patch
  • Include [env] patch: Add extra headers needed by 3D BD MVC
  • Include [env] patch: Add support for dynamic device tree overlays
  • Include [env] patch: Set default volume steps to 20
  • Include [env] patch: Enable game controllers in manifest, add repository.kodi.game
  • Include [env] patch: Bump libbluray - include MVC support
  • Include [env] patch: Enable other binary addons
  • Include [env] patch: Reinstate version check service add-on - avoid black screens on x86?
  • Include [env] patch: Update inputstream.mpd settings
  • Include [env] patch: Install dtoverlay userland
  • Include [env] patch: Enable pvr addons, disable pvr updates
  • Include [env] patch: Add experimental splash video for RPi
  • Include [env] patch: Binary-Addons: Package inputstream.mpd
  • Include [env] patch: kodi: peripheral.joystick binary addon
  • Include [env] PR:4500: kodi: update to 17.0
  • Include [env] PR:4537: [scripts] Add PKG_SOURCE_NAME for non-standard package tarballs
  • Include [env] PR:4661: stripping changes
  • Revert [env] 46b9b7b3: rtmpdump (Reason: use newclock5 bump)
  • Include [pkg] PR:8645: [video] Add season/TV show artwork to episodes/seasons even if they have their own fanart.
  • Include [pkg] PR:8824: videodb: fix smart playlists not honoring "Show empty TV shows" setting.
  • Include [pkg] PR:8922: [guiinfo] extend ranges for listitem properties
  • Include [pkg] PR:9334: [chg] decrease volume steps to 20
Build Highlights:
  1. NOTE: DVD playback remains temporarily disabled
  2. No more tvheadend addon updates for now - they've just bumped to ffmpeg 3.0 and there isn't a simple fix. Stick with the last tvheadend build for now (#0324).
  3. Alternative method to disable system addons
Build Details:
  1. XBMC:
    • [addons] add first usable doxygen documentation (PR:9433, 1 commit, 9 files changed)
    • [addons] add missing addon related headers to cmake install (PR:9448, 1 commit, 1 file changed)
    • [EGLIMX] remove the two 'helper' hacks. (PR:9447, 1 commit, 1 file changed)
  2. pvr.mythtv:
    • 4.3.1 (PR:62, 4 commits, 12 files changed)
  3. pvr.stalker:
    • Fixes (PR:52, 4 commits, 6 files changed)
  4. xbmc/fix_system_addon_enabling_alt (tamland):
    • New commits in this build:
      • CAddonDatabase: remove unused method (ec79f5d5)
      • [addons] dont call normal enable hooks when checking system addons (0edad307)
  5. newclock5:
    • New commits in this build:
      • Revert "[mmalrenderer] Wait for vsync before submitting to mmal when display sync is disabled" (1da7fcfa)
      • Wait for vsync before submitting to mmal when display sync is disabled (21d8af18)
    • Commits no longer in build:
      • mmal_render: Add debug to show time since last vsync (de554772)
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
#0325 won't load for me (rPi 1 B) - just getting an endless loop of the Kodi intro video. I've rolled back to #0324, which is loading perfectly.

Kodi crashlog, and let me know if there's any other interesting info I can get (and how to get it!), though the two fatal lines at the end of the log sound pretty definitive!

Cheers.

Edit:- Just re-installed it to get a proper debug log as I realised that debug logging wasn't actually enabled for that crashlog, and it now works fine. I don't have the time to keep up to date on every change in these builds, so I presume there was something necessary in the builds since the last one I had installed (#0320) in order for #0325 to work correctly. Or it's one of those things commonly known as a 'bugger'. Sorry for the confusion.
@BobCratchett: It was a required system add-on (kodi.inputstream), that wasn't automatically enabled when you booted #0325, so Kodi promptly fell over. Add-on crazyness. Sad
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Build #0325

Pvr 'clear data' from live tv guide and general settings not working
Build #325 installed over the previous build fine no issues noted.

Browsing photos over a network share and I find that it will either freeze Kodi or reboot it.It doesn't have to be the same folder or attempting to open a file which will cause it.

I enabled debugging and captured this....

https://www.dropbox.com/s/q839eo1nylrxj4...0.zip?dl=0

....at the time I tried to open a folder with jpg files in it which are not corrupted and view fine. Kodi just rebooted.

As a note any idea why the key command "W" will no longer toggle the watched status of TV shows or Movies.....?
Anyone using mysql with the latest nightlies? It is not working for me with any of the Krypton nightlies. I have initially reported this in the Windows section (see #44 of http://forum.kodi.tv/showthread.php?tid=262999&page=3 for clear logs of what is happening). Just tried with RPi2, but facing the same issue. Have rolled back to Jarvis and all working well. Also when running sqlite, Krypton works.

Any thoughts how to get Krypton nightlies to work with mysql?
Server: Asus Sabertooth Z77 | Intel Core i5 3.4 GHz | 16 GB DDR3 | 128 GB SSD, 82 TB (9 x 6 TB, 7 x 4 TB)
HTPC 1: Raspberry Pi 2 | HTPC 2: Raspberry Pi 2 | HTPC 3: Raspberry Pi
(2016-03-26, 14:33)steve1977 Wrote: Any thoughts how to get Krypton nightlies to work with mysql?

I use mysql and so does Milhouse. No problems here.
(2016-03-26, 14:33)steve1977 Wrote: Anyone using mysql with the latest nightlies? It is not working for me with any of the Krypton nightlies. I have initially reported this in the Windows section (see #44 of http://forum.kodi.tv/showthread.php?tid=262999&page=3 for clear logs of what is happening). Just tried with RPi2, but facing the same issue. Have rolled back to Jarvis and all working well. Also when running sqlite, Krypton works.

Any thoughts how to get Krypton nightlies to work with mysql?

Yes and I've seen no issues so far... I have three PIs (2 RPI2 / 1 RPI3) and a x86 all using nightlies with no issue with an mysql backend.

I looked at your other thread, why are you doing the following settings if you are using a mysql backend?

<importwatchedstate>false</importwatchedstate> <!-- import previously exported playdate and playcount from .nfo files. Defaults to false -->
<importresumepoint>false</importresumepoint> <!-- import previously exported resume point from .nfo files. Defaults to false -->

I would recommend removing those options.
HTPC(s): All running LibreELEC
  • AMD 2200G APU on Gigabyte AB350N-Gaming WIFI-CF
  • RPI3 x2 | RPI2 x2
NAS: FreeNAS (Latest Stable) | NFS/CIFS
Thanks for your replies. Do you think it could be related to the importwatchstates? I have them included as I often rebuild the library and pull from the NFO files. But I can remove to try whether this is causing the issue. Any other idea what could drive my mysql issues. It is very weird as the issue is replicable. Downgrading to jarvis immediatelt solves the issue and when upgrading it is broken again.
Server: Asus Sabertooth Z77 | Intel Core i5 3.4 GHz | 16 GB DDR3 | 128 GB SSD, 82 TB (9 x 6 TB, 7 x 4 TB)
HTPC 1: Raspberry Pi 2 | HTPC 2: Raspberry Pi 2 | HTPC 3: Raspberry Pi
Removed the importwatchedstate and importresumepoint from advancedsettings and upgraded. Still not working. Downgraded to Jarvis and working again. Any more ideas?
Server: Asus Sabertooth Z77 | Intel Core i5 3.4 GHz | 16 GB DDR3 | 128 GB SSD, 82 TB (9 x 6 TB, 7 x 4 TB)
HTPC 1: Raspberry Pi 2 | HTPC 2: Raspberry Pi 2 | HTPC 3: Raspberry Pi
(2016-03-26, 15:03)steve1977 Wrote: Thanks for your replies. Do you think it could be related to the importwatchstates? I have them included as I often rebuild the library and pull from the NFO files. But I can remove to try whether this is causing the issue. Any other idea what could drive my mysql issues. It is very weird as the issue is replicable. Downgrading to jarvis immediatelt solves the issue and when upgrading it is broken again.

Your watched status is stored in the database. That is the benefit of having a mysql backend so you can have watch status stored across the board regardless of device and also you can stop watching in one room and pickup where you left off in another room.

If you are using a backend the NFOs should really not be needed since the metadata scrapers will pull this data unless you have odd sources and have to create your own NFOs or something else for those sources.
HTPC(s): All running LibreELEC
  • AMD 2200G APU on Gigabyte AB350N-Gaming WIFI-CF
  • RPI3 x2 | RPI2 x2
NAS: FreeNAS (Latest Stable) | NFS/CIFS
For those using mysql, are the latest versions of that and mariadb working? At least on the wiki for windows it says (Grab version 5.5.42, there are issues with newer versions)
Hi,
I think the start up sequence takes much longer since Build #0323, 23-Mar-2016. I use a RPi3 with this build. Has anyone else have this issue since the mentioned build?
  •   
  • 1
  • 117
  • 118
  • 119(current)
  • 120
  • 121
  • 146
  •   



Logout Mark Read Team Forum Stats Members Help
OpenELEC Testbuilds for RaspberryPi (Kodi 17.0)6
This forum uses Lukasz Tkacz MyBB addons.