•   
  • 1
  • 94
  • 95
  • 96(current)
  • 97
  • 98
  • 146
  •   
OpenELEC Testbuilds for RaspberryPi (Kodi 17.0)
(2016-03-05, 13:36)amediauser Wrote: Has anyone else noticed this bug with the user interface, playing 3D framepacked movies.

It might be a bug with the new skin or it highlights the problem.

The first time after a reboot I get screenshot 1 with the user interface rendered at half resolution as expected.

If I then play the same file again, I get screenshot 2 and the icon resolution has been halved again.

I've seen the same behaviour playing 3d blu-ray iso files.
Still no passthrough with latest build using mmal.
Log:
CDVDFactoryInputStream::CreateInputStream - <f1> nfs://192.168.0.250/Storage/Filme/Home Box/Black.Mass.2015.1080p.BluRay.DTS.x264-DON/Black.Mass.2015.1080p.BluRay.DTS.x264-DON.srt <ssif>
19:30:16 1622.257324 T:1647047584 NOTICE: CDVDMessageQueue::GetLevel() - can't determine level
19:30:16 1622.261353 T:1311765408 NOTICE: Previous line repeats 11 times.
19:30:16 1622.261719 T:1311765408 NOTICE: Creating audio stream (codec id: 86020, channels: 6, sample rate: 48000, no pass-through)
(2016-03-05, 19:38)aurelmarius Wrote: Still no passthrough with latest build using mmal.

"Sync playback to display" disables passthrough unless you enable "PLL adjustment to maintain audio/video sync"
(2016-03-05, 18:28)Trixster Wrote: Running an rpi3 with #0304, anyone else unable to get the inbuilt wlan0 to show up in openelec config network?

Has it ever worked for you with previous builds (since #0229)?

From what you've said, do I assume correctly that you see "Wireless Networks" listed as a category in OE Settings > Network, and have activated the wireless network, but you don't see wlan0 listed in OE Settings > Connections?

Immediately after booting*, run the following commands - you'll need a wired network connection - and post the links:

Code:
vcdbg log msg 2>&1 | paste
dmesg | pastebinit | paste
ifconfig | paste
ls -la /flash | paste

* vcdbg is currently logging a lot of information so if you delay running "vcdbg log msg" the log will rotate and lose any relevant information
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
using build 304 with the new estuary skin and I'm still getting the tv epg grid causing the infinite loop (pi2)
(2016-03-05, 23:20)stevegal Wrote: using build 304 with the new estuary skin and I'm still getting the tv epg grid causing the infinite loop (pi2)

Still? Bummer.

Can you run the following command in ssh while it's in the infinite loop:
Code:
kill -SIGSEGV $(pidof kodi.bin)
then upload the crashlog file once Kodi has restarted - it may provide something useful.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2016-03-05, 12:58)rewsteruk Wrote: In #0303 the openELEC addon has been added to the main menu, but in the appearance settings of the Estuary skin (which is great by the way) there is no switch to disable as a menu item, please could one be added.

It wasn't possible to disable it in earlier Confluence based builds, either. The current placement may (or may not) be temporary until a more permanent solution is found.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
I'm having no issue with the EPG using tvheadend server, tried with cache enabled and disabled with neither causing any problems.

Must be a backend problem.
EPG is working in 0304 with a mythtv backend as well
(2016-03-05, 19:47)popcornmix Wrote:
(2016-03-05, 19:38)aurelmarius Wrote: Still no passthrough with latest build using mmal.

"Sync playback to display" disables passthrough unless you enable "PLL adjustment to maintain audio/video sync"
Thanks a lot. That was the problem.
Thumbs Up 
(2016-03-05, 00:26)Milhouse Wrote:
(2016-03-04, 23:46)unix72 Wrote: Hallo, I had Problem with Build 03032016. Android App Yatze (Kodi Remote). I can not use yatze as remote control. Last time (Build 02282016) Yatze works just fine.
yatze could connet to Kodi (Webserver) but no remote function.
is that problem from yatze or from kodi?
with webbrowser there's no problem with remote function
Sorry or my bad english

Yatse 6.0.1 is working normally for me with #0303. Please check that your Kodi Web Server is configured with the same port that Yatse is using. It has a habit of switching back to the old default port 80 from the new default port 8080 when changing between different OpenELEC versions.

Milhouse thanks for the Hint.
It works back normal again :-)
New OpenELEC Krypton build #0305: RPi / RPi2
(Supercedes previous build)

Code:
# uname -a
Linux rpi512 4.4.4 #1 Sat Mar 5 21:04:58 GMT 2016 armv6l GNU/Linux

# vcgencmd version
Mar  4 2016 17:58:52
Copyright (c) 2012 Broadcom
version 764f403f69e25e8a014c24f8a26f057960331205 (clean) (release)

# lsb_release
OpenELEC (Milhouse) - Version: devel-20160305210406-#0305-g19a26da [Build #0305]

# vcdbg log msg 2>&1 | grep DTOK
002482.820: Kernel trailer DTOK property says yes

# Kernel device tree status: Enabled

Based on tip of OpenELEC master (19a26daa, changelog) and tip of XBMC master (3698addd, changelog) with the following modifications:
  • Includes newclock5 patches
  • Excludes the OpenELEC linux-01-RPi_support patch in favour of sourcing these and possibly more recent patches directly from kernel branch rpi-4.4.y
  • Default setting for "Show RSS Feed" changed to disabled (new installs only) [patch details]
  • Disabled "Total Duration" in Confluence (see build #0221 for details)
  • Includes latest bcm2835-driver master (b48c36f7)
  • Includes latest dcadec master (0e074384, ahead +139)
  • Includes latest kodi-platform master (92583ef9, ahead +2)
  • Includes latest libcec master (6d68d212)
  • Includes latest libnfs master (eebe56ce, ahead +10)
  • Includes latest p8-platform master (38343e0a)
  • Includes latest addons: pvr.argustv (501f56b3, +21), pvr.demo (116a172a, +16), pvr.filmon (4beb05da, +23), pvr.hdhomerun (3f0dd8e6, +29), pvr.hts (0814da42, +55), pvr.iptvsimple (1dfc3547, +24), pvr.mediaportal.tvserver (4860e622, +48), pvr.mythtv (44df4430, +25), pvr.nextpvr (1871323c, +23), pvr.njoy (4f30f4af, +16), pvr.pctv (522f9603, +21), pvr.stalker (0402f465, +20), pvr.vbox (b0916449, +23), pvr.vdr.vnsi (2089549a, +21), pvr.vuplus (4cf6ad02, +19), pvr.wmc (9a83292f, +22)
  • Includes commits from service.openelec.settings/, ahead +1 (OpenELEC)
  • Include [env] e7cbe9cb: xf86-video-intel: explicitely disable TearFree and TripleBuffer
  • Include [env] ed774729: Intel: Implement Passthrough-Range
  • Include [env] 2f83a1cf: xf86-video-intel: bump to 8b8c9a36 (fixes segfault when refreshrate changing)
  • Include [env] 3a6268c9: VAAPI: Enable EGL
  • Include [env] 6f87cdbb: xf86-video-intel: bump to d167280
  • Include [env] 98c65e6a: Kodi: Use Limited Range by default
  • Include [env] 858f6461: xf86-video-intel: bump to 371219c
  • Include [env] compare: ffmpeg: Additional Jarvis 2.8.x patches
  • Include [env] patch: Enable other binary addons
  • Include [env] patch: Reinstate version check service add-on - avoid black screens on x86?
  • Include [env] patch: Add extra headers needed by 3D BD MVC
  • Include [env] patch: Bump libbluray - include MVC support
  • Include [env] patch: Add experimental splash video
  • Include [env] patch: Enable pvr addons, disable pvr updates
  • Include [env] PR:4500: kodi: update to 17.0
  • Include [env] PR:4537: [scripts] Add PKG_SOURCE_NAME for non-standard package tarballs
  • Include [env] PR:4661: stripping changes
  • Revert [env] 46b9b7b3: rtmpdump (Reason: use newclock5 bump)
  • Include [pkg] PR:7030: CNetwork - implement IPv6
  • Include [pkg] PR:8254: FIX: Only handle 3D bitmap subs in TAB
  • Include [pkg] PR:8645: [video] Add season/TV show artwork to episodes/seasons even if they have their own fanart.
  • Include [pkg] PR:8723: Implement filecache retry logic
  • Include [pkg] PR:8824: videodb: fix smart playlists not honoring "Show empty TV shows" setting.
  • Include [pkg] PR:8922: [guiinfo] extend ranges for listitem properties
  • Include [pkg] PR:9225: Fix out of memory crash in CArchive
Build Highlights:
  1. NOTE: DVD playback remains temporarily disabled
  2. First stab at reinstating stream info in Codec OSD
Build Details:
  1. OpenELEC:
    • redesigned initialization (PR:4823, 1 commit, 2 files changed)
    • Package updates (PR:4824, 5 commits, 7 files changed)
      • projects/RPi/options: support RPi CM and RPi Zero
      • sqlite: update to sqlite-autoconf-3110100
      • openssh: update to openssh-7.2p1
      • connman: add upstream patch to Add missing function item of xtables to match iptables 1.6
    • Package updates (PR:4825, 2 commits, 2 files changed)
      • bcm2835-driver: update to bcm2835-driver-b48c36f
      • bcm2835-bootloader: update to bcm2835-bootloader-b48c36f
  2. XBMC:
    • [EPG] Fix lockup when entering epg grid (endless loop) (PR:9265, 1 commit, 1 file changed)
    • libdvd/Makefile: rename LDFLAGS to SO_LDFLAGS (PR:9268, 1 commit, 1 file changed)
    • Add binary addon InputStream (PR:9173, 12 commits, 45 files changed)
  3. newclock5:
    • New commits in this build:
      • VideoPlayer: overlays, drop AtomicIncrement (fc753af3)
      • drop codecInfo (355ab0cc)
      • VideoPlayer: drop obsolte methods (4eb62322)
      • VideoPlayer: render debug info (472f3b5c)
      • fixup: Avoid seg-fault with null overlay (fc49e3c5)
      • MMAL: use common code for refcounting (12daa0ee)
      • debug: Include drop/skip counts in log (be684f72)
  4. Additional commits/pull requests/changes not yet merged upstream:
    • Added: [env] 6f87cdbb: xf86-video-intel: bump to d167280
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
It doesn't seem possible to turn OFF the CodecOSD with #0305.

Edit: I think if you turn ON the CodecOSD and then stop the video while the CodecOSD is visible, when you restart the video the CodecOSD will be automatically displayed and cannot be switched OFF. Watching a different video somehow resets the CodecOSD state so that it remains OFF when re-watching the original video. Or something like that... it's a bit messed up anyway!
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2016-03-05, 21:41)Milhouse Wrote:
(2016-03-05, 18:28)Trixster Wrote: Running an rpi3 with #0304, anyone else unable to get the inbuilt wlan0 to show up in openelec config network?

Has it ever worked for you with previous builds (since #0229)?

From what you've said, do I assume correctly that you see "Wireless Networks" listed as a category in OE Settings > Network, and have activated the wireless network, but you don't see wlan0 listed in OE Settings > Connections?

Immediately after booting*, run the following commands - you'll need a wired network connection - and post the links:

Code:
vcdbg log msg 2>&1 | paste
dmesg | pastebinit | paste
ifconfig | paste
ls -la /flash | paste

* vcdbg is currently logging a lot of information so if you delay running "vcdbg log msg" the log will rotate and lose any relevant information

No, the wifi on my rpi3 has not been selectable on any builds since #0229

Wireless Networks does not appear as a category in the OpenElec Settings Network tab, there is nothing there to activate like there is with Wired Networks.

Here are the links, in order.

http://sprunge.us/XONY
http://sprunge.us/HaVK
http://sprunge.us/fFKZ
http://sprunge.us/XUXV

I've been using the OpenElec Dev Update prgoram to update to your builds.
(2016-03-06, 01:32)Trixster Wrote: No, the wifi on my rpi3 has not been selectable on any builds since #0229

Wireless Networks does not appear as a category in the OpenElec Settings Network tab, there is nothing there to activate like there is with Wired Networks.

Here are the links, in order.

http://sprunge.us/XONY
http://sprunge.us/HaVK
http://sprunge.us/fFKZ
http://sprunge.us/XUXV

I've been using the OpenElec Dev Update prgoram to update to your builds.

Looks like dmesg didn't make it, however I think the problem is that you're using "dtoverlay=sdhost,overclock_50=100" in /flash/config.txt - try replacing "sdhost" with "sdtweak" and the WiFi (which operates over sdio) should then work.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
  •   
  • 1
  • 94
  • 95
  • 96(current)
  • 97
  • 98
  • 146
  •   



Logout Mark Read Team Forum Stats Members Help
OpenELEC Testbuilds for RaspberryPi (Kodi 17.0)6
This forum uses Lukasz Tkacz MyBB addons.