19 Nov 2019 - TVDB are still in the process of fixing a number of bugs that have broken the TVDB scraper and any add-on that relies on TVDB data. TVDB are still working to rectify the problems.

  •   
  • 1
  • 14
  • 15
  • 16(current)
  • 17
  • 18
  • 146
  •   
  Thread Closed
OpenELEC Testbuilds for RaspberryPi (Kodi 17.0)
(2015-12-18, 21:27)schub Wrote: I think i downgrade to some older version,
for the same test.

Report back if an older version fixes it. We have nightly builds going back months here.
If we can find the build that introduced the problem we can probably fix it.
New OpenELEC K* build #1218: RPi / RPi2
(Supercedes previous build)

Code:
# uname -a
Linux rpi512 4.4.0-rc5 #1 Fri Dec 18 21:48:01 GMT 2015 armv6l GNU/Linux

# vcgencmd version
Dec  8 2015 14:44:44
Copyright (c) 2012 Broadcom
version e591b5eb05e2cdb1b5ae25512b27d33127d7bee9 (clean) (release)

# lsb_release
OpenELEC (Milhouse) - Version: devel-20151218214710-#1218-g3f80ab1 [Build #1218]

# vcdbg log msg 2>&1 | grep DTOK
001710.323: Kernel trailer DTOK property says yes

# Kernel device tree status: Enabled

Based on tip of OpenELEC master (3f80ab16, changelog) and tip of XBMC master (116218d1, changelog) with the following modifications: Build Highlights:
  1. gcc 5.3.0 (clean build)
Build Details:
  1. OpenELEC:
    • Linux: update to 4.4-rc5 (PR:4499, 2 commits, 37 files changed)
    • ffmpeg: update to ffmpeg-2.8.3 (2a06ca0c)
    • gdb: update to gdb-7.10.1 (0cf74174)
    • gcc: update to gcc-5.3.0 (289d1509)
    • nano: update to nano-2.5.0 (f671ea77)
    • eventlircd: fix build with kernel 4.4 (74a46570)
    • mesa: update to mesa-11.1.0 (3f80ab16)
  2. XBMC:
    • [Windows] DXVA deinterlace support for DXVA renderer (PR:342, 2 commits, 9 files changed)
    • AE: fix passthrough for OSX sink (PR:8557, 3 commits, 4 files changed)
    • fixed: leftover kodi prefix in include path (PR:8615, 1 commit, 1 file changed)
    • [PVR] Feature: Separate windows for "Timer Rules" and "Timers" (PR:8561, 5 commits, 30 files changed)
    • [omxplayer] Avoid calling render callback with the lock held to avoid a deadlock (PR:8614, 1 commit, 2 files changed)
    • [rbp] Support advanced deinterlace for 1080i (PR:8611, 3 commits, 4 files changed)
    • reduce padding on dialog buttons (PR:8592, 1 commit, 1 file changed)
  3. pvr.vdr.vnsi:
    • [arm64] - fixed compilation for arm64 (PR:44, 1 commit, 1 file changed)
  4. newclock5:
    • New commits in this build:
    • Commits no longer in build:
      • [rbp] Enable QPU based deinterlace and remove resolution limit (a69ed4a9)
      • [mmalrenderer] experimental: Allow deinterlace with software decode (cf944363)
      • squash: omxplayer: Don't use AutoInterlaceMethod it changes at start of file (27f4c8e0)
      • [omxplayer] Avoid calling render callback with the lock held to avoid a deadlock (db93c87d)
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2015-12-18, 03:27)Milhouse Wrote:
(2015-12-18, 01:47)unclejoe01 Wrote: Is it possible to sync an xbox 360 wireless gamepad to these build? If no is it possible to compile with support?

thanks
joe

I believe it's possible to sync, although the joystick won't work in Kodi on RPi (no xorg, so no SDL) but should work with emulators.


I tried to sync but openelec does not find remote. I go into openelec add-on but it doesn't find remote! Any ideas!
(2015-12-19, 04:14)unclejoe01 Wrote: I tried to sync but openelec does not find remote. I go into openelec add-on but it doesn't find remote! Any ideas!

Probably best to ask for help on the OpenELEC forum while testing with an official release build - this is a testing thread not a general support thread, and your problem is unlikely to have anything to do with these builds.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
please have a look here

something about DVD Menue Problems and sample test dvd
Since the repair of Pandora I have started using Kodi 17 again. However, I have run into a problem fatal to my application.

If I go to the MUSIC menu, go to albums or artists, play a track and switch tracks one or two times, the system hangs. Even the logging display in the top left freezes. SSH will not respond. I have to cut power to recover. A log file is not created. I have not entered any overclock settings. Fan art is enabled.

Has anyone else experienced this problem? I did not have this problem with Kodi 16 releases.

Is there any built in overclocking that may be a problem?

Here is a log file. It does not contain the failure since the hang prevents creation of the log.


http://xbmclogs.com/pj9etwb6k

Bill
(2015-12-19, 22:06)bill_orange Wrote: Since the repair of Pandora I have started using Kodi 17 again. However, I have run into a problem fatal to my application.

If I go to the MUSIC menu, go to albums or artists, play a track and switch tracks one or two times, the system hangs. Even the logging display in the top left freezes. SSH will not respond. I have to cut power to recover. A log file is not created. I have not entered any overclock settings. Fan art is enabled.

Has anyone else experienced this problem? I did not have this problem with Kodi 16 releases.

Is there any built in overclocking that may be a problem?

Here is a log file. It does not contain the failure since the hang prevents creation of the log.


http://xbmclogs.com/pj9etwb6k

Bill

A kodi.old.log might be useful - this is the log from the previous session (ie. the session that froze)
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
New OpenELEC K* build #1219: RPi / RPi2
(Supercedes previous build)

Code:
# uname -a
Linux rpi512 4.4.0-rc5 #1 Sat Dec 19 21:04:19 GMT 2015 armv6l GNU/Linux

# vcgencmd version
Dec  8 2015 14:44:44
Copyright (c) 2012 Broadcom
version e591b5eb05e2cdb1b5ae25512b27d33127d7bee9 (clean) (release)

# lsb_release
OpenELEC (Milhouse) - Version: devel-20151219210328-#1219-g94468b6 [Build #1219]

# vcdbg log msg 2>&1 | grep DTOK
001696.848: Kernel trailer DTOK property says yes

# Kernel device tree status: Enabled

Based on tip of OpenELEC master (94468b6d, changelog) and tip of XBMC master (a654c3da, changelog) with the following modifications: Build Highlights:
  1. New MusicDB schema v58
Build Details:
  1. OpenELEC:
    • audiodecoder.usf: don't build on RPi (PR:4507, 1 commit, 1 file changed)
  2. XBMC:
    • [Win32File] Fix invalid assert expression (PR:8551, 1 commit, 1 file changed)
    • [mysql] Querying optimizer_switch needs to be non-fatal (PR:8545, 1 commit, 1 file changed)
    • CHG: [aml] get player clock to codec via interface (PR:8579, 4 commits, 13 files changed)
    • rework RenderCapture (PR:8613, 2 commits, 13 files changed)
    • Multiply album ratings (PR:8622, 1 commit, 1 file changed)
    • VideoPlayer: return appropriate value for RenderCaptureAllloc in IPlayer - credits to fritsch (31f5ae1b)
  3. newclock5:
    • Commits no longer in build:
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Just noticed that 3d-bluray support isn't working any longer. Tried the latest builds and it's ok until build 1215 (I tried 1210, 1212, 1214, 1215 and it's ok in all of them) and starting with build 1216 it's not working any longer (tested only 1216 and 1219).

Usually I get the menu to choose the playback method, this selection is missing and so the playback is stuck in 2d mode.

Any ideas?


Update 20151220: cannot reprocuce the problem any longer this morning - no idea why it didn't work yesterday....
Well I learn something new every day. Here is the kody.old.log file link.

http://xbmclogs.com/puxpykph5


Bill


(2015-12-20, 00:45)Milhouse Wrote:
(2015-12-19, 22:06)bill_orange Wrote: Since the repair of Pandora I have started using Kodi 17 again. However, I have run into a problem fatal to my application.

If I go to the MUSIC menu, go to albums or artists, play a track and switch tracks one or two times, the system hangs. Even the logging display in the top left freezes. SSH will not respond. I have to cut power to recover. A log file is not created. I have not entered any overclock settings. Fan art is enabled.

Has anyone else experienced this problem? I did not have this problem with Kodi 16 releases.

Is there any built in overclocking that may be a problem?

Here is a log file. It does not contain the failure since the hang prevents creation of the log.


http://xbmclogs.com/pj9etwb6k

Bill

A kodi.old.log might be useful - this is the log from the previous session (ie. the session that froze)
Hello again,
here is the expert answer about my problems with DVD menues:

(2015-12-20, 13:20)doldi Wrote:
(2015-12-20, 13:12)FernetMenta Wrote: Here is a fix: https://github.com/FernetMenta/xbmc/comm...cc0c7a95b5

There are so many things in the old code that only worked by chance. DVDInputStreamNavigator had its own discontinuity mechanism which was wrong and resulted in continuous timestamps going forward even after a seek backwards. Rewind only worked because old dvdplayer did resyncs while rewind that did results in wrong rw speed. That wrong discontinuity mechanism neutralized dvdplayers's discontinuity mechanism that was incorrectly executed while in a DVD menu.

Thank You FernetMenta,
it is possible, that milhouse would put this fix in his new nightly build?
What can i do to integrate self in recent builds?

Harald

@Milhouse
would you be so kind as to put
https://github.com/FernetMenta/xbmc/comm...cc0c7a95b5
in your next build?

THX
Harald
(2015-12-20, 05:33)bill_orange Wrote: Well I learn something new every day. Here is the kody.old.log file link.

http://xbmclogs.com/puxpykph5

Was that captured immediately after a hang? It looks like there was a deliberate shutdown.
(2015-12-20, 13:24)doldi Wrote: would you be so kind as to put
https://github.com/FernetMenta/xbmc/comm...cc0c7a95b5
in your next build?

I've picked it into my tree, so should be in tonight's build.
(2015-12-20, 05:33)bill_orange Wrote: Well I learn something new every day. Here is the kody.old.log file link.

http://xbmclogs.com/puxpykph5


Bill

Debug isn't enabled, but it looks like a normal, clean shut down with no evidence of any hanging - are you sure this is from a time when you had to power cycle?
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2015-12-20, 02:47)nalor Wrote: Just noticed that 3d-bluray support isn't working any longer. Tried the latest builds and it's ok until build 1215 (I tried 1210, 1212, 1214, 1215 and it's ok in all of them) and starting with build 1216 it's not working any longer (tested only 1216 and 1219).

Usually I get the menu to choose the playback method, this selection is missing and so the playback is stuck in 2d mode.

Any ideas?


Update 20151220: cannot reprocuce the problem any longer this morning - no idea why it didn't work yesterday....

There is a problem with the simple Bluray menu.

My playback mode for 3D videos is "Ask me", and with build #1219 I find that, on a fresh start when playing a 3D BD ISO (ie. Train your Dragon, over smb://), I'll be shown the simple Bluray menu on the first play (most times, anyway). The movie starts in 2D mode, and if if choose the Monoscopic/2D mode from the menu, or click "Back" on the remote (ie. Cancel the menu) and then stop the movie, when playing the movie a second (or sometimes a third) time there will be no simple Bluray menu shown - the movie just plays in 2D mode. Restarting Kodi restores the Bluray menu.

However if I choose "Preferred mode (same as movie)" (ie. 3D) on the first play then the Bluray menu is displayed every time the movie is played, so long as I keep choosing "Preferred mode". Once I choose "Monoscopic/2D" or Cancel, the menu stops appearing.

For me, this behaviour starts with build #1205, although in build #1204 there is no Bluray menu shown at all - not even on the first play, so perhaps it's a combination of changes in #1204 + #1205 (unfortunately, that's quite a few).

Build #1203 is the last build that reliably shows the simple Bluray menu on every play.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
  •   
  • 1
  • 14
  • 15
  • 16(current)
  • 17
  • 18
  • 146
  •   
  Thread Closed
 
Thread Rating:
  • 6 Vote(s) - 5 Average



Logout Mark Read Team Forum Stats Members Help
OpenELEC Testbuilds for RaspberryPi (Kodi 17.0)56