•   
  • 1
  • 93
  • 94
  • 95(current)
  • 96
  • 97
  • 146
  •   
OpenELEC Testbuilds for RaspberryPi (Kodi 17.0)
(2016-03-04, 23:46)unix72 Wrote: Hallo, I had Problem with Build 03032016. Android App Yatze (Kodi Remote). I can not use yatze as remote control. Last time (Build 02282016) Yatze works just fine.
yatze could connet to Kodi (Webserver) but no remote function.
is that problem from yatze or from kodi?
with webbrowser there's no problem with remote function
Sorry or my bad english

Yatse 6.0.1 is working normally for me with #0303. Please check that your Kodi Web Server is configured with the same port that Yatse is using. It has a habit of switching back to the old default port 80 from the new default port 8080 when changing between different OpenELEC versions.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2016-03-04, 13:23)popcornmix Wrote: Any 3D fans please test latest version. This has 3D support in libbluray, which means things like audio/subtitle track names should work, and hopefully fix issues with choosing the right files with Pixar movies.
Report if anything is fixed and if anything new is broken.

That sounds great!

Tried 'Brave 3D' and it only plays the introduction correctly - picture changes to black when the main movie would normally start (although the passthrough audio continues to play in the background)

Here's a log: http://sprunge.us/DCbP
(2016-03-04, 18:50)popcornmix Wrote:
(2016-03-04, 17:44)opeters Wrote: 3D MVC MKV dit not work. Movie was playing in 2D. 3D ISO did work however. This was working in the build before. How is 3D MVC detected?

mkv files need to be named correctly (e.g. with .3D.MVC. is filename).
When named correctly they play in 3D. Are you sure yours are correctly named?

No i named them .3DFP.mkv, needed for VTEN. But this seemed to work with previous build. Anyway will rename them and test again.
MY CURRENT MEDIA PLAYER
INTEL DN2820FYKH NUC 2D/3D WINDOWS
ACER HD9500BD / MARANTZ SR7009 ATMOS 7.1.4

(2016-03-04, 13:23)popcornmix Wrote: Any 3D fans please test latest version. This has 3D support in libbluray, which means things like audio/subtitle track names should work, and hopefully fix issues with choosing the right files with Pixar movies.
Report if anything is fixed and if anything new is broken.

Another thing I just noticed - when I start another 3D bluray iso it displays the information that my playback devices do not support 3D mode and so it's played in 2D (the disc/disc menu shows this info).
When I browse the disc and choose the biggest ssif file manually it can be played in 3d - but shouldn't the disc be played in 3D mode automatically?

Here's the log of my attempt to play the disc: http://sprunge.us/BOYe
(2016-03-04, 13:23)popcornmix Wrote: Any 3D fans please test latest version. This has 3D support in libbluray, which means things like audio/subtitle track names should work, and hopefully fix issues with choosing the right files with Pixar movies.
Report if anything is fixed and if anything new is broken.

I played The Martian, and it played just fine. I skipped through a lot to get to the subtitle part, and that didn't have any issues. I did the same with The Walk and everything that I saw looked good, but I didn't watch the whole movie. These are both 3D MVC MKVs.
New OpenELEC Krypton build #0304: RPi / RPi2
(Supercedes previous build)

Code:
# uname -a
Linux rpi512 4.4.4 #1 Fri Mar 4 23:56:22 GMT 2016 armv6l GNU/Linux

# vcgencmd version
Mar  4 2016 17:58:52
Copyright (c) 2012 Broadcom
version 764f403f69e25e8a014c24f8a26f057960331205 (clean) (release)

# lsb_release
OpenELEC (Milhouse) - Version: devel-20160304235529-#0304-g0e31f7f [Build #0304]

# vcdbg log msg 2>&1 | grep DTOK
002463.726: Kernel trailer DTOK property says yes

# Kernel device tree status: Enabled

Based on tip of OpenELEC master (0e31f7f6, changelog) and tip of XBMC master (ae1f6bf4, changelog) with the following modifications:
  • Includes newclock5 patches
  • Excludes the OpenELEC linux-01-RPi_support patch in favour of sourcing these and possibly more recent patches directly from kernel branch rpi-4.4.y
  • Default setting for "Show RSS Feed" changed to disabled (new installs only) [patch details]
  • Disabled "Total Duration" in Confluence (see build #0221 for details)
  • Includes latest bcm2835-driver master (b48c36f7, ahead +25)
  • Includes latest dcadec master (0e074384, ahead +139)
  • Includes latest kodi-platform master (92583ef9, ahead +2)
  • Includes latest libcec master (6d68d212)
  • Includes latest libnfs master (eebe56ce, ahead +10)
  • Includes latest p8-platform master (38343e0a)
  • Includes latest addons: pvr.argustv (501f56b3, +21), pvr.demo (116a172a, +16), pvr.filmon (4beb05da, +23), pvr.hdhomerun (3f0dd8e6, +29), pvr.hts (0814da42, +55), pvr.iptvsimple (1dfc3547, +24), pvr.mediaportal.tvserver (4860e622, +48), pvr.mythtv (44df4430, +25), pvr.nextpvr (1871323c, +23), pvr.njoy (4f30f4af, +16), pvr.pctv (522f9603, +21), pvr.stalker (0402f465, +20), pvr.vbox (b0916449, +23), pvr.vdr.vnsi (2089549a, +21), pvr.vuplus (4cf6ad02, +19), pvr.wmc (9a83292f, +22)
  • Includes commits from service.openelec.settings/, ahead +1 (OpenELEC)
  • Include [env] e7cbe9cb: xf86-video-intel: explicitely disable TearFree and TripleBuffer
  • Include [env] ed774729: Intel: Implement Passthrough-Range
  • Include [env] 2f83a1cf: xf86-video-intel: bump to 8b8c9a36 (fixes segfault when refreshrate changing)
  • Include [env] 3a6268c9: VAAPI: Enable EGL
  • Include [env] 98c65e6a: Kodi: Use Limited Range by default
  • Include [env] 858f6461: xf86-video-intel: bump to 371219c
  • Include [env] compare: ffmpeg: Additional Jarvis 2.8.x patches
  • Include [env] patch: Enable other binary addons
  • Include [env] patch: Reinstate version check service add-on - avoid black screens on x86?
  • Include [env] patch: Add extra headers needed by 3D BD MVC
  • Include [env] patch: Bump libbluray - include MVC support
  • Include [env] patch: Add experimental splash video
  • Include [env] patch: Enable pvr addons, disable pvr updates
  • Include [env] PR:4500: kodi: update to 17.0
  • Include [env] PR:4537: [scripts] Add PKG_SOURCE_NAME for non-standard package tarballs
  • Include [env] PR:4661: stripping changes
  • Include [env] PR:4808: projects/RPi*/patches/linux: Add various options required by latest RPi kernel
  • Revert [env] 46b9b7b3: rtmpdump (Reason: use newclock5 bump)
  • Include [pkg] PR:7030: CNetwork - implement IPv6
  • Include [pkg] PR:8254: FIX: Only handle 3D bitmap subs in TAB
  • Include [pkg] PR:8645: [video] Add season/TV show artwork to episodes/seasons even if they have their own fanart.
  • Include [pkg] PR:8723: Implement filecache retry logic
  • Include [pkg] PR:8824: videodb: fix smart playlists not honoring "Show empty TV shows" setting.
  • Include [pkg] PR:8922: [guiinfo] extend ranges for listitem properties
  • Include [pkg] PR:9225: Fix out of memory crash in CArchive
  • Include [pkg] PR:9265: [EPG] Fix lockup when entering epg grid (endless loop)
Build Highlights:
  1. NOTE: DVD playback remains temporarily disabled
  2. New firmware - try and improve RPi3 temperature reading
  3. New 4.4.4 kernel
  4. EPG grid lockup fix
  5. FFmpeg MVC and SSIF improvements
Build Details:
  1. Firmware (Mar 4):
    • firmware: arm_loader: Improve serial port aliasing See: link
    • firmware: Pi3: Reduce desired ring osc and attempt to make temperature reading more accurate
  2. OpenELEC:
    • gcc: Mark ARMv8 vcvt instructions as unconditional (PR:4816, 1 commit, 1 file changed)
    • Update Amlogic kernel to 3.10-0f60813 (3.10.98) (PR:4814, 2 commits, 2 files changed)
    • Enable SSL for MySQL (PR:4817, 1 commit, 1 file changed)
    • Various $HOME/.openelec (vendor) fixes (PR:4818, 1 commit, 5 files changed)
    • linux: update to linux-4.4.4 (PR:4819, 1 commit, 33 files changed)
    • More $HOME/.openelec (Vendor) fixes (PR:4820, 1 commit, 1 file changed)
    • scripts/image: fix build after https://github.com/OpenELEC/OpenELEC.t… (PR:4822, 1 commit, 1 file changed)
  3. XBMC:
    • Create AppVeyor CI configuration file (PR:9258, 1 commit, 1 file changed)
    • bootstrap.mk pointing to lib/libdvd/libdvdread (PR:9261, 1 commit, 1 file changed)
    • [Win32] Several small fixes. (PR:9263, 3 commits, 3 files changed)
    • bootstrap.mk pointing to lib/libdvd/libdvdread (b5f2ba10)
  4. newclock5:
    • New commits in this build:
      • ffmpgeg: h264_parser: fix parsing of mvc slices in some corner cases (05f8eff3)
      • Revert "ssif: Avoid corrupt images when mvc queue is empty" (db551747)
      • fixup! ffmpeg: use upstream mvc patches (8be5c002)
      • fixup! 3dbd: keep mvc queue as full as possible (e3640cc1)
  5. kernel 4.4.y:
    • New commits in this build:
      • bcm2835-camera: fix a bug in computation of frame timestamp (c5cbb666)
  6. Additional commits/pull requests/changes not yet merged upstream:
    • Added: [env] patch: Reinstate version check service add-on - avoid black screens on x86?
    • Added: [pkg] PR:9265: [EPG] Fix lockup when entering epg grid (endless loop)
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2016-03-04, 16:41)pappaganush Wrote:
(2016-03-04, 09:34)opeters Wrote: That’s unfortunate. Can’t use another backend since only DVBLink works with my current AnySee tuners.
I could be out of place here but maybe this would be the time to switch to TVHeadend?

Good luck getting any vendor to support Kodi, not going to happen in 9 out of 10 cases imho. Just like Hifiberry, they all don't have a budget for it.

As for your problem, TVheadend will take a bit to learn, because it is a little over-engineered with regard to the channel lists. If you can spare
a few evenings of tinkering, it is very very powerful and flexible. Depending on the jurisdiction you are in, using it with oscam and e.g. a USB
smartcard reader might work and might even be legal. Don't discuss here though, use a search engine and a more appropriate site for CA.

Another option might be abandoning linear TV altogether and subscribe to a service like Netflix. There were times in my life when I watched
500 channels and after a couple of months it dawned on me that I wasn't really missing anything by not watching any of them.
Katastrophentourist
Post removed as problem solved:

Router / NAS had decided to connect to each other at 10Mb half-duplex rather than 1000Mb full-duplex..

No software issue at all..
@stourwalk: is #0304 the first build that has this problem?
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
In #0303 the openELEC addon has been added to the main menu, but in the appearance settings of the Estuary skin (which is great by the way) there is no switch to disable as a menu item, please could one be added.
Here are my findings with build #0304 - at first I had the settings to show the bluray menu enabled:
  • libbluray still thinks my devices aren't 3d capable, so a lot of menus aren't displayed because the requirements do not fit
  • when I start one of those affected iso's and press stop it takes about 30 seconds until I get back to the menu, in the meantime everything freezes and no further input is possible >> log http://sprunge.us/ELOR

Finally I've changed my settings to go straight to the main movie - this makes the situation a lot better Smile (although I've to admit that I like menus Smile )

I've started a lot of different images and still noticed a few problems:
  • I noticed that I cannot always reliable skip chapters - sometimes it's loading the new chapter and after finishing the picture doesn't change and playback is halted - log http://sprunge.us/NdMA
  • Special iso 'Edge of tomorrow' - the inverted stereo mode isn't working, changing this settings has no effect on the picture (it works never - but usually I don't need this setting Wink )
  • Tried to play another pixar movie 'Up 3D' and it happens the same as yesterday with 'Brave 3D' >> Disney introduction is played, Pixar introduction is played - and after this the audio continues, but only a black picture. Tried to skip forward, backward chapters or only fast forward a little bit - no chance to get the picture back. Only when I skip back to the very beginning I get the introduction videos again. And after simply listening to the audio + black picture for a few minutes it completely locked up... not even ssh login is possible any more. The screen is frozen and in the debug-information I can see 'MEM:35244/754724 KB' >> so I think it ran out of memory. Reset the pi, repeated the experiment and created a logfile shortly before it ran out of memory again: http://sprunge.us/DVWF
    Screen black, audio plays for a couple of seconds, next also audio stops and free memory is rapidly eaten up until audio comes back and the free memory is allocated at a slower pace again... but nevertheless a couple of seconds later it's gone and the pi completely locks up.
  • Continued with testing my different images and when playing another ony and skipping a few chapters forward + fast forward I ended at the end of the movie? And finally the progress bar says 2:21:38 / 2:06:32 - definitely an invalid position Wink http://sprunge.us/BTXQ - here's a screenshot

Finally I tested playback of AACS protected 3D iso and basically I can play them now Smile Yippie !

Unfortunately all of them are played in 2D mode only - any ideas? >>> http://sprunge.us/UhgP

The progress made during the last weeks is really amazing! Many thanks to Popcornmix and Milhouse for their constant commitment to Kodi Smile
Has anyone else noticed this bug with the user interface, playing 3D framepacked movies.

It might be a bug with the new skin or it highlights the problem.

The first time after a reboot I get screenshot 1 with the user interface rendered at half resolution as expected.

If I then play the same file again, I get screenshot 2 and the icon resolution has been halved again.

Screenshot 1
Image

Screenshot 2
Image

How it looks onscreen (Aspect Ratio Corrected)
Image

Debug Log: http://goo.gl/Bxo3cm
(2016-03-05, 13:36)amediauser Wrote: Has anyone else noticed this bug with the user interface, playing 3D framepacked movies.

It might be a bug with the new skin or it highlights the problem.

The first time after a reboot I get screenshot 1 with the user interface rendered at half resolution as expected.

If I then play the same file again, I get screenshot 2 and the icon resolution has been halved again.

Screenshot 1
Image

Screenshot 2
Image

How it looks onscreen (Aspect Ratio Corrected)
Image

Debug Log: http://goo.gl/Bxo3cm

I get rendering issues only when playing files flagged has Half-SBS or Half-OU. For frame packed movies if i label them .3D.TAB.mkv instead of 3D.HTAB.mkv i get a properly rendered GUI. Try renaming them 3D.TAB.mkv and see if that fixes it for you.
I'm not having that issue. I have them named *3D.MVC.mkv
Running an rpi3 with #0304, anyone else unable to get the inbuilt wlan0 to show up in openelec config network?
  •   
  • 1
  • 93
  • 94
  • 95(current)
  • 96
  • 97
  • 146
  •   



Logout Mark Read Team Forum Stats Members Help
OpenELEC Testbuilds for RaspberryPi (Kodi 17.0)6
This forum uses Lukasz Tkacz MyBB addons.