Thread Closed
OpenELEC Testbuilds for RaspberryPi (Kodi 17.0)
(2016-03-15, 18:24)3DBuff Wrote:
(2016-03-15, 10:48)Vimes Wrote: A follow up to the sound problems with the audio extractor....

I have found that non DTS or DD files will play fine as there is no "switch" to the DTS or DD needed.

.........................

If I play any material with DTS or DD sound I need to do the above if I use Kodi 17 but not any other.

Hope the above helps Smile

It sounds like you got yourself HDMI audio extractor. What type is it?

I have an old non HDMI (back from DVD days) 7.1 high current amp and I had to get one of those HDMI extractors. I bought no name true matrix 2x4 HDMI switch with stereo line out (used for headphone amp) and optical SPDIF audio out to my old receiver. Typically those extractors have 3 settings - 2Ch LPCM, SPDIF (DD, DTS over optical, coax) and pass through to TV. The selector switch or something similar supposed to pass the info to player (Raspberry Pi) to configure the sound properly over HDMI port. Mine is automatic detecting what is connected but it has a button on remote control to cycle through all 3 modes. On occasion (I don't think it's every time) I get the same issue as you described - no sound with DD/DTS. Anything that initialize the player will bring the sound back - "y" on the keyboard and select the player again, force new refresh rate ex. 24Hz from 23.97, disable pass through, or mode change on audio extractor. It's not a major issue but it could be related to the extractor switching or refreshing tags on signal delay or something similar.

The sound quality from my extractor is very good. No distortion or any digital noise from analog line our or optical port compared to Raspberry Pi internal stereo line out jack.

I'm thinking of getting one of those extractors with analog 7.1 LPCM RCA analog out. The similar unit with 4 x 3.5mm jacks analog out burned out when connected to my Epson projector. I had to return it for refund.

This is the one that I have bought....

http://www.amazon.co.uk/gp/product/B00Y0...ge_o00_s00

with the switch you mentioned in the correct position for 5.1 passthrough it plays perfectly DD and DTS with...

Open Elec 6.0.3 with Kodi 15.2
OSMC with Kodi 16
CvH version 7 of OE with Kodi 16

so using the above builds there is no issue at all.

With these Kodi 17 builds that I have tried there are issues with both DTS and DD, as noted in my posts.I take your point about the switch on the extractor but power cycling it or changing the switch position when using these builds does not matter but if I let a DTS file play (silence) and then in the Kodi menu whilst it plays disable and enable again passthough it will then show a Digital data source and play sound, albeit not noted for being DTS and it certanly does not sound right, being a little muffled and not full range, nor 5.1. All the other builds will show DTS on my amp without any messing about.


(2016-03-15, 23:14)Milhouse Wrote:
(2016-03-15, 19:57)Vimes Wrote: mmmm worked my way up to build 218 and yet I would still get a multi coloured screen on first boot after having a working 6.0.3 and then using the update tool to download and update the Pi to the builds suggested to try.

As a side note I have now tried a build of Kodi 16 OE for the Pi and that works great with perfect DD and DTS pickup and playback.

https://www.dropbox.com/sh/0jhy0f3ysok6i...-RPi3?dl=0

I believe they are built by CvH.

Builds prior to #0229 did not include bcm2710-rpi-3-b.dtb so if you've installed 6.0.3 then upgraded to a pre-#0229 build your RPi3 will be using the version of bcm2710-rpi-3-b.dtb installed by 6.0.3 which is for the 4.1.x kernel, this is the cause of the rainbow screen on boot.

Either delete /flash/bcm2710-rpi-3-b.dtb from 6.0.3 before upgrading to a pre-#0229 build - this will disable RPi3 WiFi/BT functionality - or upgrade from 6.0.3 to #0229 (so that bcm2710-rpi-3-b.dtb for the 4.4.x kernel is installed) and then downgrade to a pre-#0229 build, which should boot normally.


Thanks for that and hopefully I will get time to now see if there is a earlier build whih worked with passthrough for both DTS and DD.
  Thread Closed
 
Thread Rating:
  • 6 Vote(s) - 5 Average


Messages In This Thread
RPI 3 no internet access on wifi - by b1m1 - 2016-03-09, 14:44
RE: OpenELEC Testbuilds for RaspberryPi (Kodi 17.0) - by Vimes - 2016-03-16, 09:36


Logout Mark Read Team Forum Stats Members Help
OpenELEC Testbuilds for RaspberryPi (Kodi 17.0)56
This forum uses Lukasz Tkacz MyBB addons.