Thread Closed
OpenELEC Testbuilds for RaspberryPi (Kodi 17.0)
(2016-03-21, 14:15)popcornmix Wrote:
(2016-03-21, 01:57)Milhouse Wrote: [*]"Sync playback to display" now disabled by default

With the last build you'll probably find "Sync playback to display" is disabled.
Historically when "Sync playback to display" is disabled you may get stuttery playback.
This occurs when, by chance the presentation time occurs too close to the vsync.
That results in small amounts of jitter in the timing causing frames to either hit or miss the nearby vsync.
Each time you start, resume from pause, or seek the render time vs vsync changes, so may cause or cure the stuttering.

The last build always blocks until the next vsync before presenting frames. I'm hoping that will avoid the stutter,
but as the occurrence of the stutter is random and fairly rare it is hard to be sure.

Please report if you see stuttering that wasn't in the preceding build. Also report if enabling "Sync playback to display" helps.
Also report if you see any hangs during playback. The method for blocking until vsync has provoked hangs in the past, but I hope I've avoided that with this version.


As I noted before with that enabled I was not getting pass through for DD or DTS. I t took me a while to figure that one out as I would not normally have it enabled.
  Thread Closed
 
Thread Rating:
  • 6 Vote(s) - 5 Average


Messages In This Thread
RPI 3 no internet access on wifi - by b1m1 - 2016-03-09, 14:44
RE: OpenELEC Testbuilds for RaspberryPi (Kodi 17.0) - by Vimes - 2016-03-21, 15:09


Logout Mark Read Team Forum Stats Members Help
OpenELEC Testbuilds for RaspberryPi (Kodi 17.0)56
This forum uses Lukasz Tkacz MyBB addons.