Thread Closed
OpenELEC Testbuilds for RaspberryPi (Kodi 17.0)
(2016-03-28, 22:17)Milhouse Wrote:
(2016-03-28, 14:09)Loc2262 Wrote: I timed it a few times, and with animation it takes 17 seconds from OpenELEC logo to GUI appearing, and without animation it takes 12 seconds. (Kodi splash screen is turned off.) The difference of 5 seconds is roughly the time that the animation is on screen. So it would seems to me that the animation is, at least for the most part, not performed in the background?
I'll need to look at that again, perhaps the systemd service needs another tweak.

This will be fixed in the next build, which should be #0329.

The kodi-splash service is currently running after the kodi-autostart service, and the latter recently (Feb 3) became dependent on the network-online service in order to resolve the systemd mount/reboot issue. So this added a dependency that meant the splash video would not start playing until the network was online, which is totally unnecessary and accounts for the extra delay.

I've reordered the kodi-splash service so that it runs before kodi-autostart, and should ensure the 6 second splash video is fully played out before Kodi is ready on a RPi3. The video is now playing as soon as it possibly can (ie. as soon as the graphical target is available).

Slower devices may experience a short period where the screen is blank after the video has played out, depending on how quickly (or slowly?) Kodi loads and the length of the splash video (too short a video == longer period of blank screen). RPi1 users will probably see about 5-6 seconds of blank screen after the splash video and before the Kodi splash, and could maybe use a longer splash video, eg. 10 seconds. The blank screen period may be as long as 15 or so seconds if the Kodi splash is also disabled.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
  Thread Closed
 
Thread Rating:
  • 6 Vote(s) - 5 Average


Messages In This Thread
RPI 3 no internet access on wifi - by b1m1 - 2016-03-09, 14:44
RE: OpenELEC Testbuilds for RaspberryPi (Kodi 17.0) - by Milhouse - 2016-03-29, 06:10


Logout Mark Read Team Forum Stats Members Help
OpenELEC Testbuilds for RaspberryPi (Kodi 17.0)56
This forum uses Lukasz Tkacz MyBB addons.