Thread Closed
OpenELEC Testbuilds for RaspberryPi (Kodi 17.0)
(2016-03-31, 23:24)herrmeier01 Wrote: Fixing issue with audio and SPI:
Starting with build #0314 SPI and onboard sound of bcm2835 is not working ("aplay -l" shows no soundcard).

Configuration in config.txt is ok
dtparam=audio=on
dtparam=spi=on

I made a lot of tests and found a fix for that issue.

When I copy bootcode.bin, fixup.dat and start.elf from #0313 release to the newer releases example #0330 then everything is working fine again.

The obvious change in #0314 is the switch to dynamic device tree but that is a kernel-only change, and you're not copying the kernel from copying #0313. Although the dynamic device tree changes were in the kernel tree on 13 March they were not included in the #0313 build, as it was felt better to blacklist them until later.

What if you re-install #0331 (ie. latest build) using keeping the #0331 firmware, delete *.dtbo from the /flash/overlays folder, reboot - do you still have SPI problems? You should have just the *.dtb files left in your /flash/overlays folder.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
  Thread Closed
 
Thread Rating:
  • 6 Vote(s) - 5 Average


Messages In This Thread
RPI 3 no internet access on wifi - by b1m1 - 2016-03-09, 14:44
RE: OpenELEC Testbuilds for RaspberryPi (Kodi 17.0) - by Milhouse - 2016-04-01, 02:27


Logout Mark Read Team Forum Stats Members Help
OpenELEC Testbuilds for RaspberryPi (Kodi 17.0)56
This forum uses Lukasz Tkacz MyBB addons.